Skip navigation
This discussion is archived

iCal to iPhone times screwy

3035 Views 12 Replies Latest reply: Sep 16, 2008 8:36 AM by jeremypk RSS
Lougoose Level 4 Level 4 (3,040 points)
Currently Being Moderated
Jun 19, 2008 7:57 PM
Ok. So whenever I sync my iPhone with iCal, the times appear one hour later on my iPhone (an 11:00 appointment shows as 12).

I have already tried syncing with Time Zone Support on for iPhone and iCal, as well as off.

What should I do to fix this?

Thanks!
 2 17" iMac Intel Duos 1GB  2 AEXs  750GB WD HDD  everything up-to-date , Mac OS X (10.5.2),  |512 Shuffle, 2 4GB minis, 1, 2, 8GB nanos, 16GB touch|  2x 8GB iPhone 
  • Allan Sampson Level 10 Level 10 (122,150 points)
    Currently Being Moderated
    Jun 19, 2008 8:22 PM (in response to Lougoose)
    Have you checked the computer time zone selection for your Mac to be sure it is correct?

    System Preferences > Date & Time > under the Time Zone tab.
     PowerBook G4 17-inch/1.67GHz/2GB RAM, Mac OS X (10.5.3), 7200rpm-100GB HD,  iPod w/Video 30GB,  iPhone 8GB
  • Allan Sampson Level 10 Level 10 (122,150 points)
    Currently Being Moderated
    Jun 19, 2008 8:54 PM (in response to Lougoose)
    Do you regularly travel outside of the Chicago or central time zone?

    If not, there is no need to have Time Zone Support enabled with the iPhone.

    Try turning Time Zone Support off on your iPhone, and make sure it is off with iCal.

    Next, do a Reset, which is done by pressing and holding the Home button and Sleep/Wake or On/Off button simultaneously until you see the Apple logo and then release - ignoring the slide to turn off prompt when doing so.

    Next with your iPhone connected, under the Info tab for your iPhone sync preferences below Advanced at the very bottom, select Calendars below "Replace information on this iPhone:"

    Select Apply, and then sync.
     PowerBook G4 17-inch/1.67GHz/2GB RAM, Mac OS X (10.5.3), 7200rpm-100GB HD,  iPod w/Video 30GB,  iPhone 8GB
  • Lawrence Finch Level 7 Level 7 (24,530 points)
    Currently Being Moderated
    Jun 20, 2008 5:44 AM (in response to Lougoose)
    Lougoose wrote:
    Also, by the way, when I deselect Sync iCal Calendars, then sync, the calendars remain there. (This is why I re-downloaded the firmware, then Restored the iPhone, figuring that might help).


    That's normal. It would allow you to have separate calendars on the iPhone and in iCal.
    Lenovo T-60, Intel iMac (x2), Ubuntu 7, iPhone, Windows XP Pro, Leopard 10.5.3
  • Lawrence Finch Level 7 Level 7 (24,530 points)
    Currently Being Moderated
    Jun 20, 2008 11:18 AM (in response to Lougoose)
    If it's exactly an hour difference the most likely scenario is that you don't have the timzeones set correctly. Is the clock correct in the iPhone? Do you have "Set Automatically" enabled in settings/date & time? Similarly for your computer? Every case we have seen of this issue thus far ultimately came down to settings on the computer or the phone not matching.
    Lenovo T-60, Intel iMac (x2), Ubuntu 7, iPhone, Windows XP Pro, Leopard 10.5.3
  • WhiteMule Calculating status...
    Currently Being Moderated
    Jul 27, 2008 12:40 PM (in response to Lougoose)
    I was having a similar issue. Though my iPhone was showing the correct time for my time zone, synced events from iCal all had the wrong time.

    Both the MacBook and iPhone time and date were set to the correct time zone.

    However, on the iPhone when I went into Settings -> Mail, Contacts, Calendars, the "Time Zone Suppport" setting was still set to Cupertino. Once I corrected that and checked the calendar, all times were correct.

    Apparently, the "Date and Time" setting under the "General" section of settings is not tied to the setting under "Mail, Contacts, Calendars."

    Good Luck,
    ~m.
    MacBook, Mac OS X (10.4.11)
  • rcart007 Calculating status...
    Currently Being Moderated
    Aug 15, 2008 9:46 AM (in response to Lougoose)
    Also check your Time Zone settings in your Moble.me Calendar Preferences online! Mine were offset by 5 hours. Mobile.me should have read the settings from my synced computers. Somehow it got set for London Time Zone.
    G5 2.0 DP, MBP 2.33gig 15", Mac OS X (10.5.4)
  • Hanson Calculating status...
    Currently Being Moderated
    Aug 31, 2008 6:35 AM (in response to WhiteMule)
    Hey thanks!
    Problem fixed!!
    MacBook Pro 17", Mac OS X (10.5.4)
  • jeremypk Calculating status...
    Currently Being Moderated
    Sep 16, 2008 8:36 AM (in response to Lougoose)
    I have a similar problem and mine is NOT fixed. I set appointments on my iPhone in iCal and then when I sync to my computer they get shifted back by 3 hours. This is totally annoying and frustrating. And I have checked, both my iPhone and my computer are set to the same time zone (Boston). I have tried resetting the iPhone and it fixed the problem but only temporarily.

    Any definitive suggestions on how to fix this?
    Powerbook G4 1.67 ghz 15", Mac OS X (10.4.9)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.