8 Replies Latest reply: Oct 5, 2008 9:11 AM by Frodo Fraggins
Fistboy Level 1 Level 1 (5 points)
For some strange reason, my iTunes won't let me browse the iTunes store, which is stopping me from buying music and films. When I sign in with my .Mac account details, iTunes shows the 'Connecting to the iTunes Store' Barbers' Pole progress bar and then times out after about 2 minutes with this error:

*We could not complete your iTunes Store request.*
*An unknown error occurred (-50).*
There was an error in the iTunes Store. Please try again later.

I have tried the following steps:

1) Moving ~/Library/Preferences/com.apple.iTunes. aside and logging in again - no change.
2) Deleting keychain 'connect.apple.com' - no change.

If I use a different user account, I can sign into the iTunes Store just fine, but not with my user account.

Does anyone have any suggestions as to the problem, or what I could try next?

Message was edited by: Fistboy

MacBook Pro 17", Mac OS X (10.5.3), Not enough hard disk space!
  • se_brock Level 1 Level 1 (0 points)
    My daughter is having same issue. I can access iTunes from her iMac, but she can not. She receives a msg "We could not complete your iTunes Store request. An unknown error occurred (-50).

    I have tried repairing permissions, turning on/off parental control, and deleting the itune preferences.
  • se_brock Level 1 Level 1 (0 points)
    I found what was causing the error. I used the terminal and look at my daughter's home directory. Her permissions and group ownership were all wrong. instead of group being the short name it was set to wheel and the permissions were set to something like 705.
    to correct this I deleted the short name using 'dscl . delete /users/shortname'
    Where shortname is the shortname of the user. Next I went into accounts and recreated the ID using the same shortname. The system recognized that a directory with that name already existed and prompted me to reuse the directory. I said OK. My daughter's account was recreated and the ownership and permissions on her home directory were corrected.
    Now she can get to iTunes!
  • doctaj1592 Level 1 Level 1 (0 points)
    I don't really understand what that means at all. But I was experiencing the same problem. Whenever I would click iTunes store it would give me that same error. And I have a solution... for now. There's something wrong with the iTunes home page, so all you have to do is avoid the home page. What I did was went to the apple website and clicked on iTunes. Then I just clicked on one of the top songs, which is a link that will automatically open the iTunes store. It worked just fine. But I still can't go to the home page of iTunes. :'(
  • LK2 Level 1 Level 1 (0 points)
    I have same problem -error 50. Repaired permissions - still same problem. Note this problem
    occurred only since installing 7.7. Where are the Apple experts that can solve this problem?
    Two of four partitions work fine. One does not.
    Error note just came up again - says *error in iTunes store*.
    How about fixing it Apple?
  • LK2 Level 1 Level 1 (0 points)
    Note previous message incorrect - my Mac on OS X 10.5.4.
  • LK2 Level 1 Level 1 (0 points)
    doctaj1592? post works just fine. After you get to the Apple iTunes page and pick a song which gets
    you into the iTunes store, just be sure to avoid clicking on the home page symbol which brings up
    the barberpole again. Stay on the music or below level and it works fine. Thanks doctaj.
  • MomGeekSquad Level 1 Level 1 (0 points)
    How do I do this? ie, where can I find permissions and group ownership? Everyone's individual i-tunes store works except my step-son's. I am STUCK!
  • Frodo Fraggins Level 2 Level 2 (330 points)
    se_brock, Did your method hold? Could you give a step by step on your terminal solution? This is really driving me nuts and I don't want to screw the computer up.

    Thanks in advance.

    Frodo