10 Replies Latest reply: Jun 27, 2008 3:33 PM by jsd2
kbruder1 Level 1 Level 1 (0 points)
When I turn on my PowerBook G4, a finder window automatically opens and then freezes, (when I right click on the finder logo, it says: application not responding). I am able to refresh finder, but it continues to freeze and the little spinning ball continues and does not load antyhing. I have left it to run for over 10 minutes and nothing happens.

I can open applications and everything else works normally, but I cannot open a finder window to look through documents, photos, etc.

PowerBook G4 (15in), Mac OS X (10.4.8)
  • 1. Re: Finder Not Responding after booting on PowerBook G4
    BDAqua Level 10 Level 10 (116,475 points)
    Hi, try a Safe Boot, holding Shift key down at bootuo, if that doesn't get you the finder then do these two ...

    "Try Disk Utility

    1. Insert the Mac OS X Install disc that came with your computer, then restart the computer while holding the C key.
    2. When your computer finishes starting up from the disc, choose Disk Utility from the Installer menu. (In Mac OS X 10.4 or later, *you must select your language first.)*
    *Important: Do not click Continue in the first screen of the Installer. If you do, you must restart from the disc again to access Disk Utility.*
    3. Click the First Aid tab.
    4. Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.
    5. Select your Mac OS X volume.
    6. Click Repair. Disk Utility checks and repairs the disk."

    http://docs.info.apple.com/article.html?artnum=106214

    Then boot from the HD, run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions.
  • 2. Re: Finder Not Responding after booting on PowerBook G4
    kbruder1 Level 1 Level 1 (0 points)
    What can I do if I do not have the startup disc? I am working in Peru this summer and do not have it with me, nor am I completely sure where it is located....

    Antyhing I can do to solve this?

    Thanks!
  • 3. Re: Finder Not Responding after booting on PowerBook G4
    BDAqua Level 10 Level 10 (116,475 points)
    Two ways I can see...

    Get a DiskWarrior from Alsoft, you need the CD...

    http://www.alsoft.com/DiskWarrior/

    Or if you had another Mac around...

    FireWire target disk mode...
    http://docs.info.apple.com/article.html?artnum=58583
  • 4. Re: Finder Not Responding after booting on PowerBook G4
    jsd2 Level 5 Level 5 (6,200 points)
    If you already have another account, log into it and see if the problem persists.
    If you don't, try creating a new admin account (via System Preferences>Accounts), log out of the old account and log into the new one. Is the Finder problem still there?

    jd
  • 5. Re: Finder Not Responding after booting on PowerBook G4
    kbruder1 Level 1 Level 1 (0 points)
    I created a new user account, which has solved the finder issue, but I am unable to access any of the documents from my original account (naturally).

    I am fine with this arrangement until I return home in 3 months, but if there is a simple fix/download/something I can do to restore my original account, that would be greatly appreciated!

    Thank you!
  • 6. Re: Finder Not Responding after booting on PowerBook G4
    jsd2 Level 5 Level 5 (6,200 points)
    From the new account, navigate here within the old account's user folder:

    HD>Users>oldaccount>Library>Preferences

    and trash this file: com.apple.finder.plist
    ===========

    Now try logging back into the old account.
  • 7. Re: Finder Not Responding after booting on PowerBook G4
    jsd2 Level 5 Level 5 (6,200 points)
    I belatedly realized that you might not have sufficient permission to do it this way, and I won't have access to my Mac to test things for a few hours. There are other ways to delete the preference file.
  • 8. Re: Finder Not Responding after booting on PowerBook G4
    jsd2 Level 5 Level 5 (6,200 points)
    Yes, now that I'm back home, I see you will indeed need increased privileges to delete the original user's Finder preference file.

    Although it can be done with a single command in Terminal, a typing error there could be disastrous. I think it is safer to take a longer route and log in as "root". You have to be careful there too, but you won't be touching any system files and therefore should be OK. It has the advantage as well that if deleting the preference file doesn't fix the original Finder problem, root can also directly access the photos, music, and documents in the original user's home folder. We can go from there if needed.

    Below is Apple's help documentation on enabling the root user in Tiger. There is an online version [here|http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh1549.html] which you should print out before doing anything. Between step 1 and step 2, click the little lock at the bottom of the NetInfo Manager window and give the current user's password.

    --------------------------------------
    Mac OS X 10.4 Help
    Enabling the root user

    The root user, sometimes called the superuser, is a special user account in Mac OS X that has read and write privileges to all areas of the file system. The root user can move and delete any file in the system, including system files not available to any other user. Because it's easy to damage the computer by moving or deleting some files, use the root account with extreme caution.

    By default the root account is not active.
    To enable the root user:

    1. Open NetInfo Manager, located in Applications > Utilities.
    2. Choose Security > Enable Root User and type a password for the root account. You may need to type an administrator password to make these changes.
    3. Choose Apple menu > Log Out.
    4. Choose Other in the Login window, type root in the Name field, and the root password in the Password field.

    The root user should only be used for specific administration or monitoring tasks. After completing a task as the root user, log out of Mac OS X and log back in using a normal or administrator user account.

    Disable root access if you do not use it often.
    ------------------------------

    Once logged in as root, try the steps given before, namely:

    Navigate to:
    HD>Users>oldaccount>Library>Preferences

    and trash this file: com.apple.finder.plist
    ===========

    Now log out of root ("System Administrator" is root's "long name) and try logging back into the old account.

    If Finder now works, as a last step go back to NetInfo manager and this time use the method above to Disable Root User. If Finder still doesn't work, post back.

    jd
  • 9. Re: Finder Not Responding after booting on PowerBook G4
    kbruder1 Level 1 Level 1 (0 points)
    I was able to follow your steps fine, but they did not fix the finder problem unfortunatly. Using the root account will let me get to my files should work out fine for the summer.

    If there are other simple things you would like me to try I can...but this should see me set until I can get home to my install discs.
  • 10. Re: Finder Not Responding after booting on PowerBook G4
    jsd2 Level 5 Level 5 (6,200 points)
    I can think of a couple more easy things to try while logged in as root:

    1) Again navigate to
    HD>Users>oldaccount>Library>Preferences
    and again trash: com.apple.finder.plist.
    now also trash: com.apple.sidebarlists.plist

    2 Navigate back up to:
    HD>Users>oldaccount
    Rename the folder Desktop to oldDesktop

    Log out of root and try the original account again.

    There are other possibilities too, but these seem to me to be most promising. Perhaps others here have more suggestions.

    If it still doesn't work, and you end up using root to copy files from the original account to the new account, I think there may be some permissions issues to deal with. Let us know if you plan to do this.