14 Replies Latest reply: Mar 3, 2009 11:44 AM by Merged Content 1
mrbofus Level 1 Level 1 (5 points)
I'm not sure if I'm missing something completely obvious, but is there a way to get Spotlight to index a network drive/share/folder?

Thanks in advance!

Mac OS X (10.5.3)
  • 1. Re: Spotlight - index network drives / folders?
    glsmith Level 3 Level 3 (875 points)
    You can, but if the device is not another 10.5 Mac, it's kind of messy. Apple was careful to qualify in the "300+ new features" marketing that you can search any "shared Mac" on your network with Spotlight (http://www.apple.com/macosx/features/300.html#spotlight), not any "shared disk".

    Anyway, you can force Spotlight to index any mounted disk by using the mdutil utility from the command line. Something like this:

    sudo mdutil -i on /Volume/network_volume

    There might be some weirdness with unmounting and remounting the network drive, wrt how up to date the index is kept. You'll have to play around with this. Also, the Spotlight GUI is notoriously bad at not providing complete search results. In your testing, I'd recommend using the command line utility "mdfind", which doesn't seem to have the same problems as the GUI.

    Note that you can also search any network drive via the Finder, however that does not utilize any index -- the search is basically just doing a complete directory tree walk...
  • 2. Re: Spotlight - index network drives / folders?
    Charles Whalley Level 1 Level 1 (70 points)
    That is not the case at all. It states "You can search any connected Mac with Personal File Sharing enabled or a file sever that's sharing its files."

    We too are having this problem.

    Any help would be appreciated.

    Thanks
  • 3. Re: Spotlight - index network drives / folders?
    glsmith Level 3 Level 3 (875 points)
    That is not the case at all


    Yes it is the case. SL won't (by default) index just any network drive (e.g. a server using SMB or NFS), but it will index other Macs connected via AFP, the default protocol used when you turn on Personal File Sharing.

    To make SL index a generic network disk, you can use my instructions above.
  • 4. Re: Spotlight - index network drives / folders?
    baseliner Level 1 Level 1 (0 points)
    Came across this thread since I'm not able to get Leopard 10.5.5 to index a network share of mine. Tried turning indexing on w/ mdutil and it says indexing is enabled but nothing happens in Spotlight. This seems to be a Leopard bug since I'm able to get another computer running Tiger to index the share fine.
  • 5. Re: Spotlight - index network drives / folders?
    baltwo Level 9 Level 9 (60,125 points)
    I'm not certain, but I don't think you can index a volume from both Tiger and Leopard installations. I'd delete the Tiger index using the Tiger installation and then try indexing with the Leopard installation.
  • 6. Re: Spotlight - index network drives / folders?
    baseliner Level 1 Level 1 (0 points)
    That's not the problem. I deleted the index created by the Tiger machine but even after that when I enable indexing on the Leopard machine, Spotlight doesn't start pulsating, no md* process kicks off.. I emailed Apple about this and apparently this feature has been intentionally disabled in Leopard. Here's the reply from Apple (this really ***** btw since I have a lot of OCR'd files that I need to search thru for my research work):

    "We intentionally turned this off for Leopard 'cause it was a problem that lots of people would enable indexing on public AFP volumes and swamp the servers.

    On Leopard we only allow local indexing of network locations via Network Homes and more recently (SL) PodCast Producer has some special SPI.

    Remote indexing via Server Side Search is also a Leopard feature.

    The AFP server needs to be running Leopard for indexing to occur. Leopard supports server-side indexing."
  • 7. Re: Spotlight - index network drives / folders?
    Tom in London Level 4 Level 4 (1,585 points)
    The problem is the index itself. Apple, in its wisdom, has decided that instead of actually searching on drives for what is really there, Spotlight will create an index and search the index.

    Don't ask me why.

    Ever since Apple did that, these forums have been filled with people who can't find their stuff, and with arcane, time-consuming suggestions for tweaking Spotlight to try and make it work.

    There's a better way.

    Don't use Spotlight, just use a much simpler tool, such as FindFile or EasyFind. Either of these two freeware applications will search your actual drives, and will search everywhere - not in an index.

    I hope some of you may find this helps to solve your problems.

    FindFile is here: http://www.versiontracker.com/dyn/moreinfo/macosx/10906315

    EasyFind is here: http://www.versiontracker.com/dyn/moreinfo/macosx/8707
  • 8. Re: Spotlight - index network drives / folders?
    Colin Cohen Level 1 Level 1 (40 points)
    I guess I have a variant on this problem - the issues seems to be Spotlight/FindFile, rather than TimeMachine as I originally thought.

    If I search for any item that happens to be in a folder on the Desktop, or on the DT itself, S and FF do not find the TM copy - which made me think there was a problem with TM. Normally any item I look for will show up twice - on my boot vol and the TM b/u.

    Obviously if there was nothing on the DT it would be no problem, but it is disconcerting to be told that current work is not backed up - and each time I have to enter TM to be sure I really have a copy.

    Is there a fix?

    I get no error messages.
    Cheers, Colin
  • 9. Re: Spotlight - index network drives / folders?
    Muya Level 1 Level 1 (5 points)
    neither of these programs work for me. any other ideas?
  • 10. Re: Spotlight - index network drives / folders?
    Tom in London Level 4 Level 4 (1,585 points)
    you mean you can't run them?
  • 11. Re: Spotlight - index network drives / folders?
    Colin Cohen Level 1 Level 1 (40 points)
    Hi Tom,

    Not me posting this time - but yet another Mac user with the same problem - I assume neither Find file nor Spotlight finding items that are on the Desktop?

    Cheers, Colin
  • 12. Re: Spotlight - index network drives / folders?
    Muya Level 1 Level 1 (5 points)
    No, I can run them and search my hd, but it won't search the connected x-serve. It worked fine in tiger, but I got a new machine and did the transfer assistant. Their are two other machines that are acting the same way, while the other machines on tiger work just fine.
  • 13. Re: Spotlight - index network drives / folders?
    Eric Siegel Level 1 Level 1 (5 points)
    Help please ... I used your command but know my searches come up with 0 items ... is there a way to undo this setting?
  • 14. Re: Spotlight - index network drives / folders?
    Level 6 Level 6 (11,035 points)
    I am in a PC dominated company with Novell and MS based servers where I keep my document files.

    How can I do a search.. even as basic as based on date it was created and file name..

    ghj