3 Replies Latest reply: Aug 16, 2008 7:33 AM by Scott in Melbourne Australia
Brooksy101 Level 1 Level 1 (0 points)
When i got my iphone youtube loaded surprisingly fast, i loaded a 10 minute clip with no problems. Now, for some reason, my youtube struggles to buffer 20 seconds in hours. Can someone tell me why this is? I have a very good broadband so i'm fairly sure that's not the problem, and also youtube won't work anywhere so it's nothing wrong with what im connecting to. Please help me.

Lenovo ;), Windows XP Pro
  • Leone D'Antonio Level 4 Level 4 (1,110 points)
    Brooksys, have you tried powering "OFF" your iphone? Do so by holding the sleep button for like 5 seconds, then swipe to power off.

    let sit for about 20 seconds. Then power on.

    Try youtube. Does it work?

    If it can't connect to youtube.... can you get internet access via Wifi okay? mail okay? safari okay?

    if those all work, then your youtube should also.

    let us know what you find out.
  • Brooksy101 Level 1 Level 1 (0 points)
    Thank you for the suggestion but im afraid it still refuses to buffer. youtube is connected because i can search for videos and it'll show how long the videos are (which is usually an indicator that there is a wifi/edge connection) but it wont buffer past 10% of a video.
    Also the strange thing is my safari works perfectly and the icon displaying what im connected to has full connection to wifi. my dad (who is the boss of a computer programming company) assures me theres nothing wrong with our broadband so i can rule that out. Does anyone have any other suggestions?
    Youtube was one of the main attractions of the iphone too so i'm really disappointed at the moment!
  • Scott in Melbourne Australia Level 1 Level 1 (0 points)
    having this problem too.

    Worked great for first month and now you tube struggles to buffer even the smallest clips when using wifi. Oddly it does work when using 3g (although YouTube seems to automatically reduce the clip screen size when using 3g).

    What's it more strange is my computer using the same wifi connection loads YouTube vids in seconds without any problems.

    All other Internet features work fine on my iPhone with the wifi connection.