6 Replies Latest reply: Sep 3, 2008 3:26 AM by Alias of Mark
XavierZ Level 1 Level 1 (0 points)
Hi all,

I have spent two days trying to set up my new Airport Express, but I am having major issues with connecting it to a wireless router via WEP. I have read hundreds of forums and tried everything but nothing has worked.

Some Information:
1. I can manually configure my Airport Extreme with no problem from a laptop that I have with wireless connection
2. If I set my wireless router to no security, the Airport Extreme works fine.
3. When I enable WEP with a 64 Bit Hex key, and use the exact same key as a 40-bit key on the Airport Extreme, the Airport Extreme won't connect
4. Every other device in my house (PS3, XBOX, AppleTV, Other PC, IPOD Touch) works fine with the 64 Bit HEX WEP Key. Just not the Airport Extreme
5. I have tried adding $ signs to the front of the key
6. I have tried changing to a 64 BIT ASCII key and 128 BIT Hex key, but no luck

My setup is a D-Link DI-524 802.11g wireless router. My PC runs Windows XP.

Would appreciate some help. I have found a few posts with the same sort of setup where people have not had success, so I am wondering if it is time to take the AX back?

Dell, Windows XP, D-Link Wireless Router
  • 1. Re: Airport Express Issues With 64 Bit WEP & D-Link Router
    Tesserax Level 8 Level 8 (48,245 points)
    Hello XavierZ. Welcome to the Apple Discussions!

    One of the problems with WEP is that the actual standard relies on a 10 character HEX key for 64bit WEP and a 26 character HEX key for 128bit WEP.

    In order to make things easier, vendors use certain algorithms to convert simple alphanumeric passwords (or passphrases) into HEX keys, thus enabling the use of simple easy to remember WEP password rather than lengthy HEX keys. The problem is that different vendors use different algorithms to generate the HEX key and therefore an ASCII password on an AirPort base station will be hashed differently on a non-Apple client and vice versa.

    When connecting a pre-OS X 10.2 AirPort computer to a non-AirPort base station, you must precede the hex key with a “$”, or enclose a ASCII key with double quotation marks (“”). The “$” sign tells AirPort that you are sending the WEP keys directly, and that it doesn’t need to translate the password into its WEP equivalent ... but this shouldn't apply with your AirPort Express Base Station (AX).

    You may find the following articles helpful:
    o Accessing a Airport Network with a Windows XP PC or laptop (with XP SP2)
    o Apple article, especially the part about "Third-party client to Airport".

    Also, when generating the WEP key on your D-Link, make sure that you only use Key 1. Keys 2-4 will not work.

    Finally, two things I suggest:
    o Use WPA or WPA2 instead of WEP as WEP is no longer considered secure.
    o If you must use WEP, use a 128-bit HEX key instead of ASCII.
  • 2. Re: Airport Express Issues With 64 Bit WEP & D-Link Router
    David Chess Level 1 Level 1 (5 points)
    We're having pretty much exactly this same problem: brand-new Airport Express, 64-bit WEP on the house wireless with a hex key, everything in the house works great, even the previous Airport Express worked great until it broke. But the new Airport Express won't join the house wireless network whether I give the hex key straight, or start it with a $, or with "0x". In my case the wireless device is a relatively old Linksys, but that shouldn't matter.

    Again, this worked perfectly with the previous Airport Express. I suspect that either the new Airport utility or the Airport Express firmware itself no longer properly recognizes the $ or the straight form of the hex password. Either there's some bug, or the secret undocumented $ technique has been changed to something else that I haven't tried yet. Maybe % or ^ or * or...

    Any help would be greatly appreciated!
  • 3. Re: Airport Express Issues With 64 Bit WEP & D-Link Router
    David Chess Level 1 Level 1 (5 points)
    P.S. I briefly turned security off on the home wireless network, and then the Airport Express worked fine. So it must be that it's for some reason not using the right password.
  • 4. Re: Airport Express Issues With 64 Bit WEP & D-Link Router
    XavierZ Level 1 Level 1 (0 points)
    Thanks for the post above, but the connection is still not working when I enable WEP. I have tried both 64 BIT and 128 BIT HEX keys. I am using only the first line in my D-Link WEP setup for the keys.

    I thought I would give an example of the type of keys I have tried:

    FADFADFA66
    $FADFADFA66
    FADFADFA660000000000000000
    $FADFADFA660000000000000000

    The first two are when I was using 64 bit HEX codes, and the last two were at 128 BIT.

    Is there something I am missing? Could the Airport Express have some sort of case sensitivity for example, or do new models with new firmware simply not work with WEP and non-apple routers?
  • 5. Re: Airport Express Issues With 64 Bit WEP & D-Link Router
    David Chess Level 1 Level 1 (5 points)
    I've now tried

    1234567890 (not the actual key, but you get the idea)
    $1234567890
    0x1234567890
    #1234567890

    and none of them have worked. Still suspecting some bug in either the utility or the Express firmware (don't know where the translation is done) that prevents hex keys from getting configured into the Express correctly.
  • 6. Re: Airport Express Issues With 64 Bit WEP & D-Link Router
    Alias of Mark Level 1 Level 1 (5 points)
    Alright you guys, I have something you should check out and try. !http://discussions.apple.com/images/emoticons/happy.gif!

    Holding down the option-key while choosing the Network from the AirPort Menu Bar Item (top right area of the "Apple Menu Bar") should allow you to enter the 64 hexadecimal character pre-shared key. !http://discussions.apple.com/images/emoticons/shocked.gif!

    Check out Apple's short article on the matter: [AirPort: How to enter a 64 character hexadecimal Pre-Shared Key for WPA|http://docs.info.apple.com/article.html?artnum=108093|Apple Support Article 108093] !http://discussions.apple.com/images/emoticons/grin.gif!

    Hopefully, that helps. !http://discussions.apple.com/images/question-assumed_resolved-16x16.gif! You may want to try the different variations of "expressing" hexadecimal characters when connecting to your networks like above.