7 Replies Latest reply: Jul 29, 2008 1:50 PM by Karyn Linehan
illustrationism@gmail.com Level 1 Level 1 (0 points)
My CD/DVD drive works just fine. Except when I try to put in a Playstation game (PS1). It whirs, makes 3-4 reading "sounds" (sounds like the reader arm moving), then spits the CD back out without the OS recognizing it.

This happens when I'm booted up in Windows (boot camp) too.

Interesting thing: A friend who bought a 17" Macbook Pro (same model, same time) does not have this problem. We put it in her Macbook Pro, and it read the CD just fine.

Any thoughts? Software / hardware upgrades I could perform?

Macbook Pro, Mac OS X (10.5.3)
  • Abhss Level 1 Level 1 (0 points)
    Hi,
    I have just started to experience the same problem.
    I put any CD into my superdrive and it makes the reading noise and spits is straight back out.
    I have had this MacBook pro for just over a year.
    Is this a major problem?
    Because i'm trying to install my Time Capsule software and obviously cannot.

    Abhss
  • Leon Yandel Level 1 Level 1 (0 points)
    @illustrationism: What model is your MacBook Pro and what is the Superdrive Model? From the sound of it, it seems like the same problem I have. I have a MacBook Pro 3,1 Intel Core 2 Duo 2.4 GHz (June '07) and my superdrive is a Matshita DVD-R UJ-85J.

    A few months back there was a firmware update (2.1) which in fewer-than-more words, screwed up all our MBP's, at least the ones with certain superdrives. If you check out this thread, http://discussions.apple.com/thread.jspa?messageID=7018290&#7018290 there is a long discussion on the topic, at the time when this first occurred with me, I tried the flashing processes to no avail, but it looks like there's another take on it recently.

    If you are unsure of your Superdrive Model, you can open System Profiler by going to Applications/Utilities and look under "Hardware -> ATA". The above link I believe also has a good collection of known Models with issues from that firmware update.


    @Abhss: From the sound of it, you're suffering from the same firmware issue as illustrationism. I've had this issue for about two or three months now and I've come across a couple things to help me get by when I need to with CDs/DVDs that my MBP won't read. If you have access to another computer, whether its a PC or Mac, put the CD/DVD in and make an image of it. For Windows, MagicISO and PowerISO should work fine, if it's another mac you can just use Disk Utility.

    Once you have an image, if its a networked computer you can just transfer it over, mount it, and install, if not, try an external hard drive, or get a USB drive and split the file into parts if your USB drive cannot hold the entire image at once.



    And on a side note: If you're burning discs, be careful of which brand you get. Since the firmware update I've tried several different brands, but now I only buy Verbatim DVD±Rs. I've also asked in a few stores- explaining to an employee that my DVD drive is sensitive and not all discs work - if I would be able to return a pack for a refund after trying a disc (DL's can be expensive, I wanted my money back if it didn't work ^^;) and so far no place I've been to has denied me.
  • illustrationism@gmail.com Level 1 Level 1 (0 points)
    Thanks for the help. I believe it's just the version of the disc drive that I have. I'm still on firmware 1.4, not 2.1 (like the people having the problem). My guess is that there's just a problem with it.

    External CD drive, here I come...
  • cp.tar Level 1 Level 1 (0 points)
    OK, this happens to me as well.

    To be more accurate, it only happens with certain CDs — e.g. one Windows install CD, Diablo 2 Install CD… yep, only install CDs so far (for instance, Diablo 2 Play CD mounted just fine; crisp new, too).

    When I put it in, it makes some whirring noises (some are even a bit unusual) and spits the CD out.

    My MacBook Pro is 2.33 MHz Core2Duo, with the following Superdrive:
    MATSHITA DVD-R UJ-857D:
    Firmware Revision: KCVB

    I would very much like to fix it before my warranty expires.
  • Daniel Muratov Roizman Level 1 Level 1 (0 points)
    I have successfully restored the firmware on a UJ-857 that was hosed following the infamous Apple Superdrive Firmware Update 2.1, thanks to the procedure & flashing utility posted by "ben11" on http://forum.rpc1.org/viewtopic.php?t=42953&sid=7a19b1238543a5e4a43d12770bbd27c1
    Please read the instructions carefully before proceeding.

    Hello,

    After some private message exchanges it seems I was able to help some people in this situation (inclduing the original poster). I wrote a simple utility to perform a very basic flash to the drive - doing that may be able to recover the situation, but my flash utility performs almost no checks and is generally much more basic than the framework which, for example, the standard Apple Superdrive updaters have used.

    So, if your drive is in a similar situation this may be able to help. But only try if you feel you've exhausted every other possibility, such as having the drive replaced. This flash process may not work for you, or in the worst case it could conceivably leave your drive is a worse state than before. It is of coursed not endorsed by anybody, in particular not Apple nor the drive manufacturer (or anybody at rpc1.org either).

    As I wrote, compared to the standard updaters this utility makes few checks on the drive status - so unless your drive has really lost its standard operating firmware, often because of an interrupted flash, don't use this rather than a more featured updater.

    Simple flash utility archive:

    http://rapidshare.com/files/57312123/SimpleFlash.zip.html

    There is the terminal based utility (and source code) - along with copies of the HAEA, HBEA, KBVB, KCVB (RPC1 patched) firmwares for the UJ-857 and UJ-857D.

    Basic Instructions
    You need to download the "SimpleFlash.zip" file, unpack it and then run it using the terminal. e.g. assuming you have downloaded the archive file to your desktop you can unpack like this:

    ben11s-computer:~ ben11$ cd Desktop
    ben11s-computer:~/Desktop ben11$ unzip SimpleFlash.zip
    ben11s-computer:~/Desktop ben11$ cd SimpleFlash

    to use the utility you start it using ONE of the following commands:

    ./simple_flash 0 UJ857-HAEA-MBP-rpc1.dat

    or

    ./simple_flash 0 UJ857-HBEA-MB-rpc1.dat

    or

    ./simple_flash 0 UJ857D-KBVB-MB-rpc1.dat

    or

    ./simple_flash 0 UJ857D-KCVB-MBP-rpc1.dat

    (choose according to the firmware you need, see below)

    It will prompt you to answer if you want to continue - to which you can type 'yes' or 'y', if you want to go on. The flash should start and will take about 30 seconds after which the utility should say "Finished". At this point I recommended you restart your Mac. If all has gone well your drive should be responding again.

    Choosing the Firmware
    The firmware included are the ones that the "Apple Superdrive 2.1" update offered for Matshita drives - except the ones in this archive have RPC1 patches. If you don't want RPC1 you could go back to standard firmware using the updaters posted in other threads on this forum after your drive is responding again.

    In principal the utility would also flash other matshita UJ-8xx drives, but suitable firmware data files are not included for them.

    HAEA, HBEA are for UJ-857
    KBVB, KCVB are for UJ-857D

    If your drive previously had:

    HAC1 or HAE4 use HAEA
    HBE4 use HBEA
    KBV9 use KBVB
    KCV9 use KCVB

    If you don't know the previous firmware revision you had then: As far as I know firmware revisions HAEA & KCVB are used in the Macbook Pro, HBEA & KBVB are used in the Macbook. Choose according to which model of mac and which model of drive you have.

    The optical drive should not accept a firmware corresponding the wrong drive model, but for a given model the various revisions may have slight differences, perhaps because of different physical constraints on the hardware - so try to pick the appropriate revision.

    Good luck.
  • cp.tar Level 1 Level 1 (0 points)
    I tried this the very same day I posted my problem (another poster above recommended it), thinking it couldn't possibly hurt.

    Really, it didn't.

    After flashing, nothing happened. OK, that was kind of expected — so I rebooted.
    Nothing happened.

    So I took it to an Apple store yesterday to have it fixed, and I even brought the CDs I've had problems with. Needless to say, the mere act of bringing the laptop to the store made it all work.
    As the guy in the store told me, rebooting in this kind of situation may not be enough: you need to power it down, remove all power sources and let it rest for 10-20 minutes, to reset completely. Which is what my bringing the machine to the store accomplished.
  • Karyn Linehan Level 1 Level 1 (5 points)
    Do I need to buy a new cd drive? Or any suggestions I can do for troubleshooting?