4 Replies Latest reply: Sep 25, 2009 2:52 PM by Horness
Horness Level 1 (10 points)
I'm trying to sync my iPod Touch 32Gb (which has been working perfectly) with my Mac Pro, and I'm getting the following message

"itunes could not connect to the iphone because an invalid response was received from the device"

SCREENSHOT
http://www.horness.com/mac/ipoderror.png

Both the iPod touch and iTunes are at the latest version as of Monday, but now it will not connect/sync.

Any idea's what caused this, and how to resolve it?

Thanks
Horness

2.2Ghz MacBook (4Gb RAM) + 2x 3.2 Xeon MacPro (16Gb RAM), Mac OS X (10.5.3), iPod Touch 32Gb
  • Thomas Hunt Level 1 (15 points)
    I have been have the exact same problem with my iPhone 8gb, I hav etried resetting sync history and using a different cable and usb port, but have been unable to resolve it.

    Anybody else suffering from this, or have a solution?

    Thanks
  • Horness Level 1 (10 points)
    Thomas, I found this after doing a google search for "ipod touch reset"

    http://support.apple.com/kb/HT1394

    The third option (below) worked for me.

    "...turn off iPod touch and turn it on again. Press and hold the Sleep/Wake button on top of iPod touch for a few seconds until a red slider appears, then drag the slider. Then press and hold the Sleep/Wake button until the Apple logo appears"

    I hope this, or one of the other solutions work for you.

    Horness
  • akpda Level 1 (0 points)
    I was having the same problem and tried some of the tips listed in the thread. When I was asked to update someone else's iPhone at my computer, and it connected without a problem, I investigated the differences. Found out that my device was in Airplane mode. When I turned the cellular radio on, it worked! (iTunes was able to connect to and update the device). Go figure that you have to have a cellular connection to make it work?!? Hope this helps!
  • Horness Level 1 (10 points)
    Worked after restart. Thanks.