9 Replies Latest reply: Jul 8, 2008 8:32 PM by JPWG
JPWG Level 1 Level 1 (0 points)
Please somebody tell me, before I lose my freakin' mind, how do I stop icons in the dock from bouncing? I know all about the "Animate opening applications" in System Preferences, but the bouncing occurs when my attention is required of an application, for example, if I download an application and it needs to be mounted. Please help rid me of this most intrusive, unwelcome Windows-esque annoyance.

iMac 20" 2GHz Intel 1GB , PowerBook G4 15.2" 1.5 GHz 2GB, Mac OS X (10.5.2)
  • orangekay Level 5 Level 5 (4,085 points)
    Then how will you know when an application needs your attention?

    As far as I know there's no way to do this. If that single bounce newly downloaded items engage in is truly that obtrusive for you then you can simply remove your downloads folder from the dock altogether.
  • JPWG Level 1 Level 1 (0 points)
    Perhaps you are new to Mac, and as a result are unaware that when an application wants your attention, it is not a matter of a "single bounce" as you incorrectly quantified it. The icon will bounce until it receives attention. And as far as knowing when my attention is required, well, it's not like the life of my entire system is contingent upon my diverting my attention to a newly downloaded file that needs to be mounted – if you can understand this.

    Thanks for your efforts, however.
  • dechamp Level 4 Level 4 (3,495 points)
    There is at least one program that says it can turn off the bouncing icons on the dock, but it's costs $20 and has a free trial - http://www.koingosw.com/products/macpilot.php

    Perhaps you can find more information with Google. I haven't personally fixated on a bounce (or many bounces) yet, but I guess there are other things about this OS that irritate me.

    Since this is a feature you don't like, you'll have to complain to those that can do something about it: http://www.apple.com/feedback/macosx.html

    Incidentally, I found out on Google that you can minimize the number of bounces for some applications by hiding your Dock. This doesn't work for all bounces.
  • orangekay Level 5 Level 5 (4,085 points)
    If you can understand the fact that these bounces are deliberately requested by application code then perhaps you will find a way to spare us the lashings of your rapier wit and contact whomever is actually responsible for producing whatever application you have running that erroneously posts these NSCriticalRequests in response to the completion of a simple file download and ask them to correct this behavior to better suit your highly refined aesthetic sensibilities. Safari certainly does nothing of the sort, and I'm hard pressed to think of any other currently shipping Apple product that might, so your complaints and your consummate arrogance are misdirected at best.
  • JPWG Level 1 Level 1 (0 points)
    Have I even once mentioned Safari as the source of the problem? Perhaps you can have an adult read my posts to you, o little orangekay. Oh, and your bit about "spare us the lashings" I do not believe that I have riposted any other than you (again, try having a non-neanderthol read my posts to you, slowly). As Nietzche once said: "If you cannot hit the nail on the head, please do not pick up the hammer."
  • JPWG Level 1 Level 1 (0 points)
    Thanks for your detailed help with this, dechamp; this is good advice. I certainly think $20 is worth eradicating this annoyance.
  • red_menace Level 6 Level 6 (14,845 points)
    Except for AppleScript (that thing bounces dialogs all over the place), I also can't think of any other applications that do that (including Safari). If an AppleScript is the source of the problem (you didn't mention what was), then perhaps a rewrite is in order.
  • JPWG Level 1 Level 1 (0 points)
    Thank you, red_menace for this information. I actually use Camino for my browser, and I don't know a whole lot about AppleScript, but I will do a little reading about such.
  • JPWG Level 1 Level 1 (0 points)
    I am delighted to discover that OnyX has a setting which disables this feature.