4 Replies Latest reply: Jul 16, 2008 5:16 AM by DHFelder71
DHFelder71 Level 1 Level 1 (0 points)
Hey everyone. Just got a Mac about a week ago and I'm having problems uploading directly to YouTube. I have my video created and go to Share -> YouTube. I then fill out all my settings and it creates the movie. The status bar then shows "Getting Upload Location..." for a second or so and then I get a pop-up saying "YouTube reported an unknown error". No mention of bad passwords or any other issues. I've tried it off and on for 24 hours without any luck. Additionally, I've messed with the various settings for YouTube and even created a new YouTube account, but no luck. It doesn't even seem like the communication to YouTube is there, but I can access the Internet and YouTube fine through Safari. Any ideas?

Also, I've noticed that the YouTube upload window appears to be different than what the tutorials show. The tutorials show you having to authenticate your account through Safari and then the password is saved. However, the screen that I have just has you entering a user name and a password without any authentication. Is this how it should be? Thanks for any help.

Adam

iMac 2.8GHz Core 2 Duo, Mac OS X (10.5.4)
  • Winston Churchill Level 10 Level 10 (88,680 points)
    Welcome to the  Discussion Forums.

    How long is your movie.
  • DHFelder71 Level 1 Level 1 (0 points)
    Thanks for the welcome. I've tried two movies. Each were under 2:30 minutes and when I actually generate them as Medium, they are less than 25 MB so I can't imagine there is a problem there. Like I said, it doesn't even try to upload. It says it that thing about the upload server and within a second, I have the unknown error. Makes no sense to me, and I can't seem to get decent results just taking the movie and uploading to YouTube directly.

    One more thing I figured out...if I enter a wrong user name or password, it will give me an error based on that. But a correct user name and password gives me the unknown error.

    Hopefully someone will be able to help me out or the problem will resolve itself, but it sounds like plenty of people are getting through without an issue.
  • DHFelder71 Level 1 Level 1 (0 points)
    Anyone have any ideas? A week and a half later, still having the same issue. Thanks for any help you can provide.
  • DHFelder71 Level 1 Level 1 (0 points)
    Hey everyone. Just thought I'd write back and say my issue has been resolved. As far as I can figure out, the issue was my YouTube password. Previously, it had some characters that iMovie just didn't want to resolve or something. I changed it all to numbers and letters and now YouTube uploads work fine. Kind of weird but glad to see it working.