12 Replies Latest reply: Oct 28, 2008 1:43 PM by Frederic Denis
Mark Brindle Level 1 Level 1 (55 points)
Using disc utility to make a mirror of 2 drives, click create and i get kernel panic and have to power off machine. if i try to start the machine with either of the two disks in it (together or individually) i get same kernel panic and have to power off.

The disks are in an external storage array (sonnet d500). I have a second storage array with raided disks in and i have raided disk inside the mac too. these all work fine..

originally 2 weeks ago i had the 2 disks working in a group of 4 disks set as a mirror of 2 striped disks. One disk in this setup failed and with this config you can never 'recover'or rebuild it - you get a degraded mirror and you can backup the data, but you must completely rebuild the raid again as the mirror of stripes never lets you add a new disk in again.period. not good.

I replaced the failed disk and rebuilt the mirror of stripes. this lasted a day until a second disk failed (all 4 were bought at same time so i was kind of expecting that to happen once one failed).

i replaced the second faulty hdd and thought about my disk usage and decided i would not make another mirror of stripes and i would make 2 mirrors instead for safe-ish storage and then transfer data to a striped raid set for editing from instead of direct from the mirror of stripes volume.
i tried to delete the raid but got a kernel panic

if i started the machine with any of the 4 disks i would get a kernel panic.
i moved the disks one by one into an older G5 running Tiger and managed to erase the raid info on 2 of them. The two new ones had some strange raid info and the Tiger machien thought there was an extra disk in the machine and would not erase or partition or allow me to destroy the raid whatever i tried.
I will be moving these now into an old XP PC to try to erase the boot records etc and erase them to be able to use them again in either mac pro or G5. painful..
so.. i ended up with 2 erased drives and have 2 new drives with dodgy raid info that causes kernel panics on the leopard machine and wont go in the Tiger machine.

The two erased drives are what ive now been trying to use in the mac pro to create a mirror - this now caused kernel panics when creating the mirror to start with and when installed in the machine at all. so i will be erasing them again in the tiger machine soon (its busy erasing with zeros another new disk that i added to the Tiger machine 2 weeks ago which seems to have some fault when raided!!! but thats another story).

so.. is anyone else having problems with creating basic mirror in 10.5.4 or is it just me??

i have a sonnet tempo e4p card with 2 external sata disk enclosures, latest firmware for the e4p card. all other previously existing raid volumes are working fine. i have one set of 2 striped disks, one set of 3 striped disks and one set of 2 stripes which are mirrored - all happy and working fine. but i cant make a new mirror of 2 disks...

I phoned Apple support and they said all raid info was kept on the disk itself and nothing on the actual machine and suggested i take the machine to an apple care centre for some tlc (although its disk i am having a problem with). since all my other disk arrays work fine i don't really want to rebuild the whole machine from scratch if i can avoid it.

Any suggestions of what i can try ??

Macpro 8core 3Ghz 8gb, g5 ppc dual 2.5ghz, macbook pro dual intel 2.3ghz, Mac OS X (10.5.4), tiger on ppc macbookpro
  • 1. Re: RAID mirror with software utility caused kernel panic every time
    The hatter Level 9 Level 9 (58,880 points)
    I think I read/scanned your post, but the things I looked for:

    That you checked and have the latest Sonnet Firmware; that Sonnet does have either problem with, or recommends against, using some models of drives and in all cases recommends using RE or RAID or Enterprise editions.

    Bad block(s) - one thing that SoftRAID and Disk Utility does is to test the sectors used by the partition tables during create.

    Also now with Leopard, Disk Utility I find has to be relaunched when I create multiple arrays or partitioning. I have some drives I partition first, then combine those partitions across all the drives.

    Ideally your drives should all be tested individually first. Some go so far as to zero or test each and insure that they work and that they have identical read/write patterns (some models or makes can vary wildly from drive to drive which can also cause problems in performance or down the road).

    I would consider SoftRAID. A much better tool for mirrors than Apple's, for stripped arrays both or either (SoftRAID lets you do things Apple's won't, too).
    http://www.softraid.com has demo and pdf manual you might want to check.
  • 2. Re: RAID mirror with software utility caused kernel panic every time
    Mark Brindle Level 1 Level 1 (55 points)
    yes my 'other' raid problem on the G5 has a disk which i am currently erasing with zeros to try and ensure bad blocks are not causing the problems that one has. thats using a G5 jive enclosure inside the G5. caused a few issues when 2 mirrored disks together - disk earrier and disk util saw no problems with it, but a couple of video files seemed to be corrupted and if they were accessed they would cause the machien to hang completely. running on degraded raid allowed me to find the bad files, but disk util cant rebuild the mirror now so im doing write test to see if 2nd disk is faulty itself (both brand new 1T enterprise disks).

    i will check the mac pro disks in terms of types of disks. i know i was very careful with the first 8 i bought, but now trying to find the same 500gb discs is virtually impossible as hdd sizes have grown, so i know i have different ones then the existing disks. its possible this is the cause.

    I will give softraid a go and see if its any better but i will check disks out first..
    ta
  • 3. Re: RAID mirror with software utility caused kernel panic every time
    The hatter Level 9 Level 9 (58,880 points)
    Check out the Sonnet downloads page
    http://www.sonnettech.com/support/downloads/computercards.html

    and support notes:
    http://www.sonnettech.com/product/temposatae4p.html

    Hopefully it is just Leopard compatibility and new driver can solve.

    I know people use to buy one or two spare drives in the past, just to make sure they had matched sets if one of them failed.

    But of course drives keep getting cheaper, faster and sometimes it is time to retire a drive from primary use to some form of backup duty.

    WD is getting ready to bring out their 3rd generation RAID series (RE3) while capacity keeps growing (and getting faster, so even one drive has a max sustained IO of 90MB/sec).

    I have some MaxLine Pro 500GB I picked up from OWC. Now I wish I had one or two more, they are 'okay' as individual drives, but really seem to shine when used in an array - something I was surprised to find out.

    Speedtools from Intech is one utility that can map out bad blocks. I once had to do a 7-way erase to fix a drive (zeroing didn't) and SoftRAID you can start and stop a zero operation, which I would not feel comfortable doing with Disk Utility.
  • 4. Re: RAID mirror with software utility caused kernel panic every time
    Mark Brindle Level 1 Level 1 (55 points)
    i thought id put the latest sonnet firmware on both machines but after re-doing fw on the older G5 non-intel machine the raid rebuild 'seems' to be going ahead. id done a long zero erase on one of the new drives before that and had no errors. That machine has a tempo x4p and a 4+4 card too as i used to have the G5 jive and external disk enclosures on that before i got the mac pro. Oh its just failed again. I will chase that one up again with Sonnet tech support.

    ive now got a copy of the speedtools and am having a check through drives on the mac pro to see if any bad blocks can be found..
  • 5. Re: RAID mirror with software utility caused kernel panic every time
    Mark Brindle Level 1 Level 1 (55 points)
    well it turns out the new disk i bought just werent any good. my g5 powermac raid mirror issue was related to one new disk with lots of bad blocks (speed tools showed that up) so i have learnt my lesson on cheap non raid disks for raid..
    am waiting on a couple of new ultrastar enterprise disks to tuen up so i can go back to the macpro and try to add a mirror again.

    i am still stuck wih several new disks that i cannot format now in the macpro on leopard or on the g5 powermac with tiger.
    ive tried softraid and that cant do it, speedtools pcformat util cant do it, disk utility crashes when i try to eras them and diskutil from termianl starts then doenst get anywhere and my pc sata card doesnt work so my last resort pc option still doesnt help me clear the partition map on these drives - ones that diskutility on leopard made for me - and drives which still cause kernel panics on the macpro if i put them in it..

    here is what diskutil says on my g5:
    /dev/disk0
    #: type name size identifier
    0: GUIDpartitionscheme *465.8 GB disk0
    1: EFI 200.0 MB disk0s1
    2: Apple_RAID 465.4 GB disk0s2
    3: Apple_Boot 128.0 MB disk0s3
    /dev/disk1
    #: type name size identifier
    0: Applepartitionscheme *233.8 GB disk1
    1: Applepartitionmap 31.5 KB disk1s1
    2: Apple_HFS Macintosh HD 233.6 GB disk1s3
    /dev/disk2
    #: type name size identifier
    0: *465.4 GB disk2
    /dev/disk3
    #: type name size identifier
    0: Applepartitionscheme *931.5 GB disk3
    1: Applepartitionmap 31.5 KB disk3s1
    2: Apple_HFS backup1T 931.4 GB disk3s3
    /dev/disk4
    #: type name size identifier
    0: Applepartitionscheme *931.5 GB disk4
    1: Applepartitionmap 31.5 KB disk4s1
    2: Apple_HFS tempi 931.4 GB disk4s3


    disk0 is the one with the bad partition info.
    it thinks it has a double raid as the console shows on startup:
    (both store45 and cache it thinks are on this disk - cache was my old mirror of stripes set on other machine, store45 was new name for my mirror, so seems like it hadnt deleted the original raid partition info before making new info which now kernel panics)

    Jul 18 18:48:05 localhost kernel[0]: AppleRAID::degradeSet - starting the set "STORE45" (B9C48619-6B2C-4547-A01E-4864754EA7E2).
    Jul 18 18:48:35 localhost kernel[0]: AppleRAID::degradeSet - starting the set "CACHE" (64F914A5-5556-4A44-AEE2-DC437868766B).
    Jul 18 18:48:35 localhost kernel[0]: AppleRAID::completeRAIDRequest - error 0xe00002c2 detected for set "STORE45" (C0E139A4-2A6D-49C6-8F77-202AF7F9285D), member 50207BE5-E487-410E-8E8E-C4C4DCD2687B, set byte offset = 999527018496.
    Jul 18 18:48:35 localhost kernel[0]: AppleRAID::completeRAIDRequest - error 0xe00002c2 detected for set "CACHE" (64F914A5-5556-4A44-AEE2-DC437868766B), member C0E139A4-2A6D-49C6-8F77-202AF7F9285D, set byte offset = 999527018496.

    so currently i have 2 new 500gb disks which cant be partitioned back to anything at all on either machine. looks like i will have to buy a new pc to reformat them..

    any suggestions of how to clear the partition map info and get them back to freespace ??
  • 6. Re: RAID mirror with software utility caused kernel panic every time
    Mark Brindle Level 1 Level 1 (55 points)
    Hmm,
    now i have some enterprise disks and i get exactly the same behaviour. kernel panic when i make a raid mirror with the 2 new ultrastar disks. I am chasing Sonnet support on this too as i cannot get rid of the partition map info that disk utility adds on. I have 4 brand new unusable disks now...and no closer to a resolution then 3 weeks ago when my original raid went down.
  • 7. Re: RAID mirror with software utility caused kernel panic every time
    clawfilm Level 1 Level 1 (10 points)
    Mark -

    I have the exact same problem! I have a dual 1.8 G5. It was working beautifully until my own ignorance got in the way. I have a 4 bay that I bought from Macgurus.com (great place if you don't know). I had (4) 250 GB Seagate barracuda Drives. Well I do post production video and with mirroring these drives so that I had (2) 500 GB mounted just wasn't enough. I bought (4) 1TB Seagate barracuda's (Great deal too $170 each).

    So I decided that I would install two 1TB drives into the bottom half and keep the original two 250 GB drives in the top half. This is where my ignorance comes in, I just assumed that the two top drives were mirroring each other, well that wasn't the case. So I got a bunch of "degraded" drives in disk utility. I tried swapping out the drives to see which ones were actually mirrored. I did find it, tried to rebuild, not successful. So then I spent 12 hours trying to extract the extremely important data off at least one of these drives. I did about 92% of the important data and still trying to extract the remaining 8%.

    I have had at least 20+ kernal panics since messing with this raid system. Now I'm at the same part you are that two of my brand new 1TB won't let me transfer files to them and causes a kernal panic. I literally just reinstalled OSX onto my main Hard drive. Tried rebuilding the raid again and another kernal panic.... this is getting really ridiculous and was thinking of just going to the mac store to buy a brand new computer. I have a project due by Friday and can't afford to be late!

    Did you resolve your problem?

    Thanks,
    if you want to chat via email- clawfilm@yahoo.com
  • 8. Re: RAID mirror with software utility caused kernel panic every time
    clawfilm Level 1 Level 1 (10 points)
    I just spoke to sonnet temp thinking it might be a card issue. I explained my situation and they told me that they have never seen the mirroring raid system really work that well. They told me to use a a few back up programs (like time machine) or the old drag and drop method... so I think I'm going to use that until Mirror Raid is flawless or closer to!

    Good luck.
  • 9. Work-around for un-bricking your drives
    pfolger Level 1 Level 1 (0 points)
    Hi People,

    I was trying to mirror two firewire drives on a Macbook Pro, and had the same kernel panics as everyone else, and it seemed that I was unable to format the drives as well. I pulled out the trusty old 800Mhz Powerbook with 10.4.11 and was able to re-format the drive with Disk Utility...

    FYI

    Paul
  • 10. Re: RAID mirror with software utility caused kernel panic every time
    pfolger Level 1 Level 1 (0 points)
    So I got this to work. Here's an excerpt from an email I sent to a vendor.

    Starting with the RAID process:

    I mounted the individual FW Drives (Maxtor 500GB), and formatted them as
    GUID, HFS+ (NOT Journaled). Then I dragged the named volume, not the drive
    itself, from the list of available drives in Disk Utility to the raid
    window, set the block size to max, and pulled the trigger. Disk Utility
    did it's thing, finished, and kernel panicked. Long story short, always a
    kernel panic when one or both of the drives was attached. So it was
    looking like I killed two drives. While I was trying
    to format the drive on a pc, I remembered my trusty 800Mhz Powerbook with
    10.4.11. I was able to mount the drive and reformat it. Not everyone is so
    lucky, here's a thread from the Apple Discussion Boards covering the exact
    same problem I was having.

    http://discussions.apple.com/thread.jspa?messageID=7646831&#7646831

    So this time I formatted the individual drives using Apple Partition Map
    and HFS+ Journaled. Then in the RAID window dragged the Drive icon NOT the
    volume, did not mess with the block size, HFS+ Journaled, and it works. It
    takes awhile to mount just one drive, but it will mount. I know I changed
    a number of variables, but it worked. FYI RAID ends up GUID...

    So that's what worked for me using two firewire drives...
  • 11. Re: RAID mirror with software utility caused kernel panic every time
    Mark Brindle Level 1 Level 1 (55 points)
    I never solved the problem... I managed to clear the drives that had become unusable by putting them in a g5 dual running Tiger and using disk util from the DVD startup rather then booting to the main OS on the startup disk. I had to make sure i was using the drives in the machine and not in any external enclosure and then i could reformat the drives.
    Lots of issues again and i managed to blow up one old drive due to a dodgy power connector in that older machine so i had to rewire one bay with longer power cable inside.
    I used speedtools and disk warrier but had lock ups with a new mirrored raid on the G5 (didnt get kernel panics on that machine but machien would freeze instead and had to be cold booted) and found out that one drive in the raid had lots of errors on it (brand new but not an enterprise disk) - so i learnt my lesson about trying to raid drives that were 'inferior' and wont be trying that again!
    so i could at least re-use drives that would cause kernel panics on the leopard quad machine.

    Ive ended up with most drives in the sonnet enclosures as separate drives now and not raided, and just copy stuff between them for backups. not ideal at all.

    Ive gone back to buying more external FW drives to use as backups too. I luckily have a few maxtor one touch III 1T external FW drives which have built-in raid - maxtor dont make these any more and i cant seem to find anything like these any more. These get used for day to day ingest of P2 files before backing up to another external FW for storage and onto the leopard machine for usage. But the whole process is not as nice as my original raid method. But ive given up trying to raid using the tempo enclosures now - one of also them seems to have a faulty connection inside as well (out of warranty now) so i have 4 slots instead of 5. This may have been part of the problem (ie the start of the problem), along with trying to use sub standard non-enterprise drives.

    if i get time in the winter i will have another go at trying to get at least mirror raid on 2 drives working again but at the moment i have to use them and do work!!
  • 12. Re: RAID mirror with software utility caused kernel panic every time
    Frederic Denis Level 1 Level 1 (10 points)
    At last, peoples with similar problems as mine!

    Our setup is:
    Mac OS X Server, now 10.5, installed on 2-mirrored-internal drives (250 GB each)
    PowerMac G5 (2 x 2.3 GHz)
    Sonnet Tempo SATA E4P
    Sonnet Fusion D500P (not sure of the model, but it's the 5-drives RAID tower)

    RAID tower consists of a mirror of 2 sets of 2 concatenated drives (each 500 GB), and one 750 GB planned for backup using TimeMachine. All drives are Seagate "entreprise" drives (4 x ST3500630NS, 1 x ST3750640NS).

    Since I decided to upgrade my server to 10.5, it's been running fine for a while, but then started to exhibit kernel panic problems, and later disc freezes on either drives of the tower (constant blue LED light stuck, can't do a soft restart, must hold power button).

    So far, I've played with many options that gave nothing (upgrading to latest Sonnet drivers/firmwares, making sure G5 firmware is the latest, un-journaling drive(s) in the RAID tower, Terminal commands to verify and repair the volumes, removing TimeMachine support, removing the tower volumes from Spotlight, name it).

    Last week, I've completely reinstalled the server. It wasn't in production yet, so it wasn't such a big deal. And it was an opportunity to refresh the DNS setup I've worked on to have a custom top-level domain in my private network. But I disgress.

    After fresh install and reconfig of basic server services, I've went to config TimeMachine. After the listing of the available drives (which has always been very long - about 45 to 60 seconds), I got my first new disk freeze. And the next day, while backing files from the RAID tower on a network (Windows) share, I got my first new kernel panic.

    So, the problem is not just Spotlight or TimeMachine or the upgrade-installation of 10.5 from 10.4. It's somewhere else.

    My last in-house test will then be to reformat each drive in the RAID tower, recreate the RAID structure and try again to make it crash (I've been good at that lately). If it does crash, then the problem will be most likely coming from a hardware problem, but I'll need my vendor to help me out to run these tests:
    - can we make it crash with a newer card from Sonnet?
    - if yes, can we make it crash with a card from a different vendor?

    - or can we make it crash with a newer enclosure from Sonnet?
    - if yes, can we make it crash with an enclosure form a different vendor?

    - and if we can make it crash in the above situations, then I guess it will mean we'll have to try to setup a server on a different machine and see if we find similar problems when running the Server along with TimeMachine and Spotlight. From this thread, I'm encouraged to think the problem might come from the Sonnet hardware. However, since our G5 is a refurb, it might be anything really, and deep hardware scan with TechTool Pro or the like might be required.

    I'm getting tired, you can imagine.


    FD