Previous 1 8 9 10 11 12 Next 575 Replies Latest reply: Jan 11, 2013 5:14 PM by Henglong Go to original post
  • DaveMcM Level 1 Level 1 (0 points)
    OK, I've install the Mobile Me control panel from the link, and when I run MobileMe I get the following error:

    AppleSyncPref.exe - Entry Point Not Found

    The procedure entry point _tidyAttrNext@4 could not be located in then dynamic link library libtidy.dll
  • ibaj Level 1 Level 1 (55 points)
    So for you, the problem is an extra copy of libtidy.dll laying around someone under C:\Windows\*

    You should search for that DLL, look for it in the C:\Windows\ hierarchy, and move it aside (to your desktop should be fine)
  • DaveMcM Level 1 Level 1 (0 points)
    And that looks like it may have solved it... My other libtidy.dll was installed by UltraEdit, and although it was in the UltraEdit programs folder it was getting picked up because my UltraEdit programs folder was in my global PATH.

    I've taken UltraEdit out of the path and now get no errors from MobileMe or iTunes now... just running a sync to see if my test data gets copied across properly
  • DaveMcM Level 1 Level 1 (0 points)
    Hurrah

    Removing the UltraEdit Program Files folder from the path so it's libtidy.dll isn't picked up seems to have fixed things... I now have contacts and notes syncing happily both ways

    Many thanks for all your help - do you have any ideas why this is suddenly an issue in iTunes 9.1, as I've had UltraEdit and all previous versions of iTunes back to version 8 installed with UltraEdit in the path with absolutely no issues until today...
  • dfmutz Level 1 Level 1 (0 points)
    ibaj I think it is more in a problem in the new bonjour driver. I had unistall 9.1 all the way and then installed 9.03 back and things were ok, but then I updated to the new mobile me and the errors started again. So I think the new bonjour driver (which should be in both updates unless I am mistaken) is the problem.
  • ibaj Level 1 Level 1 (55 points)
    The new MobileMe using the same software that iTunes 9.1 does, so this would be expected. When you launch MobileMe, what error do you get?
  • marathdamane Level 1 Level 1 (0 points)
    I'm having this problem on my computer i have tried downgrading and reinstalling and i have tried completely reinstalling. I couldn't find any libxml2.dll or libtidy.dll anywhere on my comp. Anyone got some other suggestions as to what to do for this cause I'm assuming this is the cause of my problem syncing my phone with my computer.
  • icefoxxxx Level 1 Level 1 (0 points)
    so you had this problem after upgrading as well? Weird not many people are having the same problem. My system is all clean, nothing should be wrong... What's your OS?
  • icefoxxxx Level 1 Level 1 (0 points)
    oh **** I didn't notice... I'm using exchange server so everything is synced on the air; I just hate the error message.

    My PC is self built, but with Win7x64 system. Maybe it's the 64bit OS? Anyway, Apple screws big time with this upgrade.
  • icefoxxxx Level 1 Level 1 (0 points)
    It's too long and I don't know if this is the section you need...

    =======================
    SyncServer.exe begins
    =======================

    [2952 @ Wed Mar 31 00:36:38 2010] [_ISDVLog SyncServer.exe] Logging initialized, engine version (null) : log level 3
    [2952 @ Wed Mar 31 00:36:42 2010] [_ISDVLog SyncServer.exe] _setClientWithIdentifier: com.apple.Outlook isEnabled: YES forDataClassNamed: com.apple.Notes
    [2952 @ Wed Mar 31 00:36:42 2010] [_ISDVLog SyncServer.exe] _setClientWithIdentifier: com.apple.Outlook isEnabled: YES forDataClassNamed: com.apple.Calendars
    [2952 @ Wed Mar 31 00:36:43 2010] [_ISDVLog SyncServer.exe] _setClientWithIdentifier: com.apple.IE isEnabled: YES forDataClassNamed: com.apple.Bookmarks
    [2952 @ Wed Mar 31 00:36:43 2010] [_ISDVLog SyncServer.exe] _setClientWithIdentifier: com.apple.Outlook isEnabled: YES forDataClassNamed: com.apple.MailAccounts
    [2952 @ Wed Mar 31 00:36:43 2010] [_ISDVLog SyncServer.exe] _setClientWithIdentifier: com.apple.Outlook isEnabled: YES forDataClassNamed: com.apple.Contacts
    [2952 @ Wed Mar 31 00:36:47 2010] [(unknown facility) com.apple.Safari.isRegistered] dataClassNamesInstalledForClientWithIdentifier: app not installed
    [2952 @ Wed Mar 31 00:36:48 2010] [com.apple.WindowsMail.isRegistered SyncServer.exe] running atop Windows 7; declining registration
  • Shidevil Level 1 Level 1 (0 points)
    Hi to all,
    I have downloaded mobileme and opened it up but got no error. I did the command prompt and run syncserver.exe and got this error. "The program can't start because objc.dll is missing from your computer. Try reinstalling the program to fix this problem."

    Help anyone?
  • icefoxxxx Level 1 Level 1 (0 points)
    you are the man!! I have ultraedit as well.
    So it's UE's fault... Who could have imagined that!@
  • ibaj Level 1 Level 1 (55 points)
    Running SyncServer.exe by itself like this isn't going to work. That's expected.

    Are you using the latest MobileMe & iTunes 9.1?
  • Shidevil Level 1 Level 1 (0 points)
    Yes i'm using the latest mobileme and itunes 9.1

    Care to give a brief explanation on running the syncserver using command prompt?

    after i went to application support it was okay, but doing "..\Mobile Device Support\Syncserver.exe" they said invalid directory name"
  • dfmutz Level 1 Level 1 (0 points)
    Ok, I think someone in the programming department made a mistake because all the dlls and missing files I have found. They are all within the C:\Windows\Common Files (x86)\Apple\Apple Application Support directory. All the files that have been missing from the forum responses are there but I don't think syncserver knows to look there.
Previous 1 8 9 10 11 12 Next