Skip navigation
This discussion is archived

Using alternate SMTP server to MobileMe as default

3377 Views 6 Replies Latest reply: Jul 11, 2008 7:36 PM by jaliebs80 RSS
jaliebs80 Calculating status...
Currently Being Moderated
Jul 11, 2008 1:40 PM
Original iPhone 8Gb, 2.0, Mobile Me

I am attempting to set up my email on my phone so that it receives push email from MobileMe and defaults to a different SMTP server. I have been able to do this successfully on my MBPro, yet the iPhone is giving me fits.

Here is my current settings:

Settings -> Mail, Contacts, Calendars -> MobileMe

Mail = On
Contacts = On
Calendars = On
Bookmarks = On

Account Info ->
Name = my name
Address = myemail@me.com
Password = *****
Description = MobileMe

Outgoing Mail Server
SMTP = smtp.theserveriwanttouse.com

Outgoing Mail Server ->
Primary Server = smtp.me.com = Off

Other SMTP Server ->
smtp.theserveriwanttouse.com = On
AT&T SMTP Server = Off

Everything so far looks correct to me and it should work just fine. However, when I send an email it is received as myemail@me.com rather than myemail@theserveriwanttouse.com.

Does anyone have an idea of what settings I have wrong or why this doesn't work? I would really, really like to keep my MobileMe email secret and have all of my other email forwarded but if I can't figure this out then MobileMe isn't worth the $99 / year.

Thanks for any help.
MBPro 2.16 GhZ 15" 2GB RAM, Mac OS X (10.5.4)
  • Allan Sampson Level 10 Level 10 (122,145 points)
    Currently Being Moderated
    Jul 11, 2008 2:07 PM (in response to jaliebs80)
    The SMTP server used to send messages with an account alone does not change the email address shown as the sending email address for an account.

    What is shown as the name and sending email address for an account is determined by what is entered in the name and email address fields for the account settings.

    +Account Info ->+
    +Name = my name+
    +*Address = myemail@me.com*+
    +Password = *****+
    +Description = MobileMe+

    Apple prevents entering a different email address in the email address field for the account settings with a .Mac or MobileMe email account to appear as the sending email address for the account. Using a different SMTP server to send messages with the account should allow for this, but you must enter the email address that you want to appear as the sending email address in the email address field for the account settings. This may not work either. This restriction is part of an overall effort to prevent spam emanating from Apple's domain.
     PowerBook G4 17-inch/1.67GHz/2GB RAM, Mac OS X (10.5.4), 7200rpm-100GB HD,  iPod w/Video 30GB,  iPhone 8GB
  • Allan Sampson Level 10 Level 10 (122,145 points)
    Currently Being Moderated
    Jul 11, 2008 3:04 PM (in response to jaliebs80)
    But, I was able to use the gmail SMTP and have it come across as myemail@gmail.com from the phone.


    I believe this is because Gmail requires using your associated Gmail email address when sending messages with Gmail's authenticated SMTP server - regardless what is entering in the email address field for the account preferences. The user name for the SMTP server authentication is the portion of your Gmail email address in front of the @ sign. Gmail probably does this as part of an overall effort to prevent spam emanating from their domain.
     PowerBook G4 17-inch/1.67GHz/2GB RAM, Mac OS X (10.5.4), 7200rpm-100GB HD,  iPod w/Video 30GB,  iPhone 8GB
  • Colorado Cary Calculating status...
    Currently Being Moderated
    Jul 11, 2008 3:17 PM (in response to jaliebs80)
    I am trying to do the same thing and have mine set up just like yours except that for me Gmail SMTP still shows it as me.com and the only SMTP servers enabled are Gmail ones. I've verified the me.com account in Gmail's settings too.

    MobileMe settings:
    name: myname
    address: myemail@me.com
    password: *******
    description: MobileMe

    Outgoing Mail Server
    SMTP: smtp.gmail.com

    Outgoing Mail Server ->
    Primary Server: smtp.me.com = Off

    Other SMTP Server ->
    smtp.gmail.com = On (port 587, this is for my Gmail mail account which is turned off)
    smtp.gmail.com = On (port 465, this is for my Gmail mail account which is turned off)
    AT&T SMTP Server = Off
    Mac Mini 1.66 GHz Intel Core Duo, Mac OS X (10.5.4), iPhone 2.0

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.