Skip navigation
This discussion is archived

iPhone 2.0 - Can't locate me in Google Maps

31042 Views 268 Replies Latest reply: Sep 14, 2008 5:23 AM by Adrian H RSS
  • eccparis Calculating status...
    Currently Being Moderated
    Jul 13, 2008 9:36 AM (in response to bigmagic)
    Where are you in France? I'm in 92260 Fontenay-aux-Roses and my Google Maps works almost 'nickel' on Orange/EDGE, putting me 'only' 700m from my house. The route (itinéraire) function from or to my house also works fine.

    This may or may not have to do with the fact that I've always had very strong signal from Orange here, which leads me to think it once again a function of nearby cell towers.

    On another thread - or was it David Pogue's column at the NY Times? - I had read that even with the new 3G, Google Maps might not work very well in Manhattan or other cities with tall buildings because the shadow of those buildings may 'block' the (faux-)GPS signals.
    MacBook (Intel) / G4 iMac (PPC), Mac OS X (10.4), various external HDs, 2.0 original iPhone, iPod... and I sing, too (really!)
  • Mac-a-doodle Calculating status...
    Currently Being Moderated
    Jul 13, 2008 9:55 AM (in response to SC::UK)
    I have found the same problem however I noticed something that others haven't mentioned. After succefully updating to 2.0 I discovered when first using maps locate me function I was asked to "use current location", options provided were "Don't allow" an "OK". I touched OK and was left waiting while the system could not find me ( as others have said). I tried again and as in the first time the same question and options were presented. Again I chose OK again I was left hanging with no success.

    Later when I took a photo (the first since upgrading to 2.0) a similar question and option window opened up. I recalled being told the new 3G iPhone has GPS which will record the GPS location where a photo has been taken. This time I chose don't allow as I guessed that the iPhone was seeking permission to utilise it's non-existent GPS chip. I also guessed that was what the maps options were also asking for and thought next time I'll choose don't allow. However I have not been asked to Use current location each time I have unsuccessfully tried to use the locate me function ( despite being asked each and every time in the camera function) and now fear I have set my phone to attempt to use the Non existent GPS chip as a default setting in maps.

    Can anyone confirm this has happened to them and if so how to reverse it?  
    iMac G5 PRE-INTEL, Mac OS X (10.4.11), 1st Gen iPhone running 2.0
  • eccparis Level 3 Level 3 (740 points)
    Currently Being Moderated
    Jul 13, 2008 10:22 AM (in response to Mac-a-doodle)
    I, too, have answered the same question both in Google Maps and Camera, and everything works fine here just south of Paris. (I still think it might be a function of the strength of cell towers nearby, as well as no tall buildings whose shadows may get in the way of GPS or faux-GPS signals...)
    MacBook (Intel) / G4 iMac (PPC), Mac OS X (10.4), various external HDs, 2.0 original iPhone, iPod... and I sing, too (really!)
  • bigmagic Calculating status...
    Currently Being Moderated
    Jul 13, 2008 10:58 AM (in response to eccparis)
    I am actually in WE in Angers and I have tested in the same place with the two firmware versions.

    When the firmware 2.0 was released, I tested Google Maps in my car (I live in Chatillon) and the location sometimes was working ... This issue is perhaps related to the location ??

    Message was edited by: bigmagic
    macbook, Mac OS X (10.5.4)
  • Damienoneill Calculating status...
    Currently Being Moderated
    Jul 13, 2008 1:50 PM (in response to Mac-a-doodle)
    As far as I know the iPhone will revert back to the old method of using the nearest phone tower to locate you if you do not have GPS in the phone. I am sure the iPhone OS handles of this for you so even developers would not have coded bad applications which only work on the 3G iPhone.

    Besides I have tried this in loads of places and only got it working once. In a O2 store, where the other 3 iPhones refused to work. It seems be a vary bizarre bug...
    Mac OS X (10.4.3)
  • brygul Calculating status...
    Currently Being Moderated
    Jul 13, 2008 3:00 PM (in response to Mac-a-doodle)
    Hi luddite1,

    If you look in settings -> general, you should see a 'location services' option. turn this to 'off' and maps should ask your permission again. (Drives me nuts that the camera asks every single time I want to use it!)

    The symptoms of the failure to locate me certainly feel to me too to be as though the phone is trying to use GPS (which of course doesn't exist) and then hanging. Whether that's really the case I don't know... what I'm certain of is that this is an issue with 2.0, not a function of the cell towers which my phone needs to use to triangulate - (as mentioned earlier) location has always worked very well for me until it immediately stopped working (in the same geographical locations) after upgrading to 2.0.

    @eccparis - thanks for your suggestion; sadly that doesn't work. I've come across some alternative suggestions which involve jailbreak type methods, but I don't much fancy taking my chances with that!
  • texwake01 Calculating status...
    Currently Being Moderated
    Jul 13, 2008 4:19 PM (in response to SC::UK)
    Im having the same issure but mine crashes to the home screen. especially when im driving somewhere and I need to look up traffic or somthing but when i sit on a couch it works for some reason. Im in houston so this should not be a huge problem.
    Windows Vista
  • mkoistinen Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 14, 2008 2:57 AM (in response to texwake01)
    Can you confirm that you are using an original iPhone with v2.0 of the OS installed?

    If you are having the same issue that is being reported here, it would imply that the new OS on the original hardware is capable of using WiFi access points to determine location (I would speculate that your access point was geotagged by SkyHook), but that some devices hang (or crash, as in your case) when they need to rely on cell-tower triangulation.

    However, some people report that their device hangs even when in range of a WiFi access point that is registered with SkyHook. I am one of these. I cannot get Locate Me to work anywhere at all. This is a real bummer as one of the key new features of OS v2 is the location-based services support for things like Camera, Twitteriffic and other apps.

    I wish someone would post a fix!
    Mac OS X (10.4)
  • eccparis Level 3 Level 3 (740 points)
    Currently Being Moderated
    Jul 14, 2008 3:27 AM (in response to brygul)
    @eccparis - thanks for your suggestion; sadly that doesn't work.


    Maybe you could try displacing the 2.0 update (say to your desktop) so that iTunes doesn't 'see' it as the latest update? i.e., try to trick iTunes into thinking that 1.1.4 was the last one on your iPhone?

    Or you can make a copy of 1.1.4 and put it on your desktop, and select it instead?

    Just my two cents!
    MacBook (Intel) / G4 iMac (PPC), Mac OS X (10.4), various external HDs, 2.0 original iPhone, iPod... and I sing, too (really!)
  • eccparis Level 3 Level 3 (740 points)
    Currently Being Moderated
    Jul 14, 2008 3:34 AM (in response to bigmagic)
    Bonjour Angers! Could you post here how you downgraded to 1.1.4? Some other posters here are trying to do that, but my suggestion didn't seem to work...
    MacBook (Intel) / G4 iMac (PPC), Mac OS X (10.4), various external HDs, 2.0 original iPhone, iPod... and I sing, too (really!)
  • eccparis Level 3 Level 3 (740 points)
    Currently Being Moderated
    Jul 14, 2008 3:53 AM (in response to bigmagic)
    Rebonjour Angers ! You mean we're practically neighbors if you live in Châtillon, Hauts de Seine?

    When the firmware 2.0 was released, I tested Google Maps in my car (I live in Chatillon) and the location sometimes was working ... This issue is perhaps related to the location ??


    Your experience seems to indicate that location [does] come into the picture here, since your town is right next door to mine.

    (For those who are not familiar with France, both Châtillon and Fontenay-aux-Roses are suburbs just south of Paris. Meanwhile, bigmagic is in Angers currently, about 300 km south-west of Paris where the Orange cell towers are undoubtedly farther apart than near Paris. My guess therefore is that location does play into this issue here, so long as we're relying on EDGE hence cell towers.)

    By the way, bigmagic, connaissez-vous la belle chanson de Poulenc, "C." (sur un texte de Louis Aragon, Les Ponts-de-Cé, juste au sud d'Angers) ? C'est ma mélodie de Poulenc préférée ! (Je suis chanteuse classique.)
    MacBook (Intel) / G4 iMac (PPC), Mac OS X (10.4), various external HDs, 2.0 original iPhone, iPod... and I sing, too (really!)
  • Stephen Darlington Calculating status...
    Currently Being Moderated
    Jul 14, 2008 5:18 AM (in response to SC::UK)
    No solution, I'm afraid, but you can add me to the list of people that this affects. I note that it seems to correctly find my location using WiFi, but never with the cell tower triangulation. Both worked fine with 1.1.4.

    https://twitter.com/sdarlington/statuses/856736601

    Cheers,
    --> Stephen
    MacBook C2D 2Ghz, Mac OS X (10.5.4)
  • bigmagic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2008 5:40 AM (in response to eccparis)
    Hi,

    To downgrade the firmware to the version 1.1.4, you need to install iTunes 7.5 and put the iphone in DFU mode and then restore (two times) the iphone using the version 1.1.4.

    It's explained in a french forum :
    http://forum.frenchiphone.com/index.php/topic,21066.0.html
    macbook, Mac OS X (10.5.4)
  • SimonWhitehouse Calculating status...
    Currently Being Moderated
    Jul 14, 2008 5:50 AM (in response to SC::UK)
    add me as well please, this is a total pita for me as i use my iphone when out traveling from site to site everyday and now its useless...didnt have this problem with the N95 and its GPS.....might have to get it out the draw!

    Simon
    MacBook & iMac, Mac OS X (10.5.4)
1 2 3 4 5 ... 18 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.