Skip navigation
This discussion is archived

Itunes remote not working

26854 Views 36 Replies Latest reply: Mar 28, 2009 11:57 AM by Draydawg RSS
  • le_fino Calculating status...
    Currently Being Moderated
    Jul 23, 2008 5:24 AM (in response to everettwolf)
    I made my Time Capsule the unique router for all my wifi and ethernet connections and the iTunes Remote still gives me a "Cannot find library" error. Not sure what else to try. As previously mentioned, I have the latest iTunes, the latest Remote software on my iPod Touch with 2.0 software, latest firmware on the Time Capsule, latest patches for 10.5.4 on the MacBook Pro...and all the recommended settings for sharing, et.
    Any other suggestions?
    MacBook Pro 15" 2.6 GHz 4 GB RAM, Mac OS X (10.5.4)
  • Gbcsoundguy Calculating status...
    Currently Being Moderated
    Aug 6, 2008 11:52 AM (in response to Flat Eric)
    THANK YOU it finally works, I've been bouncing my head off the wall trying to figure it out!! The remote is awesome
    Mac OS X (10.5.4)
  • proc113 Calculating status...
    Currently Being Moderated
    Oct 20, 2008 8:05 PM (in response to le_fino)
    I have this exact same problem! This does not work on my macbookpro. However, it works just fine on my wife's macbook. Both computers are on the same wireless network and both are running the latest updated leopard. Her music library is twice the size of mine, both libraries are stored on their respective internal drives.

    I get the screen to enter the 4-digit control code, however, it doesn't find my library after accepting the 4-digit entry.

    Any assistance would be appreciated!
    MacBookPro, Mac OS X (10.5.5)
  • saubrooklyn Calculating status...
    Currently Being Moderated
    Nov 16, 2008 6:49 PM (in response to le_fino)
    Unfortunately, this is 1 of the infuriating issues that pop up with Apple products from time to time when users push the full suite of apple products to the brink. My system includes a MacBookPro Intel 10.5.5, Airport Extreme and an iPhone 3G w/Remote app. Add to that a LaCie ext hard drive supplying your music library via USB and you've got some issues. I too had the same problem, where the iphone would give u the passcode for control, but iTunes would NOT offer a device/remote icon and field for password. I followed all the firewall instructions listed previously in this string and still nothing helped. It was only after restarting the computer (nothing else) and launching itunes that I was able to get the Remote icon to appear. Additionally, I should note that my phone was plugged into the mac when it worked. Another thing that could affect this is how many additional itunes libraries are already listed in the Remote app of your phone. Since I had already used Remote when my library was ON my local mac, that iTunes file name was still in Remote. Thus after I moved iTunes library to my external, there's a good chance Remote was still pointing to my old file (which, of course, was not active). Libraries are named from the USER who is logged in on the machine running iTunes, and not WHERE the library/music is located.
    Mac OS X (10.5.5)
  • dulcettones Calculating status...
    Currently Being Moderated
    Dec 3, 2008 4:16 PM (in response to joshmanwho)
    Not sure if this helps but I had the same problem with my iPhone 3G and my Macbook Pro.
    I also found that iTap (app for trackpad control using the iPhone,) had stopped registering a connection with my Macbook over wifi despite my still having iTunes library sharing on etc.
    I think that this started either when I updated iTap or remote or after a recent OS X update.
    To fix it I tried getting rid of all remotes in iTunes etc but nothing would work.
    Eventually I tried restarting my wireless router and connecting the iPhone to iTunes via the USB cable and following this the device item in iTunes appeared with the remote icon and I was able to re-pair my iPhone and iTunes.
    I think that there may be a glitch that causes the connection between the iPhone and iTunes / OS X when you update one of the apps.
    Hopefully this will be sorted by future updates as I don't want to have to re-pair after updates all of the time.
    Macbook Pro 15", Mac OS X (10.4.8), 2.16 GHZ, 2Gig, iPhone 3G 16 Gig, iPod 60 Gig Classic and Nano
  • flysi Calculating status...
    Currently Being Moderated
    Dec 8, 2008 9:55 AM (in response to dulcettones)
    I am had been having a lot of the same issues when using Bitdefender, and despite allowing iTunes and bonjour through the firewall remote still wouldnt work. Thankfully my license has now run out and I just changed both my laptop and PC over to Kaspersky and really hoped this would work.

    Firstly, my laptop. Installed the new software, let it do its think, and restarted the laptop. Opened up itunes, entered the 4 digit code and all was great. Have shut down computer multiple times and remote and it all works fine.

    Did the same on the PC. Same default settings on kaspersky, same process, typed in the 4 digit code to itunes, and itunes said my phone was now synced. However, when I go to remote it just seems to time out and never connects.

    Both music libraries and all tracks are on the respective local hard drives, except the laptop one is 300Mb vs 15Gb on the PC. The PC is also connected over a cable to the router, but those are the only differences.

    Its therefore not a external harddrive issue... its not a router issue, its not the iphone, its not the firewall so what is the problem? I am assuming its a timeout issue as I have the similar sometimes using the Roku remote app but that seems to try looking for longer.

    As mentioned earlier, it would be nice for someone from Apple to comment on here as it seems to be a major frustration for a lot of users.
    PC, Windows XP
  • Draydawg Calculating status...
    Currently Being Moderated
    Mar 28, 2009 11:57 AM (in response to Flat Eric)
    my remote did work but for some reason it doesnt work now. when i tried adding a new library when i deleted all the otheres, the code thing didnt show up on my itunes. ***. and on my firewall its allowed so idk wut the problem is
    Windows Vista
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.