Previous 1 2 Next 17 Replies Latest reply: Jul 17, 2008 7:59 PM by ultimaonliner
lampip Level 1 (0 points)
Apologies if this has been answered, could not find a way to search posts and looked around and saw similar questions but none that answered this for me.

Just got the 3G and love it, but am trying to connect to my wifi (have a dlink router with an airport extreme wireless N running as an access point) and i put my password in (WPA) and it doesn't give any errors and shows the network name in the wifi field under settings with a checkmark. but it never uses it, always see 3G symbol at top. When I go to the network settings for the wifi all the fields are blank (IP Address...) I tried restarting the phone and resetting the network settings but get the same results. My wife's original phone connects to it and works properly.

Has anyone else experienced this or have any suggestions? I am dying to try the iTunes remote on the phone but cannot.

Thanks in advance for any help you can give.
Peter

PC, Windows Vista
  • Steve Rawley2 Level 1 (5 points)
    I'm still using Edge and my iPhone is doing the exact same thing today. I can connect to other wireless networks but when I come home to the Airport Extreme base station, I get the 169..... IP address and only able to connect to Edge.

    It has always worked before. I updated Airport and iTunes today along with some other updates that came up on "software updates".
  • Jonah Lee Walker Level 3 (565 points)
    I am having the exact same issue with my new 3G iphone, but my upgraded 2G iPhone worked fine. This seems to be something with the 3G not switching off. I can't get any of my 3rd party programs to sync because they all use WIFI. This *****, I need to figure out a solution for this.
  • Kingdaddy Level 1 (0 points)
    I just got the 3g phone today too, and I cannot connect to my wifi at home. I have a D-Link DIR 655 Wireless N router, and I had no problem connecting it to my iPhone 1.0, however, the new one asks for my password, which I enter, and then it comes back and says it cannot connect. I'm not sure how to fix it. Looking at the boards, apparently quite a few others are also having wifi issues.
  • heybill Level 1 (0 points)
    Okay, I got mine to work on my home network with my time capsule by assigning a static IP even though the router is DCHP. Shouldn't have to do that though...
  • SFLapple Level 1 (0 points)
    I did the same thing with my netgear I had to assign a static ip and it worked! Even though it should work automatically.
  • Appy Ammer Level 1 (0 points)
    OK, I have exact same issue. iPhone 2G connects to home wifi base station. iPhone 3G will not. I have even assigned static IP address and whilst the airport logo shows a full signal I have no access to internet via wifi. I have checked with routers software that there are 5 available IP addresses and tried all 5 without success.
    Any help would be appreciated.......

    Thanks for your help
  • Matt Musante Level 1 (20 points)
    Ensure that the DNS server is set correctly. After upgrading to version 2.0 I had a problem with my original iPhone connecting to the WiFi access point at work that had always worked before. I found that it had a bad IP address in the DNS server setting. WiFi -> Network Name -> "arrow" -> DNS.

    I typed in a local DNS server that I found by searching google and everything worked again.
  • George61d Level 1 (0 points)
    Well I am gald to hear its not just me. The only way I can get my IP 3g to work is to enter in static information. Using DHCP does not work. The IP3G will connect to the Airport access point ok but no addresses are assigned to it. My old iPhone works just fine.

    Guess we will have to wait until someone posts a fix.
  • mikemcde1 Level 1 (105 points)
    Here's something to try. On your iPhone go to settings/general/reset then choose "Reset Network Settings" this will not do any harm to the data on your phone. See if that takes care of any issues. I have a 3G iPhone and all is working well with my AEBS. If you are using a non apple router make sure the firmware of the router is up to date. Let me know if the reset works.
  • Hamfist Level 2 (155 points)
    This totally just worked. In WiFi>[network name]>'>' all the information is present.

    Thanks!! Really appreciate it.

    Ryan
  • Hamfist Level 2 (155 points)
    though, now all my added apps crash on launch.

    is this happening with you?
  • George61d Level 1 (0 points)
    Thanks for the suggestion I will try that. I should add that DHCp is not working with the airport base station that I have but it is working fine with the second wifi network with a non apple router that we have set up here.

    Cheers
  • George61d Level 1 (0 points)
    ok just did it and no change. i.e it is still not working with the apple base station and it is working with the non apple base station. I updated the apple base station this am so it is running the latest firmware.
  • mikemcde1 Level 1 (105 points)
    delete the apps and reload them. If they were purchased apps you might need to purchase them again but Apple has always been good about refunding me on songs that I downloaded twice. Just tell them the download was currupt and they'll refund you. Also on the receipt they send you there is a link on each item to report a problem.
Previous 1 2 Next