1 2 Previous Next 16 Replies Latest reply: Aug 22, 2008 4:37 AM by Jimmy Heaven
Col. Graff Level 1 Level 1 (50 points)
I have a iPhone EDGE 16 GB. I updated it earlier today with software version 2.0 (5A347).

I have a lot of music on the device, some ripped from my own library and some purchased through the iTunes store. Everything was working fine before the update but there have been several problems since the update. Occasionally I will begin to get songs that look like they are playing but there is no sound.

Changing the volume, stopping and starting the song, and switching to another song/playlist and then switching back doesn't work. The only thing that works is manually turning off the iPhone by holding down the home and sleep buttons and restarting the device. The songs then will play without any problems. I have only had this problem for 2 reboots so far.

The only thing that seems to be a common factor is that so far all of the songs that have problems playing are M4P files purchased from the iTunes store. So far I have had problems with songs off the albums +The Verve Pipe+ "Villains" and +Jack Johnson+ "Sleep Through the Static", but not always the same songs. Other M4P songs seem to work fine even when I'm having problems with some songs.

Anyone else encountering problems playing purchased music? Everything seems to work fine in the iTunes installed on my computer.

iPhone EDGE 16 GB, Other OS, software version 2.0 (5A347)
  • 1. Re: Purchased Music Not Playing
    sequeller Level 1 Level 1 (0 points)
    Same issue for me here. The differences are:

    - My iPhone is a 8GB EDGE
    - My music purchased until end of last year *will not* transferred to my iPhone
    - My music purchased this year is transferred perfect

    I even reset my iPhone completely to try to solve this issue, but without any luck.

    I don't know if this is important, but I did reset my activated computers in Itunes earlier this year, because most of them did no more exist and I reached the 5 computers limit. But on any new computer I can listen purchased music and the same it was before I updated to iPhone OS 2.0.
  • 2. Re: Purchased Music Not Playing
    Col. Graff Level 1 Level 1 (50 points)
    sequeller wrote:
    I don't know if this is important, but I did reset my activated computers in Itunes earlier this year, because most of them did no more exist and I reached the 5 computers limit.

    This is my 3rd computer with this library and I have the other 2 deactivated so I only have 1 computer currently using the library, I've never had to ask Apple to reset my activations.

    I did have some trouble a bit ago with upgrading my iTunes songs to iTunes Plus. Some of my songs upgraded and some that had iTunes Plus versions didn't upgrade properly. The problem is currently being looked at by the iTunes Store staff. I don't know if the two are related.

    I wonder if I should trash my iTunes database file so that it can be regenerated but I don't want to lose any data that might be held in it, such as my song ratings. I'd do it as a last resort but I'd rather find out if it is something else first.
  • 3. Re: Purchased Music Not Playing
    ackc Level 1 Level 1 (0 points)
    I'm having the same problem. I updated yesterday to software version 2.0 and since then music purchased from the iTunes Store will sync to my iPhone but not play. Or rather - it APPEARS to play (the progress bar moves) but I can't hear any sound with headphones or through the speakers. Music ripped from my CDs plays just fine. The purchased music plays fine in iTunes on my computer (no permissions issues as far as I know). I'm having this problem with any purchased music I have tried so far, not just with certain songs or certain albums. The same purchased songs, on my non-updated iPod Touch, will play just fine.

    I tried restarting and resetting the device as suggested, but that didn't solve it for me. I have tried changing the way the songs are synced (from syncing playlists to manually managing the songs) and that didn't help. I have cleared and resynced the iPhone, restarted the computer, etc. I haven't tried completely restoring the iPhone (at least, not yet....)

    Any ideas of something to try next?

    (And it may be unrelated, but two music videos purchased with albums from the iTunes Store also won't play - same "This movie format is not supported" issue mentioned in some other discussion posts).
  • 4. Re: Purchased Music Not Playing
    dalbello Level 1 Level 1 (0 points)
    Same issue here... Anyone managed to sort it out???
    Rebooting doesn't help. Tried everything already.
  • 5. Re: Purchased Music Not Playing
    ghbuchholz Level 1 Level 1 (0 points)
    My wife's iPhone is having a similar problem to the one described here. Some itunes purchased music plays fine, but other music purchased from the same account play without sound. I checked the info and the only difference is that the purchased by for the songs that work is different between the songs that play and those that don't. All of these songs work in itunes as well as on a new shuffle and a new nano purchased in December07.
  • 6. Re: Purchased Music Not Playing
    Jeremy Gordon Level 1 Level 1 (5 points)
    I am having the same problem with my EDGE 8GB iPhone. Updated to 2.0 first day that 2.0 came out and am just now having the problem with some songs. All other audio works great, and some songs play fine. I have all purchased music through my iTunes account and it's only a handful of songs that will play, most just look like they are playing but with no audio.

    At first I thought it was the whole "plug/unplug" headphones problem. Only after fooling around did I realize that all the audio from my iPhone games works fine, and the audio from a handful of songs works fine. I can't tell any pattern of which songs have problems, they seem to be from various "vintages" of iTunes purchase.

    Bummed!
  • 7. Re: Purchased Music Not Playing
    Damon M. Level 4 Level 4 (3,695 points)
    Here is a link to another thread that might help out.

    http://discussions.apple.com/thread.jspa?threadID=1601599&tstart=0
  • 8. Re: Purchased Music Not Playing
    TVCTVC Level 1 Level 1 (0 points)
    This is the exact issue I have. No Purchased songs produce sound, yet they appear to play. We need to stop discussing this and have Apple give use the fix.
  • 9. Re: Purchased Music Not Playing
    Col. Graff Level 1 Level 1 (50 points)
    Unfortunately the answer in that thread didn't work.

    I purchased some stuff (some free music and apps) and everything was good for a bit. I recently purchased a TV show which worked at first but then I started getting a message similar to "this tv show won't play on this ipod". I rebooted and the show works fine now.

    I still don't know what is causing this problem but it seems that it is triggered over time. Maybe the software is reading a preference file that got corrupted or maybe there is a bug that puts the phone in an unstable state, I'm not sure. All I know is that everything works once the phone is rebooted and then some time later (usually hours or days of use later) I have problems.
  • 10. Re: Purchased Music Not Playing
    sonson226 Level 1 Level 1 (0 points)
    I have the same problem...I will try the fix. Right now I am stuck in Reset mode: white apple --sssssllllooooowwwww moving bar.
    I am waiting.

    Also noticed the same problem with ringtones purchased via iTMS, The ones I made in Garage Band play perfectly -- all else that was purchased: nada musica. Grande problemo Apple....

    Also: apps try to load, but then I am back at the home screen....

    And finally: I have 4 updates to the apps I bought, but I cannot update them, because when I go to the screen to update them, I get a message that says: "There are no updates available for this account."

    Native apps all work great. Just little else....
    2.0 Upgrade: not so good!
  • 11. Re: Purchased Music Not Playing
    Jessie Angel Level 1 Level 1 (0 points)
    I'm having the same issue here. It seemeds to work fine with some purchased songs, but not with others. It's so annoying. Ring tones seemed to be affected too.

    UGH!!!
  • 12. Re: Purchased Music Not Playing
    mcolson5 Level 1 Level 1 (0 points)
    Same issue with my 16gb ipod touch. Regular music fine, purchased music is fine on computer but, when i play it on my ipod, the song plays but no audio. It's not even letting me get audio from songs I originally bought on my ipod's itunes store. I just don't get it, i've tried messing with authorization stuff and nothing's working.
  • 13. Re: Purchased Music Not Playing
    twoshirts Level 1 Level 1 (0 points)
    I have 32 gig ipod touch. Had same problem. Spoke with Tech. Make sure that the pc you are using is authorized. In itunes go to store>authorize computer. Had to restore ipod to factory default. Resync entire library from scratch. Do not use a backup from the ipod.
  • 14. Re: Purchased Music Not Playing
    ds_dsp Level 1 Level 1 (0 points)
    I had this same issue after upgrading to the 2.0 software. None of my purchased music or videos worked on my iPhone. I updated the software again and everything worked fine. Try doing this and see if it works. Best of luck...
1 2 Previous Next