Previous 1 2 3 4 5 Next 68 Replies Latest reply: Sep 8, 2008 2:02 PM by socceteer Go to original post
  • Aggrajag Level 1 (0 points)
    (Long post but I hope to explain it in detail to maybe help others.)

    I had this same problem last night. My iPhone 3g (with the supplied operating system, no upgrades or tampering) was working fine but after a sync/backup all my downloaded apps would not work. All the built-in apps worked fine but everything I had downloaded would not run - they start for a second (ie. the loading screen) and then drop back to the iPhone menu. This was tested individually for every app I had installed (Aurora Feint, Bejeweled 2, Cube Runner, Enigmo, iBeer, iPint, Midomi, Moonlight Mahjong, PhoneSaber and SplashID.)

    I tried a full power off/on several times to no avail, even waiting overnight before trying again. (To perform a full power off hold the top power button for several seconds then swipe the red Power Off bar that appears.)

    I then wanted to delete an app as mentioned here but couldn't as I'd never got apps to sync. I investigated how to do this (as it's not as obvious as syncing music/photos/calendar etc) and performed "Authorize computer" (in the Store menu) on my iTunes and then ran "Transfer Purchases from xx's iPhone" in the File menu. All my apps then appeared in iTunes in the applications section of my phone.

    I then felt safe to delete an app from the iPhone so I picked on Bejeweled 2 and removed it. (To do this hold down any icon until they all start to wobble and then click the red X.) My iPhone was actually still docked and after forcing a sync the application did not re-appear. I unplugged the iPhone, plugged it back in and upon this auto-sync the application was automatically reinstalled.

    Wonders of wonders, every single app now worked again.

    It's a pain, and will no doubt be fixed, but that's a simple solution for now.

    I recommend choosing an app to remove/reinstall that does not save any settings - perhaps a gimmicky thing like iBeer because I did lose my saved settings for Bejeweled.

    Hope this helps someone.



    Message was edited by: Aggrajag
  • Xacto Level 1 (0 points)

    I just had the same problem... when I tried to run ANY 3rd party programs it would go black and then back to the main screen. I had to restore my iphone to make the applications work again. This process takes an hour each time. Not happy about this.
  • credford Level 1 (0 points)
    Thanks Aggrajag. This worked for almost all of my apps.
  • ireadcomics Level 1 (100 points)
    I was good for a few days and it just happened again. then my iPhone restarted. It's frustrating.
  • TigerSSMac Level 2 (180 points)
    I'm having this exact same problem, already did the restore once on day 4 and here it is day 7 and I'm having to delete apps and redo it a second time. !!! Resetting the iPhone 3G does no good.
  • TigerSSMac Level 2 (180 points)
    Ohh, one other thing, been trying to delete the apps from the iPhone itself and the dang apps won't stay gone. Reset the phone and there they are, right back after I just cleared 2 pages full of them. Arghhh!!
  • ianolito Level 1 (5 points)
    I am experiencing the same problem on an iPod Touch. Installed Remote and it worked for a while but after a sync it won't start anymore. Hope this gets fixed.
  • defecta Level 1 (0 points)
    im noticing the same issues with 2.0. and many others. i ***** so bad i went back to 1.1.4.

    I was getting constant wireless dropouts on 2.0 where 1.1.4 had no issues.

    AFAIK this IS widespread. Everyone i know who has the new iphone wants their old one back. Im glad i didnt get one just yet.

    This needs a fix ASAP but i wont hold my breath. It looks like Apple has their hands full ATM with MobileMe etc so im not expecting anything soon.

  • Disco Volare Level 1 (0 points)
    mine started doing the same thing the day I bought it. The only app I had installed at the time was Phone Saber. It worked until I turned the phone completely off during a movie; when I turned it back on the app wouldn't load. It's happened three times since then and always after I turn the phone off. The repair guys at the Apple Genius shop said Apple was aware of the problem and to just not turn the phone off until a patch is created. Other than having to re-download all my applications I am really enjoying my 3G. Pandora was a nice surprise that just sets this phone way above anything else out there!
  • Mitchell Harris Level 1 (55 points)
    This fixes applications opening then quitting without requiring a long restore or resync process:

    Uncheck Sync Applications. It will warn you about deleting your content--just press OK. As soon as it begins to sync, Check Sync Applications and press Apply. If it begins to backup, press the x.

    One app may be reloaded and lose it's content, but that should be it. After this, all applications should work.

    Goodness gracious though. Apple should fix this.
  • verlogh Level 1 (0 points)
    This has a bug that's been cropping up every few days since I got my phone. What's truly irritating is that I have eReader, along with several books loaded on my phone. I get halfway through a book, and then it stops working. When I reload the program, I have to redownload and reactivate all my books, then try to find where I left off.
    It's also kinda embarrassing when someone wants to see what your new phone can do, and when you try to start up an app, it just refuses to start.
    "Oh it does this sometimes. Let me try another"
    And then none of them seem to work, and I have to redownload them.
    Please fix this.
  • Aaron Y Level 1 (0 points)
    Just another example, I am a IT specialist with over 20 years experience, mostly working with Apple products. Both my girlfriend, who is using a 1st generation iPhone, and I (3G), have had apps crash, causing not only the rest of the apps to not launch, but eventually causing either cache files, or something else in the memory or operating system to get so corrupt that both of our phones have gotten stuck on the white apple. Hers once, mine several times because of the number of applications I have tried out and played with. The other reason Apple should be concerned is the fact that a large number of iPhone customers are taking their phones back and exchanging them for new phones and receiving new phones costing Apple much time and money. Apple needs to fix these bugs ASAP.
  • Aaron Y Level 1 (0 points)
    You are luck you do not work at Apple right now or Jobs would be punting your butt straight out the door for being so cocky. I am sure there is a lot of crap flying at Apple these days!
  • defecta Level 1 (0 points)
    i have installed 2.0 twice now and the second time Mail would 'crash' every time it was started.

    After a little googling i found that it was a permissions issue and that it was cause by conflicting permissions that the application Mail had been assigned. The behaviour of Mail was exactly the same as the issues i was having with App Store Apps that i had downloaded and decided to no longer run.

    Could it be that these apps that are 'crashing' just dont have the right privileges that they need to run correctly? Like Mail did?

    Unfortunately for most the only way for me to correct this issue was to 'liberate' my iPhone and install OpenSSH so i could edit the permissions. (google "mail iphone permissions terminal" to find a walk through)

    I also found that i needed to authorize my Macbook in order for Apps to sync between the two or otherwise i got an error. Its somewhat annoying that I wasn't told that i needed to do this as it was only after much fiddling that i found this solution.

    if only someone from Apple would acknowledge these issues and let us know to expect a release...sigh
  • SMR Level 2 (205 points)
    I too am having the same problem, but I also get back a message when I try to view or listen to synced media, the iPhone says that it isn't there. "No Content" available...