Previous 1 2 3 Next 68 Replies Latest reply: Sep 8, 2008 2:02 PM by socceteer
ireadcomics Level 1 (100 points)
I downloaded some apps to use with the 2.0 update on my new iPhone 3G. The problem is when I click an app to use it, it will act like it is opening, hang for a second, then go back to my home screen. Anybody else experiencing this or know a solution?

iMac/iBook G4, Mac OS X (10.5)
  • Jefe Tapa Level 3 (925 points)
    Try deleting the app from the iPhone (put the iPhone in to edit mode and tap the "X" icon). Then delete the app from the iTunes library.

    You should now be able to purchase/download the app again from the iTunes Store on your computer-- you shouldn't be charged again at all. Once you've downloaded it to iTunes, sync it to your iPhone.

    Good luck!
  • boozedog Level 1 (5 points)
    I'm having similar problem -- except that it's every downloaded app that's behaving this way! Even the Apple Remote software!

    Non-downloaded apps are working OK.
  • SimonLee Level 1 (5 points)
    yup, major, major problem for me too!! 1 in 3 app hang.

    The only way i have got round this is to re-set the iphone and they work fine after that.. untill they crash again...

    <Edited by Moderator>

  • ireadcomics Level 1 (100 points)
    Yeah, a fix is desperately needed. It's on all downloaded apps so my guess is it's Apple's issue.
  • A A P L Level 7 (21,730 points)
    Oh come on.
    I've got 20 apps on mine and they all work, sans one and I deleted it.
    I love when people start going to "Just like Microsoft" when they can't make something work.
    Give the rants a rest.
  • A A P L Level 7 (21,730 points)
    Any app can cause a problem - just like a computer - which the iPhone really is.
    I would try to resist the temptation to install tons of new items at one time.
    Most of them are also 1.0 and will need fixing.
    Apple and other vendors will be updating things as we go - it's the first day, and it's not going to be perfect.
    I download apps all the time for my Macs, and some don't work.

  • Iain Collins Level 1 (0 points)
    I have this problem too. Currently no 3rd party applications will start on my 8GB iPhone 3G.

    At first, it was just a couple of free applications which all worked for the first few times, then suddenly stopped working. Deleting and re-downloading them fixed the issue but it came back, eventually. Now - for no apparent reason, it wasn't even reset - none of the third party applications (about 2 commercial applications and about 10 free ones) will start.

    The iPhone has plenty of free space on it (at least 500 MB). All the built in applications work without issue. Restarting the device does not fix the problem.

    "AAPL" doesn't seem to understand the issue and as such probably shouldn't be commenting.
  • A A P L Level 7 (21,730 points)
    Well, lain, seems you might be the one that doesn't understand how to work the iPhone.
    I get it.
    I had a couple apps that caused grief.
    I deleted, reset, and it's 100% now.
    Not that difficult.
    Something apparently corrupted on your iPhone.
    A restore might be in order.
    It happens on iPod Touches too.
    The above often, if not usually fixes things.

    Good luck.
  • TomRo Level 1 (0 points)
    Sorry AAPL, but lain's correct on this one. You seem to have had a different issue or the same, but to a differnet degree. I have the same problem as lain on my iPhone 3G. All apps breaking off the startup process and returning to home screen.
  • boozedog Level 1 (5 points)
    so i ended up restoring. tried first from backup but problem persisted. so did a clean install ... not a good workaround tho ... lost all my voice messages, settings, etc.

    still, love the device, but looking forward to the next point release
  • setec Level 1 (30 points)
    AAPL - you are clearly wrong. This is a widespread problem. If it it's not raining at your house it doesn't mean it's not pouring everywhere else.

    It seems that a lot of this time the problem reappears for fixed apps when syncing with iTunes. Then after unplugging the iPhone, the apps don't seem to work.

    I agree, a fix is needed ASAP.
  • A A P L Level 7 (21,730 points)
    You are joking.
    Evidence is sorely lacking for that statement...
  • Iain Collins Level 1 (0 points)
    A follow up...

    This contains other, not directly related bugs, but all that occurred during the process of getting to where I am now (which is working again, for now).

    Because their is one specific app I wanted to run, I deleted it and tried to re-download it (just as I had done successfully before, when it was only 2 or 3 apps that had stopped working).

    This time the App Store (on the iPhone itself) informed me that I "Only had permission to download software from the UK store". That should be correct, as I'm in the UK and it's a UK account, it was just incorrect in asserting I was not in the UK.

    So .... I connect the iPhone to iTunes (which I've synced it with three or four times now without issue).

    I saw from the Info tab in iTunes (which happened to be open at the time) that iTunes also thought I didn't have MobileMe enabled on the phone (for Contacts, Calendars and Web Browser settings) - previously it was displaying the correct information. I turned the MobileMe sync settings OFF and then back ON while the device was still plugged in and iTunes updated the information in the Info correctly immediately (without having to sync or even disconnect+reconnect the iPhone).

    So, having resolved that issue, I downloaded the app I wanted from the iTunes Store on my Mac - which worked fine - and hit Sync. On sync it removed all the other sync'd applications without warning (something it had not previously done), very annoying of course.

    The one app I've re-downloaded now works (and, after turning off the option to automatically sync all applications off in iTunes to prevent it deleting applications that have been downloaded directly to the phone). Immediately after doing that I found I could now also download applications using the App Store on the iPhone itself.

    Really, really buggy - and obviously more than one issue here. The general state of MobileMe/.mac accounts being messed up (my .mac website is still not working fully...) contributed to this problem, as did some unfortunate design decisions in iTunes (i.e. that it defaults to removing any existing apps installed on the iPhone without warning the first time you sync after downloading an app via iTunes).
  • Iain Collins Level 1 (0 points)
    Just to confirm, the behavior you describe exactly the problem I am (/was) seeing.
Previous 1 2 3 Next