11 Replies Latest reply: Nov 3, 2008 11:27 AM by elitebox007
therichard Level 1 Level 1 (0 points)
Every time my computer wakes up I get the message "Connection Lost" referring to the mouse (Mighty Mouse) and keyboard. I have to wait a couple of seconds for them to start working. I tried to remove them from the list of Bluetooth devices and then pair them again, but had no success. It's pretty annoying to have this happening everytime the computer wakes up.

Is anybody else experiencing this? Any suggestions?

Thanks.

richard

MacBook Pro 15" 2.33 GHz Intel Core 2 Duo, Mac OS X (10.5.4), Dual Screen 23" HD Display
  • robbalaam Level 1 Level 1 (0 points)
    I actually have the same issue. I am also losing connection while I am useing both my mouse and wireless keyboard. Never has happened until this week. And it happens all the time. Anyone else
  • creese Level 1 Level 1 (0 points)
    I have an older white apple wireless keyboard. I paired it successfully, but every time I restart the computer, it won't work. I have to go through the pairing process all over again, and turning the keyboard off and and back on seems to be required.

    Very frustrating.
  • itsalljustaride Level 1 Level 1 (0 points)
    I have this issue as well, and havn't found a sufficient answer on the forums as of yet.

    I can pair my mouse every day, and it will work fine, until I leave it at night when my computer shuts down. When I return in the morning I have no mouse, and have to go back to the bluetooth setup wizard and re-pair the mouse by turning it off then on again. I can't even just come in and turn the mouse off and on and have it work. I have to actually go through the setup wizard.

    I CAN however, go to the bluetooth preferences, click on the mouse, and choose "connect" when it is turned off, then turn it on and it will connect without having to re-pair, but this is just as tedious and annoying as the whole setup process.

    It's so annoying to have to have a wired mouse plugged in just so I can pair my wireless mouse every morning. Kind of defeats the purpose of a wireless mouse.

    When I orginally bought the mouse and keyboard I had to return the original mouse because it wouldn't hold a connection even when I was using it. Obviously these wireless mice of Apple's need some more TLC in the engineering dept.
  • jgrotepass Level 1 Level 1 (0 points)
    I am using several Bluetooth Keyboards and mice for my Apple(s). Never had the issue you are describing.
    So, here is what I am doing:
    After pairing mouse and Keyboard I go into the System-Settings and select the Bluetooth-Setting.
    I select (i.E.) the mouse and then click the little gear on lower side and choose "Show more Information" (or similar - I have the German version of 10.5).
    At least I swith the "Favorite" for my mouse and my keyboard.
    Also you should check if your Bluetooth is switched to "On" when you start or wakeup your computer.
    Finally there is a button "More Option" on this screen on the lower right side.
    Click that and check the checkboxes and read the text.
    Switch on the options that you might find interesting.

    Maybe this helps a bit.
  • therichard Level 1 Level 1 (0 points)
    I'll try that, thanks for the tip.
  • Ratton Level 1 Level 1 (0 points)
    Hi. I was having the same issue. It was impossible to use my aluminum wireless keyboard for more than five minutes without getting the connection lost message. When the connection was restablished the keyboard would often send repeated keys to my macbook. But I've tried something and now it's working perfectly. Actually I'm typing this message with my wireless keyboard. I could never type a message this size before fixing this issue. I'll explain what I've done, but my Leopard is in Portuguese, so I'll try to translate the best way possible:
    1 Go to System Preferences and click on Bluetooth. Remove the wireless keyboard.
    2 Now click on + to add a new Bluetooth Device.
    3 do NOT select Keyboard. Choose the last option "Any device".
    4 In the next step, click on "Key-pasword options"and choose the first option "Auto generate a key-pass" and click OK
    5 Now select the keyboard on the devices list and Continue.

    Since I've done this, I've been working with my keyboard for 5 days without any single lost connection.

    I hope it works for you too!
  • MLemmon Level 1 Level 1 (0 points)
    I am also having a chronic "connection lost" problem w/my wireless keyboard and mouse. It's worse with my keyboard. It's the full size 109 key version (white w/clear plastic base). Apple's got to resolve this. I've had my computer in 3 times now (Apple Care) to fix the problem and it's still NOT FIXED! FYI ... "connection lost" w/keyboard has happened THREE times while typing this post. I'm starting to regret switching from PC to Mac.
  • pickmynose Level 1 Level 1 (20 points)
    often browsing the bluetooth device will get it up and running pretty fast. I have the computer setup to display the bluetooth file exchange status at the top of the screen. Even though the mouse/keyboard have no bluetooth file exchange protocol, its usually sufficient to browse the device for it to be re-paired again.
    The best option is to turn off sleep mode on the computer. You can have it sleep the display instead which would solve the issue with losing bluetooth connections
  • pickmynose Level 1 Level 1 (20 points)
    try testing for wireless interference. Move your computer/bluetooth mouse etc to another room and see if you are having the same issues. Remember, bluetooth is a radio frequency connection and interference can cause a lot of issues with it. For instance, turning on a desktop light screws up the bluetooth totally since I bought a UPS and requires rebooting the computer to fix the issue. Re-pairing doesn't seem to work. Just turning the light on/off totally screws up the bluetooth because of electrical noise so I've had to banish the light to the never use junk pile.
  • elitebox007 Level 1 Level 1 (0 points)
    Open System Preferences --> Network. If Bluetooth is listed as a networking service in the left sidebar (and you are not using Bluetooth for networking), remove it from the list. You do this by highlighting Bluetooth and clicking on the minus sign. You can add it back later if needed. Click the Apply button. You may want to restart.
  • elitebox007 Level 1 Level 1 (0 points)
    Open System Preferences --> Network. If Bluetooth is listed as a networking service in the left sidebar (and you are not using Bluetooth for networking), remove it from the list. You do this by highlighting Bluetooth and clicking on the minus sign. You can add it back later if needed. Click the Apply button. You may want to restart.