Previous 1 2 Next 17 Replies Latest reply: Nov 13, 2008 2:08 PM by diedoggie
Elsewhere42 Level 1 Level 1 (0 points)
It took a few hours but I found the solution to this problem.

Here is a brief description of what happened:

Went to App Store on my new iPhone 3G and downloaded three applications: Monkey Ball, eBay and Jott.

At first all three worked. (Monkey Ball is a great game but difficult to control)

I stopped running the applications and did some other things with my iPhone 3G. (email, safari, you tube, etc...)

I then tried to run Monkey Ball again. It showed the Splash Screen for a few seconds and then the iPhone went back to the main display. The Monkey Ball application just "turned off" and went away.

I tried to load the other applications and ran into the same problem. They would try to load and then the main iPhone display with the icons would show.

I tried to do a full reset by holding both buttons for 10 seconds. That did not help.

I was about to do a restore when the solution occurred to me:

1: Hook the iPhone to your computer and start the Sync process.

2.1: iTunes will ask you if you want to transfer your applications to your computer. It will warn you that if you don't the applications will be deleted from your iPhone. THAT IS WHAT YOU WANT.

2.2: If you have already transferred your applications to your computer, then BEFORE you start the sync you need to delete the applications from iTunes on your computer. Do this by clicking on Applications in the left menu and then right-clicking on the bad application and selecting Delete.

3: Tell iTunes that you DON'T want to transfer your applications to your computer and allow it to delete the applications from your iPhone.

4: Reset your iPhone by pressing the two buttons for 10 seconds.

5: Go back to the App Store and re-download and install the application(s).

NOTE: It will look like the App Store is going to charge you for the application again but at the last minute it will say that you already bought the application and will not be charged.

Basically what you are doing is deleting the application from your iPhone and reinstalling it.

iPhone 3G, Windows Vista
  • Alex Bottinelli Level 1 Level 1 (15 points)
    Another solution would be to go to the Application Tab in iTunes for your iPhone and deselect the Applications you want to remove from the iPhone. When you sync again, the offending applications will come off. Recheck them, sync again, and they'll be reinstalled.

  • RonAnnArbor Level 4 Level 4 (2,705 points)
    By the way -- I have found that Monkey Ball messes up the iPhone consistently -- if you play it for awhile, then close it and go back to doing other things, you'll find that everything runs at a crawl, that sometimes some of the programs don't open. A reset clears it all out. I haven't found any applications other than Monkey Ball that seem to have this effect.

    I found that it wasn't worth it to keep the game on the iPhone. Waste of money, despite the cool graphics, but not worth whatever processor background things it has going on that don't seem to clear out when you exit the program.
  • joebogdan Level 1 Level 1 (0 points)
    Thanks, that solved it for me too.
  • metec Level 1 Level 1 (0 points)
    I have the same issue and the fix only works for about a day. So I have to redownload the apps pretty much everytime I want to use them.
  • Alex Bottinelli Level 1 Level 1 (15 points)
    Have you tried rebooting the phone to see if that clears the issue when the applications won't launch?
  • metec Level 1 Level 1 (0 points)
    Yup, many times. It's not all the apps at once. For example right now AIM won't work and the only way to get it to work is to delete it and redownload it.
  • Alex Bottinelli Level 1 Level 1 (15 points)
    Well, then I would suggest doing a full restore to the phone. See if that fixes the issue. Restore from backup should be just fine. If THAT fails to work... then I would recommend doing a full restore again but DON'T restore the backup. Instead, just let the iPhone resync everything from scratch. Bad thing about that option, however, is that you'll lose any notes or POP mail or any other such information that's on the phone. But, you may lose the problem too.

  • Marie-Claude Leblanc Level 1 Level 1 (0 points)
    Hello everyone,

    After using my iPhone 3G without any apps problems for 2 weeks, I just began to get problems tonight. I was "kinda" reassured when I read that I was not the only one getting this issue.

    I was not able to open any app. Not one.

    I charged it, resynced-it, reset it, nothing worked and then, I updated 3 apps (you just have to click on the app store and click update all) and all apps (around 20) are now working perfectly fine....


    Could this be the problem?


    Message was edited by: Marie-Claude Leblanc
  • New-Apple-Guy Level 1 Level 1 (0 points)
    I too am having the same problem: All my previously working apps... stop working.

    you just have to click on the app store and click update all) and all
    apps (around 20) are now working

    Exactly where is this "update all" button?
  • Marie-Claude Leblanc Level 1 Level 1 (0 points)

    Sorry for not replying sooner. Just read your post. You need to go in the App Store and at the right of search, you have Update. Tell me if it works. It worked 2 times for me !

  • toddjb Level 1 Level 1 (0 points)
    I'd like to join the "Downloaded Apps Not Working" club as well.

    I pretty much have had the exact same experience. I downloaded several apps. They all worked. Now none of them will run.

    Does anyone know why this occurs or if there is anything other than a temporary fix? (It sounds like the uninstall/reinstall fix is only temporary).

    I tried going to the AppStore and the "Update" link, but it says "All Apps Up-to-date."

    Anyone have a guess on this one? Thanks.
  • DANIEL101 Level 1 Level 1 (0 points)
    The problem has to do with the iPhone OS 2.0.2. It is still buggy.

    My unit at first froze, however, I was able to shut down and restart the iPhone. After restart... ALL my App Store apps stopped working (launch at first then go back to home screen). ARGGGGG !!!!!!

    I noticed initially when I installed apps from my iMac to the iPhone it took:
    5 seconds per app....
    after 30 installed apps it took 60 seconds to install an app
    after 90 installed apps it took 70 seconds to install an app
    after 110 installed apps it took 75 seconds to install an app

    The last app never installed, instead I got this unknown error (0xE800002d) go figure.
    110 apps equaled to 324 MB... plenty of free space left. What gives?

    I believe, Apple's OS has a serious problem managing flash memory, in particular in the app layer of the OS. When the OS tries to thread from one mem array to another in our case, OS array to App array, there exists too much latency and the app crashes & corrupts the iphone app kernel. The temp fix would be to just re-install the iphone app kernel upon iphone reboot.

    I believe, Apple has incorporated some cheap flash memory from particular manufacturer(s) with slow read and write times and now they are having to scramble to re-write code in the OS to compensate for the NAND chip differentials of millions of deployed iphones they have put into the market.

    Let's all hope Apple can put their arms around this issue and put it to bed.

    I'd like to use the apps I bought one day and not worry about the apple screen of death!
  • DANIEL101 Level 1 Level 1 (0 points)
    Another user posted this. Hope this helps.

    2.0.2 has been de-authorizing iPhones. Meaning the account you use for the iTunes store and the App store is no longer being "read and/or found" by the iPhone. This causes the exact issue you're describing.

    The fix for it is to open iTunes and click on "Store > Authorize Computer" and enter you information in while your iPhone is plugged in. Then run a sync to be safe.


    Better yet just buy a song or grab a free App directly on your iPhone and enter your information again. It adds the authorization back in. Once that's done, your other Apps should run.
  • ml12 Level 1 Level 1 (0 points)
    Once I had this problem and fixed it by logging out of itunes store on my pc, then syncing allowing me to re-enter account info in app store.

    Now i have the problem again and nothing fixes it.

    I think having too many apps (7 pages) may be the cause..

    Does everyone else having this problem have a lot of apps?
Previous 1 2 Next