Skip navigation
This discussion is archived

AppStore problems; Apps don't launch

12154 Views 49 Replies Latest reply: Nov 10, 2008 6:49 PM by ushkdavid RSS
1 2 3 4 Previous Next
Mark Round Calculating status...
Currently Being Moderated
Jul 13, 2008 10:49 AM
This is turning into an absolute farce, as if the problems on launch day weren't bad enough.

I have purchased two applications today through the iPhone's AppStore, and both times I have the same problem - which I have seen other people talking about as well: The applications downloaded but then took a very long time during the "Installing" phase, and then once that had finished, they won't start.

Tapping on their icons just makes the iPhone pause, and then I get chucked straight back to the home screen.

I have tried deleting them and re-installing: same problem. I am also getting frequent "App Store is not available" messages and timeouts when browsing apps, from this I am guessing that the app tries to contact the store during the final part of the "installing" phase, times out, and leaves a broken application installed.

So, not really making a very good impression at the moment. I assume that as I can re-download applications, I haven't actually lost any money but it still makes the whole thing look like a complete shambles.
  • DaneBlankenship Calculating status...
    Currently Being Moderated
    Jul 13, 2008 11:45 AM (in response to Mark Round)
    I'm having the same issue with the MLB.com At-Bat application. It worked fine yesterday, but today when I open it I am thrown right back to the home screen.
    Dell Latitude D830, Windows Vista
  • DaneBlankenship Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 11:57 AM (in response to DaneBlankenship)
    I was able to finally get MLB.com At-Bat to launch.

    I originally purchased the app directly from my iPhone. After my first sync it stopped working. So I removed the app from iTunes and then started another sync. This removed it from my iPhone. I then downloaded it from the iTunes app store (for free since I had already paid for it) and initiated yet another sync. This time iTunes installed the app on my iPhone and now it works again.
    Dell Latitude D830, Windows Vista
  • jonesv70 Calculating status...
    Currently Being Moderated
    Jul 13, 2008 12:00 PM (in response to DaneBlankenship)
    Having the same problem! I dont understand it. So you buy a game or App from the App store, works fine once installed. Then the next day the App fails to work, throws you back to the home page and there's X amount down the drain. Cheers Apple.
    iphone
  • thirdinline Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 12:50 PM (in response to Mark Round)
    Yep, same for me, downloaded a few apps both through itunes and on the iphone through the apps store.

    They launched once when I first downloaded but now don't launch. I've deleted both on itunes and the phone, reinstalled etc but still no joy. This is not good enough!

    Come on, whats going on??
    iPhone
  • MTLM Calculating status...
    Currently Being Moderated
    Jul 13, 2008 12:53 PM (in response to Mark Round)
    Same here. Everything worked fine until I synced my iphone for the first time. Now none of the 3rd party apps work.
  • dartagnan64 Calculating status...
    Currently Being Moderated
    Jul 13, 2008 1:05 PM (in response to MTLM)
    Same problem for me with Aurora Feint. Texas Hold em just freeezes on loading and I have to hit home again to get oout of loading screen Re-installing didnt work for Texas Holdem and only briefly worked for Aurora feint. Assume iPhone 2.0.1 to be just around the corner if this becomes a big issue.
    MacBook Pro, Mac OS X (10.5.4)
  • Robert Gruber1 Calculating status...
    Currently Being Moderated
    Jul 13, 2008 2:46 PM (in response to Mark Round)
    Same here. Apps worked fine yesterday, now when I try to launch them they hesitate and throw me back to the home screen. This is on my iPhone Edge. It affects purchased apps as well as free apps and even the apple remote app.
    iMac 20' CoreDuo, Mac OS X (10.4.4), iMac 17' G4, PB G4 15, Cube, Mac Plus
  • voodoogmr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 5:45 PM (in response to Robert Gruber1)
    Same here. All apps I downloaded directly from my 3G suddenly stopped launching. Deleted them from the phone and tried to sync them from iTunes, but just got an error that said my phone wasn't authorized to use these. So, I deleted all the apps in iTunes and re-downloaded them all on my iMac and synced them. Seems to be working for now.

    Kinda defeats the purpose of having the App Store application on the phone, but I'm sure this can be be fixed. Just kinda stinks if you have games like Aurora where you can lose your saved game. sigh
    24" iMac Core 2 Duo, 2.33GHz, Mac OS X (10.4.9), 2GB RAM, NVIDIA 7600GT w/ 256VRAM, 750GB HDD
  • djholla Calculating status...
    Currently Being Moderated
    Jul 13, 2008 10:16 PM (in response to Mark Round)
    Same here. Absolutely ridiculous. OneTap Movies just crashes and snaps back to the home screen every time it is launched - although it worked prior to syncing. I had to restore my phone and set it up as a new phone to get it working again. Now it's back to crashing after syncing. Utterly ridiculous and completely unacceptable.

    I am really disappointed in Apple - apps crashing constantly, MobileMe/.Mac aliases have disappeared from Mail.app on the Mac and aren't available to send from on the iPhone either, MobileMe updater issues...the list just goes on.

    Too bad they don't seem to read feedback or these forums. Don't they use the iPhone themselves? I mean sh*#!, we've only had the 2.0 firmware and MobileMe for 2 days now and we've been plagued with constant issues. At least an acknowledgement that something is going on would be nice. I could at least respect that.
    Mac OS X (10.5.4)
  • maxwellro Calculating status...
    Currently Being Moderated
    Jul 14, 2008 12:07 AM (in response to djholla)
    I too am having this problem. All of my third party apps begin to launch, but then revert back to the home screen. There was no problem for the first two days that I used them.

    Does anyone know
    1. What is causing this to happen?
    2. How to fix it?

    Thanks!!
  • bb426 Level 1 Level 1 (75 points)
    Currently Being Moderated
    Jul 14, 2008 12:21 AM (in response to maxwellro)
    wow...i guess i'm not a loner on this issue...EVERY SINGLE APP that i've downloaded FROM MY PHONE has booted me out of the app.....i have the original iphone and i think this has to do with either the syncing job that iTunes does or the install job that the phone does....this is sort of disappointing because just now, i have had to reset my phone and wait about five minutes+for it to finally show the home screen....it just showed the apple sign for that time... i dont have a ton of apps on my phone, and idk why it's been so slow...and btw, has anybody noticed that when you sync the phone to iTunes, it takes forever to backup the phone? i just want to sync the phone and not have to wait nearly 20 minutes to back up each time...
    HP Pavilion dv9308nr Notebook PC, Windows Vista, Vista Home Premium, 2 gig RAM, AMD Turion 64 x2, 1.60 GHz, NVIDIA GeForce Go6150
  • mtibbitts Calculating status...
    Currently Being Moderated
    Jul 14, 2008 5:43 AM (in response to bb426)
    bump, me too on the same issue...10+new apps and the all push me back to the main screen
    iphone 3g, Other OS
  • Inter VCIP Calculating status...
    Currently Being Moderated
    Jul 14, 2008 11:18 AM (in response to Mark Round)
    Ditto.

    Eight apps, all working yesterday. After sync, NONE of them work.

    Let's see some action on this, Apple.
    MacBook, Mac OS X (10.5.4)
  • MeatMuppet Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 14, 2008 1:42 PM (in response to Mark Round)
    Same. All apps stop working after sync. You can have newly downloaded working apps alongside broken ones but one sync kills them for me.
    Windows XP Pro
1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.