Previous 1 2 Next 21 Replies Latest reply: Jul 23, 2008 4:02 PM by rokkuramu Go to original post
  • thelimodrivers Level 1 Level 1 (0 points)
    this might sound dumb, but it worked for me- after reading this thread, i just went downstairs and reset my high speed internet modem by unplugging the power cord. After that i could connect on my ipod touch, but not my laptop, so i reset the modem again.

    i just typed this on the laptop, and im on itunes store on my ipod.

    hope this helps.
  • doh1231 Level 2 Level 2 (210 points)
    i can connect to my Router fine, and even bring up the router config pages on my iPod Touch.... yet i cant get past the router to the outside world.

    This iPod Touch worked fine for a couple days with the same router, then today it just stopped... no configs changed anywhere. I have another iPod Touch, exact same, in the house, and it still works fine. I tried all kinds of resets and even blanked the ipod and did a full restore without using a backup... even right after the restore (which was 2.0 ...?) before i put on a single thing, it still would not work. This is some type of major screw up on Apples side...
  • zjohnsonua Level 1 Level 1 (0 points)
    Just tried the on/off switch+home button reset thing and after powering back up it all works right away. I love my ipod and mac but apple has some serious glitches when it comes to their "upgrades"...
  • doh1231 Level 2 Level 2 (210 points)
    ive tried the reset like that numerous times, and still cant get on the internet
  • thelimodrivers Level 1 Level 1 (0 points)
    ok I've got it. if you can, update your router firmware. Some routers aren't up to date, which makes them incompatible with the 2.0 firmware.

    give it a go, hope this helps.
  • gar2232 Level 1 Level 1 (0 points)
    Same thing. when are going to get 2.1 to fix this? and here's the kicker. I paid the 19.99 for the January update and now the 9.99 for the 2.0. I spent 30 bucks where had I waited I would have spent only ten. Get us an update to fix this wifi problem please.
  • rokkuramu Level 1 Level 1 (0 points)
    Okay, I had the same problem and I was able to fix it by doing this. First go to your router system. I have a D-link router so I just typed the IP address into my browser's address bar and it'll take me to control panel. There, look around for the download section because you'll need to *upgrade your router's firmware*. In another post somewhere on this board, someone explained that because the firmware on your router may be old that's why it can't connect with the iPod with the 2.0 firmware. So I updated mine and it's working great now.

    Afterward, before connecting to the router again, also try restarting your iPod by holding the Power and Home button together until the screen blacked out. *Continue holding* it until the gray apple logo come back on.

    Hope this helps!
Previous 1 2 Next