Previous 1 2 Next 17 Replies Latest reply: Aug 15, 2008 8:44 AM by DaddyPaycheck
Brent D. Level 1 (0 points)
For a while now, my G5 would have intermittent problems not finding the network after it has been asleep for a bit. I used to resolve this by resetting the router, or sometimes putting the Mac back to sleep and resetting the router.

Lately, I discovered another fix: wake up my MacBook. The MacBook wakes up, connects wirelessly, and sees the network, and shortly thereafter, the G5 sees it too.

I cannot interpret this. Why would it be that the G5 would fail to see the router until after the MacBook is awake (and sees the router)? I never could figure out which component was at fault before, and this further confuses me. I mean, it seems that it has to be the G5, since if another computer can see the net on the same network, it would rule out the router and the cable modem. Right?

So what do I do about the G5, then? Yesterday, it was getting to the point where every time I woke up the G5, it wouldn't find the network (until after I woke up the MacBook).

G5 Dual 2.0 Ghz, Mac OS X (10.4.11), Belkin wireless router
  • DaddyPaycheck Level 6 (16,030 points)
    Hi Brent D.-

    Sounds like a bad router.

    Is the G5 using wireless or is it wired?


  • Brent D. Level 1 (0 points)
    The G5 is connected via a hard wire connection, 10 Base T from the built in port on the G5 to the router.

    Do routers just up and fail like that? By the way, while it was behaving that way most of yesterday, it didn't behave that way today. I'd hate to go out a buy a new router and have this intermittent problem come back.

    Does anyone have a pointer to some diagnostic tests that would help me confirm that it is the router (or something else)?


  • Kenichi Watanabe Level 7 (30,465 points)
    If it's really 10base-T, getting one that's at least 100base-T or even gigabit (like the AirPort Extreme Base Station combo wireless N and gigabit Ethernet) would not be a waste of money. The Power Mac has gigabit Ethernet ports (that's 1000 base-T). It's a fire hose trying to pump water through a garden hose.

    If you upgrade the router, make sure you also upgrade your wires to at least Cat 5e. Actually, maybe poor cabling is causing the unreliable connection.

    My Linksys router failed with no warning. Apple conveniently released the square AirPort Extreme Base Station a few months before, so I got one. It's been rock solid.
  • DaddyPaycheck Level 6 (16,030 points)
    Routers, just like any other hardware, can just up and fail one day.

    Are you sure that you are connected at 10 Base T speed? Take a look at *About this Mac* under the *Apple menu*, select *More Info*, then select Network in the left column of the System Profiler. There you will find your actual connection speed.

    The cheapest thing to try is a new cable and/or new port on the router.


  • Brent D. Level 1 (0 points)
    I mis-spoke: It's 100BaseT.

    MAC Address: (redacted)
    Media Options: Full Duplex
    Media Subtype: 100baseTX

    Still, since now the problem is back to intermittent, I'm stuck with not knowing if swapping a cable or switching the port makes a difference. Any troubleshooting techniques to suggest?
  • John Brand Level 1 (0 points)
    Hi, Brent:

    I would not be too quick to start swapping things out (esp. expensive things!) without letting the discussion flow. I have never seen an answer that worked except updates and not all do... see below.

    My Dual 2.5GHz G5 has been doing this on and off for years. It has been networked wirelessly since I got it and I am on my third router now for other reasons. I run two other Macs (G4 mini and early IMac/Intel) as well as two laptop PCs, all wireless. None of the other machines ever has this intermittent connectivity issue - just the G5. The symptom is a stalled browser (Safari or FireFox) with the wireless symbol almost always at four bars. Once in a while (like today), the bars will fade down to two for a while, but rarely. Absolutely the only temporary fix I have found successful is to switch airport on and off. Cure may hold for a while or it may not. Have noticed some apps using airport still seem to work (an old MacStumbler utility) even when Safari locks up. Thought it might be a Safari bug, but FireFox does the same thing.

    IMHO, this is fundamentally related to a G5 software issue or interaction with the airport or network card. As I noted above, code evolution is a strong factor in my experience. My problems come and go tightly linked to software updates. It is usually a night-and-day change. I am at 10.4.11 on all Macs here; problem had not been around until I ran the last big update to 4.11. Interestingly, my daughter owns a very new iMac with Leopard and has seen the same type of behavior since Day One. I have also seen this problem mentioned about Leopard and iMacs in the lay press.

    Wish I could offer a solution, but I am just waiting it out again.
  • Gary Ludlum Level 1 (25 points)
    Have you tried using a static IP address?
  • Brent D. Level 1 (0 points)
    I'm not sure. The IP address that the router assigns doesn't change, and the setting called "Lease Time" ("The length of time the DHCP server will reserve the IP address for each computer") is set to Forever. Sounds like static to me, but I'm not really sure.
  • pacush Level 1 (0 points)
    I had the same problem but now it got even worse: I can't connect to my network @ all. Rightnow I'm using a belkin usb wireless network adapter which is doing the job just fine. It's a real mystery to me why I can't connect using the airport card since my old powermac dual G4 (also with airportcard) is still doing fine and has no problem connecting and the same goes for my ibook G4.
    I've been searching the net for a solution but haven't found it yet.
    I've been a real mac-addict but lately I find it hard to defend/recommend apple as my powermac G5 has given me more trouble then pleasure…
  • The hatter Level 9 (60,925 points)
    ISPs are always making changes, sometimes there are firmware updates for routers, and network equipment that worked on PPC doesn't always on Intel, but in your case you have an Intel Mac and it works fine, just your G5 with problem.

    I had trouble with my connection after sleep, and it happened running Windows and OS X. Not sure yet why it is fine now other than changed cable.
  • orisinio Level 1 (0 points)
    I'm having the same problem on a dual 1.8 GHz G5. Weird thing is that FTP connections seem to work fine. Browser and e-mail fails most of the time, though.

    Network diagnostics keep telling me my Ethernet connection is working. But then, oops, it isn't! Doesn't matter if I boot from OS X 10.4.11 drive or 10.5. My previous machine, a dual 1.6 GHz G5, was rock solid (until the CPU melted down).

    I, too, am thinking it's a software issue, since 10.4.11 and 10.5 seem to be closely related. I'm going to reinstall 10.4 and not apply the updates to see if the problem goes away. Trouble is, some of my applications require 10.4.11. Grrr.

    I'll do the reinstall and let you all know what happens.


    Message was edited by: orisinio
  • orisinio Level 1 (0 points)
    Okay, I reinstalled OSX 10.4, and am having the same result -- intermittent connections to the internet. I swapped ports on my hub/router -- a waste of time, since this Windows machine I'm using right now has no trouble with the Ethernet cable. Perhaps I'm experiencing some sort of hardware failure in the G5 after all. It seems to be reassigning its own IP address for some reason.

    I've saved a disk image of the 10.4.8 update -- maybe I'll install it next to see if there's a change.

  • orisinio Level 1 (0 points)
    Okay, after reading enough discussions on this topic that pointed the finger to cabling, I pursued the issue. Didn't seem relevant, since my Windows machine and my previous Mac G5 dual 1.6 GHz tower worked fine with the same cabling.

    I went to the System Preferences > Network > Ethernet settings and clicked the Advanced button. Sure enough, my "new" (actually second-hand) G5 was more performant than my previous one, and the connection speed was set at 1000baseT. I configured it manually for 10baseT/UTP, and viola! everything is working fine now -- though it might be faster if I replaced all my cabling and used 1000baseT.

    Don't know if that helps, but it might be a setting worth tweaking to see if things straighten out for you.

  • Brent D. Level 1 (0 points)
    This is not the same problem. When I say that I keep losing the connection, I mean that there is no connection.

    You are saying that FTP connections work, which would mean you are getting some sort of internet connection. You are also saying that Network diagnostics says that things are fine when they aren't, which is not the case for me.

    Quite simply, the network connection drops.

    I just got one clue that is pointing to the router, though: I was using both a G5 and a MacBook at the same time, and both lost internet at the same time. Reset the router, and both got it back. That points, in my mind, to the router.
Previous 1 2 Next