Previous 1 2 Next 16 Replies Latest reply: Aug 26, 2008 5:02 PM by pjbracer1
percival pelican Level 1 (5 points)
Is anyone else getting this error message when they try updating their old iPhone with the new 2.0 update?

It tells me that I have to plug it into iTunes, and when I do it says "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes", so I press OK, it then says "If you are experiencing problems with your iPhone, you can restore its original settings by clicking Restore." I click restore, it takes a few minutes and then gives me this error message... every time.

My phone is now unusable!

Macpro 2.8GHz 8 Core, Mac OS X (10.5)
  • percival pelican Level 1 (5 points)
    I worked it out... seems like the dock isn't such a reliable way of doing updates. I used the lead connector instead and it worked fine.
  • percival pelican Level 1 (5 points)
    Try using something other than the dock to connect the iPhone to the computer.
  • mcarrhorns Level 1 (0 points)
    i'm having the same problem even without using the dock station? i itunes says that it is restoring for about an hour and then at the end say unknown error 6. anyone figured this out yet?
  • MandyLynn Level 1 (0 points)
    I am having the same problem except my error number is 1603. I have tried uninstalling/reinstalling iTunes, turning the phone off and on and following the "unable to restore instructions" on the tech support site. I am using the cable directly connected to my computer, not the docking station. I still get the error message "The iPhone could not be restored. An unknown error has occured (1603.)" Any ideas? Thanks!
  • Lara07 Level 1 (0 points)
    I'm having the same problem..my phone is also unusable now. What is the best way to reverse this process? Please, I am begging someone for an answer!
  • tods27 Level 1 (0 points)
    Got the same 1603 error. I am now trying to restore the iPhone, but it's taking a long time. I'll update if it's successful.
  • tods27 Level 1 (0 points)
    Worked out OK. I hooked up the iPhone to the PC directly (no dock) and did a restore. Note that my iPhone was left with the Apple logo and a processing icon at the bottom of the screen. I had to do a reset to clear that, then hook it up to the PC. After the restore, everything seemed to go well. I did get some funny messages about contact conflicts and it said that it had to update 300+ of my contacts on my PC. Didn't see any data loss.
  • chrisharrell Level 1 (0 points)
    I'm having the same problem, and changing the cabling (and computers) fixed nothing. I took out the SIM card and put in my old motorola Razr and am using that for my phone until I can get this fixed.
  • tachowar Level 1 (0 points)
    THIS WORKED FOR ME....first disconect all usb hardware, don't use the dock, and TRY in EVERY usb port on your computer ! it should work on one.
  • tbeach Level 1 (0 points)
    Similar problems with my upgrade but mine sticks at "Verify iPhone software..."for hours. I have an unusable iPhone and am traveling internationally.
  • kdh05 Level 1 (0 points)
    Add my name to the list. Wow. This is really bad. Lots of people having the same issues. I am getting the "... unknown error occurred (6)" message

    I have tried:
    - removing and reinstalling iTunes.
    - connecting directly to my iPhone (previously I was using the dock connected through USB on my monitor.
    - deleting the downloaded update file (ipsw file).
    - retrying the upgrade restore multiple times.

    I am about ready to try the upgrade from another computer and restore from my main machine (as reported on another thread by "pepsiguy").
  • kdh05 Level 1 (0 points)
    Ok. I finally got it working - just took a lot of work.
    - On my first try I had the phone connected through USB ports on my monitor.
    - After later attempts with the phone directly connected to my PC, I removed and reinstalled iTunes. This didn't seem to help.

    Ended up doing the following:
    - Connected the iPhone to a totally different computer that had never synced with an iPhone.
    - This at least got the 2.0.1 update on the phone.
    - Connected the iPhone to my main computer and iTunes prompted me to do a restore (which I did).
    - I then fell into the endless restore loop described here:
    http://discussions.apple.com/thread.jspa?messageID=7762838&#7762838
    - I finally picked the "setup new phone" option and everything seemed fine.

    Too much effort for such a seemingly simple upgrade. I hope the next upgrade is not this much work.
  • orlinkt Level 1 (0 points)
    What seemed to solve the problem for me was:
    - using a different Windows Account
    - using the original USB cable (not the one from iPhone 3G)
    - unplugging all other USB devices.
  • pjbracer1 Level 1 (0 points)
    You Guys are lucky I get the same problem and mine is only 24hrs old!

    Only just got the thing syncing it with Itunes and it said there was an update so I thought why not before I put anything on the **** thing and now can use it!

    I havent even made a call yet!

    Not the best of starts!

    I am using only the cable and nothing else plugged in USB still doesnt work!

    Looks like it might be goin back!

    Ill keep you posted

    Paul
Previous 1 2 Next