Skip navigation
This discussion is archived

Application stuck at "Waiting for Upload"

6981 Views 12 Replies Latest reply: Aug 15, 2008 10:43 AM by typewriter RSS
whosyourtator Calculating status...
Currently Being Moderated
Jul 14, 2008 6:41 AM
When submitting my application yesterday, I tried to use the web based upload link and the checkbox would never appear for the application binary in the itunesconnect portal. No error message was displayed after the actual upload. The page displatyed 0.9 of 0.9 with an x next to it which just deleted the upload. If I tried to submit as is, the page told me I had to submit a binary, arrgh, which I tried repeatedly.

I then tried to use the "ApplicationLoader" tool. It said the upload was successful but the application is stuck at "Waiting for Upload" status. Anyone else in the same boat? I am using a wildcard appid as the setup suggests. I have checked a couple of other threads mentioning this and how people fixed this. I tried what was in those threads, I am using a wildcard app id.
Macbook Pro, Mac OS X (10.5.4), 2.4 GHz
  • kiichi Calculating status...
    Currently Being Moderated
    Jul 15, 2008 8:13 AM (in response to whosyourtator)
    Hello,

    Check this thread
    http://discussions.apple.com/thread.jspa?threadID=1590980&tstart=0

    I tried "asterisk" (wildcard) for app id and use new provision file.

    But now it's "in review" status forever...
  • appleRyan41 Calculating status...
    Currently Being Moderated
    Jul 16, 2008 9:51 AM (in response to whosyourtator)
    same EXACT thing is happening to me, event with the 0.9 of 0.9 with the x next to it, failed upload on the site and using the ApplicationLoader tool which was successful, but i've been at "waiting for upload" status for about 12 hours now...
    i'm already using a generic app id. so i don't know what i could possibly change to improve this situation??
    any info would help.
    thanks
    -ryan
    macbook pro, Mac OS X (10.5.4)
  • darrensi Calculating status...
    Currently Being Moderated
    Jul 16, 2008 11:38 AM (in response to whosyourtator)
    Same problem here. Uploaded through the ApplicationLoader last night and its still showing "Waiting for upload" on itunesconnect. This is my second app and I didn't have this problem with the first one - the status was updated to "In review" within a few minutes.

    One thing I noticed is that ApplicationLoader itself was acting strangely. On my first app upload, the progress bar chunked along nicely as it was uploading. On my second app upload, the progress bar stayed at zero while the time remaining count quickly counted up to around sixty minutes, then the progress bar went to full and said the app was uploaded.

    Anyone else experiencing this or having successful uploads in the past 24 hours?
    Mac OS X (10.5.4)
  • smartsoftwaredevelopment Calculating status...
    Currently Being Moderated
    Jul 16, 2008 11:13 PM (in response to darrensi)
    I am in the same situation as you are. I was uploading 2 updates via Application Loader. The first app is now stuck at "Waiting for Upload" while the second one changed to "In Review" very quickly, as it should have. Could it be that it's a bug that only affects the FIRST app you update (or upload) on iTunes?

    Any more people in the same situation?
    Mac OS X (10.5.2)
  • appleRyan41 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2008 11:18 AM (in response to appleRyan41)
    another update:
    Another day and a half has passed, still stuck on "Waiting for Upload." I've tried going through the entire certificate / provision process (with a Wildcard App Id) multiple times now, following the developer guide verbatim. I even tried resubmitting my app under a new name and SKU after redoing the entire code signing process and the same outcome occurs (with 0.9 of 0.9 and the X next to it) with no error messages. I've tried to contact apple via multiple support email addresses, still no responses.

    I'm really disappointed that $99 has gotten me nothing more than a broken upload mechanism, many wasted hours and absolutely no response from the support teams. if the problem is indeed with my package and not the upload mechanism then there needs to exist some sort of feedback telling me what's wrong! Please Apple, it's been over 2 days now, I just want to get my application into the store.
    macbook pro, Mac OS X (10.5.4)
  • bvdman89 Calculating status...
    Currently Being Moderated
    Jul 17, 2008 12:20 PM (in response to whosyourtator)
    I have the same problem: 1 Waiting for upload, 1 In Review (5 business days so far)
    .
  • admanimal Level 1 Level 1 (90 points)
    Currently Being Moderated
    Jul 21, 2008 12:28 AM (in response to bvdman89)
    I also have the same waiting for upload problem now. I even went so far as to install XCode and my certificates on a laptop where I had never done any development before, recreate my projects, and create new provisioning profiles all exactly following the instructions but my app is still stuck on waiting for upload.

    The really weird thing is that I tried sending the zip of my other app that is currently for sale and was built using the old style application-specific appID and it accepted that with no problem. But of course when I tried to submit my new app built with an application-specific appID as well, it had the same upload problem.

    There is nothing worse than spending a whole weekend finishing up an app just to find that the submission system is all screwed up and there might not even be a chance of it appearing in the store this week.
  • typewriter Calculating status...
    Currently Being Moderated
    Aug 15, 2008 10:43 AM (in response to admanimal)
    I had this problem, and was able to solve it.

    1. Load your project in Xcode.
    2. Open Info.plist
    3. Change Bundle Identifier from whatever it is, to a string containing no whitespaces. (something like myApp)
    4. Build, zip, reupload with App Loader.

    When I did that, the iTunes Connect website IMMEDIATELY showed "In Review"
    Skynet MBP, Mac OS X (10.5.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.