1 2 3 Previous Next 39 Replies Latest reply: Mar 20, 2009 12:19 PM by Georgemaxim Go to original post
  • 15. Re: Spotlight server not working properly
    DY-E Level 1 Level 1 (20 points)
    Hi Forum folks.

    Stephen's solution of putting the "Everyone" or "Other" permissions to at least "Read Only" seems to do the trick for my servers.

    I've tried it on a 10.4.11 OS X Server too, and it seems happy to index + communicate with clients instantly after the permissions change was issued.

    Such an immediate result (no waiting around!) after making the change, the files are searchable again.

    Thank you!
    Derek
  • 16. Re: Spotlight server not working properly
    Long_Admin Level 1 Level 1 (0 points)
    No luck with 10.5.5 update, still the following errors:

    19.09.08 14:49:26 mds[87] (Error) Server: Peer checkin failed -- no store for path '/Volumes/HD2/Groups/1'
    19.09.08 14:49:26 com.apple.AppleFileServer[419] MDSChannelPeerCreate: (os/kern) invalid argument
    19.09.08 14:54:38 mds[87] (Error) Server: No store registered for scope "/Users/admin"
    19.09.08 15:47:04 com.apple.AppleFileServer[419] MDSChannelPeerRequest: (ipc/send) invalid destination port

    Apparently those errors arise when spotlight is asked from a client, and then when asked from the server spotlight returns incorrect results.

    Already tried mdutil -i on, mdutil -E...

    Any help would be appreciated.
  • 17. Re: Spotlight server not working properly
    Mac Doc Mike Level 1 Level 1 (0 points)
    Having the same issue here with Server 10.5.4. Hesitant to upgrade to 10.5.5 given the printing issues in Adobe Apps (admittedly on client machines) and working from server issues with 10.5.3.

    I've tried Spotless, deleting indexes and re-starting Spotlight service, adding read-only permissions to everyone... +no luck+. Sometimes we'll get a few results, yet there are countless other files matching the search criteria. (Only file-name based, we don't do much searching contents)

    I've had similar results as others in that after deleting the index, it seems to work for a day or so, then it's broken again.

    Anyone else have any ideas or thoughts about 10.5.5?

    Thanks!

    Mike
  • 18. Re: Spotlight server not working properly
    hornson Level 1 Level 1 (0 points)
    same here as well.
    i figured out that, if i create a file on the server it shows up in spotlight, even when doing a search on a client machine.
    if i create a file on a client machine it won't show up.
    same happens when client machine is moving former shown files (created on server) in a differernt location.
    seems to be a permission issue?
    any ideas?
    all the best,
    markus
  • 19. Re: Spotlight server not working properly
    skinnypoo72 Level 1 Level 1 (0 points)
    look fellas...the AFP service and spotlight service is buggy at best....
    doesnt matter what hardware you run or which 10.5.x software...
    it doesnt work right period....all the points you guys made are valid.

    here is the solution:

    get a windows server box 2000 or 2003 or even an XP box
    and run this http://www.grouplogic.com/products/extremeZ-IP/

    super fast searches...indexing...i mean fast....works with all apple clients.
    take the time to try it free...easy to setup up....works period...
    no missing file nonsense...thats pretty much all they do and have excellent support.

    i have started to abandon my xserves...and move this way...
    hopefully with "snow leopard" they will finally address real issues...
    and stop adding useless features....maybe get enterprise level
    support where it should be...these servers are too expensive to have these stupid issues.

    hopefully less engineering hours at iphone would make a difference.

    good luck
    Luis.


    see my other posts in the 10.4.x forums.

    personal info - i have 4 xserves runing 10.5.5, 10.4.11, 10.4.11, 10.3.9
    and i support over 70 clients...so iam not talking out of my butt.
  • 20. Re: Spotlight server not working properly
    dkelley Level 1 Level 1 (10 points)
    I don't know if this help everyone or not.
    I have a 10.5.5 server with 2 internal drives and shares on both drives.
    No combination of indexing, reindex, turning spotlight on and off works.
    The only share i came make searchable from a client machine is the share that is location on the boot drive.
    Why should this matter ??? but no one at apple support seemed to know this.
    Once i moved my shares on to the boot drive, everything started to work the way you would think it shoudl.
  • 21. Re: Spotlight server not working properly
    Patrick Van Nerum2 Level 1 Level 1 (30 points)
    Same problem here on Xsan.
    3 Xserves and volume hosted on Xsan. Shares are reshared by the server to the clients.
    A file created on a client en copied to the server=no search result in Spotlight.
    A file created on the server on the Xsan volume = search result on client!

    Changing the file permissions for everyone didn't help me....

    All servers are 10.5.5. I will file a bugreport at Apple.
  • 22. Re: Spotlight server not working properly
    Patrick Van Nerum2 Level 1 Level 1 (30 points)
    Changing the POSIX permissions read by everyone does work for me.
    But this option I don't want to use on a server share....
  • 23. Re: Spotlight server not working properly
    Nova Level 2 Level 2 (385 points)
    changing permissions does not work for me... chiming in to add another to the list of people encountering this problem. i've turned off spotlight for all the sharepoints, and i still get the log errors. sure would be nice if someone in Apple's engineering group could address this topic. but why spend time fixing leopard server when you can just put all your developers on another product... enter snow leopard server. 3000+ views of this topic ought to be a hint to someone over there that something's amiss..
  • 24. Re: Spotlight server not working properly
    Nisei Level 1 Level 1 (0 points)
    Same problem overhere.
    The weird thing is that files which can't be found by clients show up correctly when I do a search on the server itself. So they are indexed correctly.
  • 25. Re: Spotlight server not working properly
    MacBiXo Level 1 Level 1 (0 points)
    Hi to all!

    Everyone has ha solution?
  • 26. Re: Spotlight server not working properly
    Mike Matthews Level 1 Level 1 (10 points)
    Anyone know if the 10.5.6 update solves this? Looks like it might...

    Spotlight provides more reliable results when remote users search a server volume with Spotlight searching enabled. Important: This change takes effect when you enable Spotlight searching on a sharepoint. In order to take advantage of this improvement on a sharepoint where you have already enabled Spotlight searching, disable Spotlight searching, save, re-enable Spotlight searching, and save again. The sharepoint will remain online during this process, but Spotlight searching will be unavailable for a short time while the index is rebuilt.

    mm
  • 27. Re: Spotlight server not working properly
    Michael Gmuer Level 1 Level 1 (5 points)
    Easy Solution:

    In response to skinnypoo72's post wich said:
    [look fellas...the AFP service and spotlight service is buggy at best....
    doesnt matter what hardware you run or which 10.5.x software...
    it doesnt work right period....all the points you guys made are valid.]

    I do have to agree Spotlight is buggy, unusable and in no way a serious enterprise solution AND it shouldn't be that way... Apple what's wrong with You - don't You strive to be taken seriously in the enterprise field - THEN you should act accordingly, shouldn't You ?

    ...I'm taking care of dozens of Leo Servers at many customer sites... for example now just had a problem with an Xserve/Xeon-8-Core with XRAID's plenty of everything - using 400% of processing power for mds exclusivly - practically halting productive work for the whole ad agency AND still not finding many files.

    ...but contrary to skinnypoo72 advice, I would NEVER reccomend switching to a Windows box at all - but simply & easy - just shut down Spotlight alltogether on all shared volumes !
    + provide Your Clients/Users with the Freeware search tool "EasyFind" from devon-technologies.com and Your Problems are just history It searches manually now withouth index - and DOES find everything, just a UNIX find with a nice GUI - easy
  • 28. Re: Spotlight server not working properly
    Oz Barron Level 1 Level 1 (5 points)
    Ok, been having the same issues as everyone else. Just applied the 10.5.6 update, stopped and started Spotlight, and all seems good... so far.

    Fingers crossed
  • 29. Re: Spotlight server not working properly
    Mike Matthews Level 1 Level 1 (10 points)
    I applied the 10.5.6 server update, removed access for Others, stopped and started Spotlight on all the various sharepoints, and things seem to be working correctly now. Users can search the shared hard disk for items and they don't see items on sharepoints that they don't have privileges to access.

    Hooray!

    mm