13 Replies Latest reply: Aug 18, 2008 2:24 AM by Steve Fermor
Steve Fermor Level 1 (35 points)
Hello everyone,

A strange problem has occurred when playing a CD in iTunes. It won't let me eject the disc, saying that "the disc is in use". This on a brand-new iMac 24" intel model, with all the latest software.
I have to quit and then I can eject it. I've been using iTunes on my previous Mac for years and never had this problem. Has anyone else come across this?


iMac 24" intel, Mac OS X (10.5.4), Programmes in regular use are Freehand, Photoshop, Freeway, Keynote, iMovie, iDV
  • Steve Fermor Level 1 (35 points)
    Hello everyone,

    As an update to my post, I have noticed that if you load a CD and then ask to eject, it does so. If you have played part of the disc though, then you have to quit to remove it. None of the eject buttons work, neither does the menu command. Can anyone help?
  • John Sunier Level 1 (15 points)
    I'mhaving similar ejection problems since installing v7.7 with Leopard on my 20" iMac. But most of the time neither the eject in the RH lower corner of iTunes nor the keyboard button work. The only way to eject CDs is either to quit iTunes or restart the Mac. AppleCare was no help because during the time I was on the phone with them it DID eject the discs! Then immediately after it stopped again.
  • Frodo Fraggins Level 2 (330 points)
    Did you try dragging the disk to the trash can?
  • give me a break Level 1 (0 points)
    I found this thread because I am experiencing the same issue. I decided to move to MAC from the PC world expecting a better experience and while I am still hopeful I am not off to a good start with this and another issue. That aside I found that if I waited a few minutes the eject will work. I was copying my music disks and found about 70% of the time I had to kill iTunes in order to eject.

    This last disk I was distracted searching for information on the issue; the result being that I had waited at least several minutes longer than I had previously so I tried to eject again and it worked. I think iTunes is still copying non-music files after it gives the "i'm done" sound and until it finishes it won't release the disk. this is just an excuse/explanation and may be wrong but it fits the experience, even so it is a bug reminiscent of microsoft.

    Short answer is be patient.
  • Steve Fermor Level 1 (35 points)
    John, Frodo, and Give Me A Break,

    Thanks for your help. Actually I did try dragging it into the trash, but the result was the same.

    However, I think I've found something. Are you all using Time Machine? I am - I turned it off, and now I can eject Cds ok. I'm not any sort of a system expert, but it would seem to me that Time Machine is somehow 'protecting' the disc. Perhaps it feels it should back it up while it's in there?
    I know you can ask Time Machine not to back up certain things, but I've not had chance to research this yet. The options suggest you can ask it not to back up certain discs. Mine excludes the drive I use for Time machine (naturally), and a small pocket drive, but where I'd find the CD drive I'm not sure. Does anybody now?
  • klausness Level 1 (0 points)
    This seems to be a problem with iTunes 7.7 (there are a few other threads about this -- since search has been disabled, people keep starting new threads). I'm not using time machine, so I don't think it has anything to do with that. Luckily, I still had a copy of iTunes 7.6.2 lying around, so I reverted to that, and now I can eject CDs normally again.

    I'd say this is a pretty embarrassing bug, really. Basic functionality shouldn't be broken like this.
  • Steve Fermor Level 1 (35 points)
    Hello klausness,

    Thanks for that info. The forums are a bit of a mess at the moment without search - which I did try first but got pointless answers from all over the place. Thankfully, the search issue is down to Apple and not my new iMac. I did wonder what was going on until I saw the announcement.

    Time Machine might be a coincidence then? If so, we'll have to wait until Apple fix it.
  • Pulpio Level 1 (0 points)
    I am having the same problem following the most recent iTunes update (7.7 (43)). When I try to eject a CD I get a message stating that the disc is in use by another application, and I can't eject the disc (by any means) until I close iTunes. It's extremely annoying.

    I'm using OX 1.4.11 on a 20" iMac, so no Time Traveler (or whatever it's called) here.
  • Somepocho Level 1 (0 points)
    Try this:
    System Preferences -> TimeMachine. Turn TimeMachine Off. Launch iTunes; load CD and play. Attempt eject.

    I was having this problem but it seems to have resolved by turning, in my case, TimeMachine Off.

    HTH. . .per forum rules, will internalize snarky comments.

    Message was edited by: Somepocho
  • Furtwanglerian Level 1 (10 points)
    I am replying here to bump this thread. (I have complained of this problem in another thread already, only today discovering the issue is also being discussed here.)

    To be very clear: This non-ejecting CD issue is a new problem, precipitated by the 7.7 version of iTunes.

    People have at times experienced difficulty ejecting CDs in Mac environments in the past. But this is a new issue. The 'old solutions' don't apply. Only quitting iTunes permits the CD to be ejected. iTunes 7.7 is the problem.

    The problem can occur without regard to whether Time Machine is installed.

    All that said, I'm new here -- Can anyone tell me: Do Apple staff read these support discussions?
  • Steve Fermor Level 1 (35 points)
    Thank you all for the recent posts. I was ready to turn Time Machine off, then load a CD and see whether it would eject after playing - I should stress that I've never had a problem if the CD hadn't been played - and now I can't get it to go wrong!
    This certainly is a puzzle.

    As my Mac is new and with Applecare, I can phone the techs. Give me a couple of days as I'm really busy, but I'll post again when I've had a word and see what they say.

    As for Apple support staff reading these forums - possibly. Some of the people who have answered my questions in the past stand a good chance of being Apple techs - they know too much! They might be here, but unofficially.
  • Adam_T Level 1 (0 points)
    I've noticed the same issue here. Not helpful if I'm trying to preview CD tracks while on the road for a show, but I digress...

    I've noticed that going to the last track on the CD, and then ffwding through to the end of that track, letting the CD spin down, and then pressing eject in iTunes works, especially if you've been listening to a variety of tracks on that CD.

    NB: This tends to work, but not always. It is, however, the best thing I've found yet (still have to download 7.7.1).
  • Steve Fermor Level 1 (35 points)
    Hello everyone,

    I did say that as my Mac was new, I'd talk to the Apple techs about it. However, the problem stopped occurring. While wondering what to do about that - as I hadn't changed a thing - an iTunes and security update came out, which I installed. I still have no problems with ejecting CDs, but I can't offer any explanations as to why this happened.
    Are you all still experiencing problems, or has it mysteriously sorted itself out?