Previous 1 2 3 4 Next 50 Replies Latest reply: Sep 16, 2008 3:30 PM by Tony Greiner Go to original post
  • habble Level 1 Level 1 (0 points)
    I got the same error message and all the printing jobs were rejected by the printer. I downloaded the driver for the printer (mine is Color laser 3800) from HP support&driver site and installed it. It solved all the problem.

    Message was edited by: habble

    Message was edited by: habble
  • Johnny. Just Johnny. Level 1 Level 1 (0 points)
    My networked LaserJets (3 different models) worked fine before installing this update, then started giving me the:

    /Library/Printers/hp/filter/hpPostProcessing.bundle/Contents/MacOS/hpPostProces sing failed

    error (not the crash -- it just barfs and I can't print anything).

    Re-downloading and re-installing drivers for one of the printers (LaserJet M5035x) straight from HP appears to have solved the issue. At least on the two LaserJets that worked up until last week.
  • Mitch Str Level 1 Level 1 (0 points)
    I have since learned that the Laserjet 1022 was not included in the HP Printer Driver 1.1 Update from Apple. So, I am not 100% sure why your printer kept on working and mine stopped/switched to GutenPrint driver.

    See list of printers included in HP Printer Driver 1.1 Update:
    http://support.apple.com/kb/HT1893
  • -g Level 4 Level 4 (3,205 points)
    Big deal, I couldn't print out of Photoshop CS3 before the update, and still can't print out of Photoshop CS3 after I ran the update.

    Saving as JPEG and Preview still works, tho...
  • John Blanchard1 Level 5 Level 5 (5,030 points)
    It seems that this issue is tied to presets. You can try this as a workaround:

    "From print dialog box, delete any custom pre-sets that may have existed before driver update. After driver update, user can recreate custom pre-sets and all should be good."
  • Rolland Bryan Level 1 Level 1 (5 points)
    Recreating the presets solved the problem for me too. Thank you gavinmster
  • VanDewey Level 1 Level 1 (0 points)
    Regarding hpPostprocessing errors, there may be a conflict with older custom presets.

    From the print dialog box, if you have custom presets you've created in Tiger prior to Leopard update, there may be an issue/conflict with the custom presets. Just delete the preset and then recreate/save a new custom preset (e.g. duplex on, 2up, etc) and you should be OK.
  • Typo180 Level 1 Level 1 (30 points)
    I was working on a co-worker's HP Laserjet 2420 (print jobs were stopping). He ended up removing the Adobe plug-in for Safari which solved the problem.

    Here's the log for reference:
    I [28/Jul/2008:11:47:50 -0500] Listening to ::1:631 (IPv6)
    I [28/Jul/2008:11:47:50 -0500] Listening to fe80::1%lo0:631 (IPv6)
    I [28/Jul/2008:11:47:50 -0500] Listening to 127.0.0.1:631 (IPv4)
    I [28/Jul/2008:11:47:50 -0500] Listening to /private/var/run/cupsd (Domain)
    I [28/Jul/2008:11:47:50 -0500] Loaded configuration file "/private/etc/cups/cupsd.conf"
    I [28/Jul/2008:11:47:50 -0500] Using default TempDir of /private/var/spool/cups/tmp...
    I [28/Jul/2008:11:47:50 -0500] Configured for up to 100 clients.
    I [28/Jul/2008:11:47:50 -0500] Allowing up to 100 client connections per host.
    I [28/Jul/2008:11:47:50 -0500] Using policy "default" as the default!
    I [28/Jul/2008:11:47:50 -0500] Full reload is required.
    I [28/Jul/2008:11:47:50 -0500] Loaded MIME database from '/private/etc/cups': 52 types, 49 filters...
    I [28/Jul/2008:11:47:51 -0500] Loading job cache file "/private/var/spool/cups/cache/job.cache"...
    I [28/Jul/2008:11:47:51 -0500] Full reload complete.
    I [28/Jul/2008:11:47:51 -0500] Cleaning out old temporary files in "/private/var/spool/cups/tmp"...
    I [28/Jul/2008:11:47:51 -0500] Listening to ::1:631 on fd 4...
    I [28/Jul/2008:11:47:51 -0500] Listening to fe80::1%lo0:631 on fd 8...
    I [28/Jul/2008:11:47:51 -0500] Listening to 127.0.0.1:631 on fd 6...
    I [28/Jul/2008:11:47:51 -0500] Listening to /private/var/run/cupsd on fd 7...
    I [28/Jul/2008:11:47:51 -0500] Resuming new connection processing...
    I [28/Jul/2008:11:47:58 -0500] [Job 6] Adding start banner page "none".
    I [28/Jul/2008:11:47:58 -0500] [Job 6] Adding job file of type application/postscript.
    I [28/Jul/2008:11:47:58 -0500] [Job 6] Queued on "HPLaserJet2420" by "nevins".
    I [28/Jul/2008:11:47:58 -0500] [Job 6] Started filter /usr/libexec/cups/filter/pstops (PID 37101)
    I [28/Jul/2008:11:47:58 -0500] [Job 6] Started filter /Library/Printers/hp/filter/hpPostProcessing.bundle/Contents/MacOS/hpPostProces sing (PID 37102)
    I [28/Jul/2008:11:47:58 -0500] [Job 6] Started backend /usr/libexec/cups/backend/usb (PID 37103)
    E [28/Jul/2008:11:48:07 -0500] PID 37102 (/Library/Printers/hp/filter/hpPostProcessing.bundle/Contents/MacOS/hpPostProce ssing) crashed on signal 10!
    I [28/Jul/2008:11:48:07 -0500] Hint: Try setting the LogLevel to "debug" to find out more.
    E [28/Jul/2008:11:48:09 -0500] [Job 6] Job stopped due to filter errors.
  • Robster50 Level 1 Level 1 (15 points)
    Hmmmm

    Since installing the HP update in software installer my Multifunction printer can no longer scan!!!!!!!!!!

    Every time I try to scan something I get an error 'Sorry scanner cannot be initialised' error communicating with printer.

    Nothing wrong with printer as my wife's laptop has not been upgraded and this scans fine on it.

    Bugger!!!!!!!!!!!!!!!!!!!

    Robin
  • paleo Level 1 Level 1 (0 points)
    yup, here too. HP drivers update v1.1 via Software Update hosed my perfectly fine HP Laserjet 2420:

    Library/Printers/hp/filter/hpPostProcessing.bundle/Contents/MacOS/hpPostProcessi ng failed

    deleting the presets solved the problem.
  • Scott Mcintosh Level 1 Level 1 (0 points)
    This was my problem. I deleted my custom presets, and everything started working perfectly. Thank you, thank you!
  • lythaby Level 1 Level 1 (20 points)
    Just to add another 'me too', alas printing from filemaker will not work at all, as the presets are set within the filemaker script.

    Well done apple!!

    Downloading driver from HP to hopefully solve the problem.
  • lythaby Level 1 Level 1 (20 points)
    Just to concur, download the drivers from HP, install, re-start, remove and add the printer, and hey presto.
  • OldBrandBrent Level 1 Level 1 (0 points)
    I guess I wouldn't be so quick to blame Apple for this. I believe the updates came from HP and were distributed by Apple using their auto-update feature. I can't imagine Apple writing drivers for HP printers. Same with the problem with Filemaker. It could just as easily be HP's or Filemaker's fault for not following the rules.
  • lythaby Level 1 Level 1 (20 points)
    I would agree, if not for 2 things.

    1. The HP software on the HP site is still the old version.
    2. Nothing has changed within filemaker.