10 Replies Latest reply: Oct 27, 2008 10:18 PM by batesfilms
r_touch21 Level 1 Level 1 (0 points)
Hi all I need your help!?! I'm having a problem launching my programs. When I click or double click on a program, it will launch but will then immediately give an error saying "the application _________ quit unexpectedly." This is happening with all of the programs on my computer.

Second problems is with my files. I'm getting an error code -600 when opening up a file. That includes jpg. and doc.

Please Help

Ibook G4, Mac OS X (10.4.1)
  • Carolyn Samit Level 10 Level 10 (98,305 points)
    Hi and Welcome to Apple Discussions...

    According to Apple Error Codes here: http://docs.info.apple.com/article.html?artnum=9804

    That error code means, "no eligible process with specified process serial number". Are you by chance using an application that was a trial version and it expired?

    Also, anytime you get the, "application unexpedtedly quit" dialog box, it can also mean there isn't enough available disk space. Open Disk Utility from the Applications/Utilities folder. Select MacintoshHD in the panel on the left. Now look down at the bottom of that window where it says:
    Capacity and Available. Make sure you always have 20% free disk space of the total drive. It takes 15% just to boot your Mac.

    Carolyn
  • r_touch21 Level 1 Level 1 (0 points)
    I'm not sure about programs being expired because its happening with every program. That includes iphoto, firefox, safari, word, itunes, and etc. The programs open up then suddenly quit unexpectedly.

    As for the error code -600, I'm experiencing this error when opening files of jpg. and doc. BTW jpg. is opening up in Preview and the doc. file in Word.

    For the HD, there is about 2.5 gb of free space...
  • Silly rabbit Level 4 Level 4 (2,980 points)
    Hi,
    2.5GB is dangerously low. I'd guess you have a 40GB drive, so you should try to keep at least 8-10GB free, which you can determine easily in the bottom of any Finder window. The maxed disc space could be causing problems to your system like sluggishness, but I doubt it is causing all your apps to quit unexpectedly. That is probably more related to some kind of directory corruption. So, what do you do? Usually when apps start crashing unexpectedly the first step is to delete the preference file for the offending app. The preference file look like this, apple.com.iphoto.plist. All the preference files are in the same pattern, it's only the name of the app that changes. You'll find them at <hard drive/library/preferences< or you can just search the individual app preferences in the search box of the Finder window. Try deleting one or two for offending apps and see if they still crash. Also, because your directory is a bit funky you should run a maintenance app like Onyx. Install it and run Maintenance. It should sort out the directory issues to get your machine running again. Try these and post back with your results.



    I also noticed your profile states 10.4.1. You should update to 10.4.11.

    Onyx - <a class="jive-link-external-small" href="http://">http://www.titanium.free.fr/pgs/english.html
    Make sure you get the right version for your OS.


    Good luck!
  • r_touch21 Level 1 Level 1 (0 points)
    Sorry about that I'm actually running 10.4.11. I followed your steps but I could not find the preferences for the programs I'm having problems with. But I do see other files like com.apple.SoftwareUpdate.plist and etc. I'm also unable to download Onyx because Firefox and Safari are quiting unexpectedly.

    I've noticed that my dock with all my programs is no longer and can't figure out a way to get them back. I also noticed another error when opening up doc. files which reads:

    Application Launch Failure
    The application "Word" could not be launched because of a shared library error: "5<MicrosoftWord><CarbonLib><CFMPriv_LaunchServies>"
  • Silly rabbit Level 4 Level 4 (2,980 points)
    OK, try this.
    Open a Finder window and type, apple.com.safari.plist into the search box (top right hand corner of the window). You will see the file in the window. Drag it to the trash, empty the trash and restart your computer. Safari should start with a new preference file. If it starts go straight to titanium software and download Onyx.



    Also, to find the preference files you want you can extend the size of the actual column (in column view) so you can see the full name of the files.



    Finally, do you have the original install discs for your Mac? If so, you should start the computer by booting from the disc and run the disc repair utility. This may fix it.

    Here's how: Insert the OS disc and shutdown the computer. Next, restart the computer holding down the 'C' key. This will make the computer boot from the CD. When it starts go to the file menu and open the disc utility. Select the hard drive in the left column and then repair disc. - If the installer starts just quit it.



    Give them all a go. I look forward to hearing some positive results.
  • r_touch21 Level 1 Level 1 (0 points)
    Hey finally was able to get the disc to boot the system. I ran a extended hardware test using the disc and everything seems ok because everthing passed. Before I boot the system I was wondering if this will delete all my files on the hardrive??
  • r_touch21 Level 1 Level 1 (0 points)
    hi again I ran a disk and permissions repairs like mention above. Everything seems to be okay because no repairs were needed. But I'm still having the same problems...Please help!!
  • fltnsplr Level 1 Level 1 (0 points)
    Interestingly, I've been having the same problem with programs just quitting on me by the score. I would recommend following the advice of the person who said to dump the plist of the offending applications. They can be found in the library/preferences section, or by using the Finder and typing in com.apple.safari.plist, for example. Drag all that stuff to the Trash and restart the program.

    I had to use my backup hard drive to even get online this morning, and by chance came across this discussion. Also, if you use the installation disk, everything will revert back to whatever OS is on the disk, and you'll have to go through the cumbersome process of updating the OS (in my case it would start at 10.3 and go to 10.4.11, like you have).

    In addition to OnyX (which I just downloaded but haven't tried yet), I can highly recommend Pacifist, at www.charlessoft.com. It's $20 and well worth it, because it is "a Cocoa application that opens up .pkg installer packages and lets you install or extract individual files out of them." You don't have to reinstall everything every time you need an individual program; simply select what you want from the nefarious installation disk and blow off the rest!

    Good luck!
  • Manuel W Peters Level 1 Level 1 (5 points)
    I frequently encounter this error code as well.

    Specifically, whenever Photoshop gets hung up in some sort of process and I force quit it, the application icon in the dock shows that it is still active. Sometimes it takes several minutes for it to finally quit, other times I need to do a reboot.

    If I try to open a Photoshop file, the error code appears. I'm using a (legit) license of Adobe CS3 Design Premium.

    This happens about once or twice a month depending on the size of the file.
  • batesfilms Level 1 Level 1 (0 points)
    I got this code when FCP freezes. Strangely, it occurs just after 10PM. Three nights in a row. I'm not joking.

    Will try above fixes.