7 Replies Latest reply: Jul 20, 2008 9:54 AM by bull87
bull87 Level 1 Level 1 (0 points)
After a clean install of Leopard on my Macbook, though I can connect to the internet, I cannot access the software update server. Going into software update simply brings up a message saying 'cannot access update server' 'check network settings'. This has been the case for a couple of weeks and I have tried switching off all firewalls, and manually downloading the latest Leopard combo update, and fiddling with my broadband router (Orange Livebox).
Any ideas what could be causing the problem? I have even tried creating another admin user account and the same problem occurs there too.

Macbook 13, Core 2 Duo Intel 2.0ghz, Mac OS X (10.5.4)
  • entity Level 1 Level 1 (10 points)
    are you behind a proxy?
    one suggestion is that you download the combo updates for your OS from www.apple.com/downloads and see if the updates resolve the updating issue
  • bull87 Level 1 Level 1 (0 points)
    I've just got the combo update (downloaded manually) and it still hasn't fixed it. As far as i know i'm not behind any kind of proxy, it's just a home broadband router from Orange (firewall switched off).
  • nerowolfe Level 6 Level 6 (13,065 points)
    Be sure the firmware on your router is up-to-date.
  • entity Level 1 Level 1 (10 points)
    try connecting directly to your internet modem (if it is separate from your router) to eliminate the router being a possibility.
    not sure if this would help much but as a long shot, try creating a new network location and test in it.

    http://support.apple.com/kb/HT1569 is a general article on troubleshooting software update issues, but most of it you've already tried.

    Message was edited by: entity
  • nerowolfe Level 6 Level 6 (13,065 points)
    That's a good idea if it's possible.
    On my cable system, I can connect directly to the cable modem, but on my Verizon DSL, the modem is part of the system.

    Out of curiosity, I wonder if the Apple software update server is "unlisted" or public?
    If the IP or name is public, the OP can ping it to verify a connection. Of course some addresses do not respond to a ping.
  • denski55 Level 1 Level 1 (0 points)
    I have a similar problem. I took my iMac to an Apple Store to have the guys at the Genius Bar troubleshoot a problem. They checked out my iMac, and suggested I do an Archive and Install when I got home. Result - the problem was fixed! But it wiped out 10.5.1, 10.5.2, and 10.5.3. I'm internet-limited for large downloads, so I returned to the Apple Store with my iMac and asked them if they could download 10.5.1 through 10.5.3, which they did. But now I have tried to download 10.5.4 and I always get this message: "Software Update can't find the update server. Make sure you're connected to the internet, then try again." [I am connected to the internet.]
    I ran the Network Diagnostics: Airport, Airport Settings, Network Settings, ISP, and Internet all have the green "dot." But Server has a red "dot" and says Failed (underneath it). I continued with the Network Diagnostics and got this message: "Network Diagnostics was able to connect to the Internet, but not to the server 'lehighvalley.local'. [This is the server for the Apple Store.] This could be caused by problems with the server or an Internet problem between this computer and the server."
    Result - I can't download any updates (because the Software Update can't find the update server). Any solutions? Thank you.
  • bull87 Level 1 Level 1 (0 points)
    This sounds exactly like the problem i've had. Do you think it has more to do with your ISP than any problem with the computer itself?