Previous 1 2 Next 16 Replies Latest reply: Jul 30, 2008 10:40 AM by blevenstein
phpjeff Level 1 (0 points)
I noticed that there was a version 1.0.1 of Cro-Mag out and that got me thinking that the App Store "Updates" section should have had that listed, but it was not there. Anyone else have an issue with the App Store application on the iPhone not alerting when an update is available?

I was able to delete it from iTunes and then "re-purchase" it which of course was free. At which the message stated it was going to update the application.
  • John_Burke Level 1 (0 points)
    I had a similar problem. The App Store within the iPhone showed me that three of my applications needed updates, but when checking for updates on iTunes, I was told that 6 applications actually needed updates. For some reason, even after syncing it the updates did not take effect.

    Also, I bought two application from the iPhone App Store and even after opening them before syncing, I noticed that they still do not show up in the Applications tab of iTunes.
  • phpjeff Level 1 (0 points)
    I noticed that and finally discovered the "Transfer purchases from iPhone" under the File menu in iTunes. But, I was having an issue where it would only transfer one application at a time. I had to repeat the process until all apps where brought in to iTunes.


    I finally discovered the "Check for Updates" link in the iTunes - Applications page (lower right of window). That showed me just how many applications I needed to update. I hope they get a handle on the update feature on the iPhone App Store.
  • donhillla Level 1 (15 points)
    There seems to be a big delay on the Apple side in getting the Apps updated. I have one app where the vendor's app page was updated to version 1.1 with new screen shots, but the program is still at version 1.0. They submitted both the screen shots and program on the 14th. I know of another vendor who submitted an app two weeks ago, was approved and is still waiting for the app to loaded.
  • Kirocop Level 1 (0 points)
    I have this problem too
  • wetdog160 Level 1 (5 points)
    yes, I am having related issues.

    At first I realized the 4 or 5 apps i purchased on the phone were not syncing to iTunes on my macbook. Selecting "transfer purchases" from the iPhone does absolutely nothing for me.

    Second- I discovered that the "App Store" icon (that should be on my home screen on the 3G) is just not there anymore. It's completely gone from all three home pages I have.

    so, very frustrating. I don't want to restore until I can back up the $20 worth of apps i have purchased.

    Has anyone fought with this issue and figured it out?
  • TheChiman Level 1 (0 points)
    I also have this problem. I have an iPhone 3G as well as the original iPhone. On the 3G and in iTunes, I can't download updates because they tell me there are none. But just now when I synced my apps to my original iPhone, the App store application told me there were 5 updates available.

    I don't know if this is related but when I delete an application in iTunes and select the menu item "Check for purchases", nothing happens. iTunes does not tell me that I'm missing an application that I had bought and downloaded.
  • Davidaz Level 1 (15 points)
    I had a few problems with updates but now all seems well. I found a folder in the iTunes folder called "Mobile Applications". I have a couple apps in there that are duplicated? One is "Tap Tap".ipa I have 1. TapTap1.ipa (like it's a duplicate) 2. Tap Tap.ipa (has a space between the Taps?) 3. and another that is
    TapTap.ipa (no spaces) ? There is only ONE app in my iTumes Applications screen so I don't know which ones to delete?
  • Wan Chai Man Level 2 (395 points)
    I have this problem too
  • Ben Rigsby Level 2 (460 points)
    To figure out which app is the one being used right click on the icon in iTunes and choose "Show in Finder" The one highlighted is the one to keep. You can delete the others that have a similar name. I had this same issue. I also removed the number from the file name after I deleted the duplicates.
    Hope this helps.
  • Stain Boy Level 1 (10 points)
    i'm getting a slightly different issue. the iTunes store lists Cro-Mag Rally as at version 1.0.2. my iPhone is indicating the update in the App Store application. but if i click on "Check for Updates" in iTunes, it says i don't have any updates!

    now i'd rather not update a 50 MB game over wi-fi when i could over my much faster wired connection. if i try to re-download Cro-Mag by clicking "purchase" it doesn't tell me i've already purchased it...which makes me nervous as i don't want to be charged again and i cancel the transaction.
  • TheChiman Level 1 (0 points)
    This is my problem exactly. If you have already purchased the app, don't worry. You can re-download it without being charged again. If it still makes you nervous, check your email receipt from Apple, which should show you exactly what you bought.

    I don't understand why the apps aren't updating. There was a blog post talking about how apps wouldn't update if there's a balance on your iTunes account. However, this is not the case for me so that's not it.
  • cell-gfx Level 1 (5 points)
    I have the same issue, but have found that it can also be resolved by reacqiuring the application from the store. Take Exposure for example. My local version is 1.0.0 :

    The store version is 1.0.1 :

    If I use the update command in the Applications screen, it tells me I have no updates. If I click 'Get App' again, however, I get this message :

    Accepting this then downloads the update. Can anyone explain why the version detection isn't working within the Applications section though?

  • Judith Farber Level 1 (0 points)

    I've been using the method you mention below, but if I do so from iTunes rather than my iPhone, the Applications section in iTunes still shows the older version (as per the Get Info command). The app does NOT get updated on the iPhone following a sync. If I "buy" the app again from my iPhone, then it gets updated properly. I noticed this only recently when I attempted to download an updated version of an app to which noticeable features had been added, rather than minor bug fixes. Frankly, I think iTunes in many cases is still downloading older versions of the software.

    Here's one example: I checked for updated apps from iTunes this morning and was notified that Speed Dial had been updated to 1.1. I downloaded it from iTunes and it appeared to download successfully. A sync did not result in my iPhone being updated, as the new features of the app were not available when I tried to use it. I downloaded the update directly from iPhone and the new features finally showed up. Following a sync, the Applications section of iTunes STILL shows version 1.0.
  • blevenstein Level 1 (10 points)
    I've had similar issues. And it's frustrating that there's no good consistent way to see which version of the app you truly have on the phone at any given time.

    I've noticed that the version number of an app shown in the app store doesn't always match what Get Info shows inside of my iTunes library. Also, I've noticed iTunes is keeping old versions of updated apps in the Mobile Applications folder under your iTunes library. I wonder is one of these things is causing the problem.

    I've tried deleting the old versions and removing the appended "1" or "2" from the app file name, but that doesn't necessarily solve the problem. And it does seem like keeping at least one previous version of the app is a good idea.

    I think there is some issue with how Apple is tracking the version numbers of these apps.
Previous 1 2 Next