6 Replies Latest reply: Sep 17, 2008 11:18 AM by Rob McElroy
Rob McElroy Level 1 Level 1
After a lengthy discussion with specialists in the IPhone tech department at Apple, it appears that Time Machine does NOT back up the encrypted files that hold much of the syncing information from your iPhone or iPod. These are the files that appear in your iTunes preferences file under the Syncing tab, which are labeled as backups. For some reason, Apple has chosen NOT to let Time Machine back them up, which has resulted in my losing all of the information stored in my iPhone "Notes" folder.

The file in question is called "MobileSync" and can be found in your hard drive under Users/your computer's name/Library/Application Support/MobileSync.

If you check your computer's current status, the MobileSync file exists and its subfolder is called "Backup." The subfolder of Backup contains the ID's of your iPhone or iPod. If you open Time Machine and go directly to the MobileSync file, it exists on today's date ONLY. The entire folder called MobileSync is missing/nonexistent in all of Time Machine's backups.

So, does anyone know how to force Time Machine to backup a file that it isn't currently backing up? Also, does anyone know if my computer has a snapshot of my lost MobileSync Backup file SOMEWHERE in its vast memory? I am desperate to recover the information from my iPhone Notes file.

Thanks,
Rob

Message was edited by: Rob McElroy

Macbook Pro, Mac OS X (10.5.4)
  • footeking Level 1 Level 1
    I need my notes too! Two years of notes lost to 2.0 update.
  • Xian Rinpoche Level 1 Level 1
    expertise.applemusic
    Apple Music
    Looks like I'm not going to retire my version of SuperDuper! just yet...
  • BudnNNJ Level 1 Level 1
    I've just had the same problem. All my SMSs and Notes erased with the new software. GOING CRAZY looking for them on my computer. Looks like the "MOBILESYNC" file isnt in any of of the time machine instances except "present" any one figured this out yet ? I put in a call support... will post anything i hear.
  • wardy3 Level 2 Level 2
    It's definitely excluded that directory for me too.

    I just copied "MobileSync" to somewhere else and tried another backup, which worked. So it doesn't exclude the name "MobileSync", just the path.

    Now, as long as I remember to copy it every now and then
  • CompuDude Level 1 Level 1
    Good tip! I wish this info was spread more widely. I did a full TM backup of my Wife's computer specifically so she could roll back to 1.x software, if needed, before she upgrades her gen1 iPhone to 2.x. My evil plan would have been thwarted if this directory was not backed up!
  • Rob McElroy Level 1 Level 1
    As a result of my inquiry, Apple has now fixed this problem in its new OS X 10.5.5 upgrade. Time Machine will now back up the iPhone's Mobilsync file which contains your iPhone's backup files. You will now be able to look back in Time Machine and see previous versions of these backup files, starting with the first day you installed the 10.5.5 upgrade. MobilSync files prior to the day you upgrade, are not available.

    I have yet to be able to find my old MobilSync files so that I can locate and decode my previous IPhone Notes, SMS text messages, Bookmarks, Settings, etc. that were lost when I removed and re-installed ITunes during the much anticipated iPhone's 2.0 software release.

    There is a free third-party program from MIT that may help, but I can't seem to get it to run. If anyone knows how to use Terminal to run a Python script, please instruct me. The MIT scripting program will decode the data in your encrypted Mobilsync backup files so that you can read the actual data that is stored there. Whether my "old" (now unused) backup files are in there, I don't know, but I want to check for myself. The iPhone's backup folder is actually huge, with thousands of subfolders.

    Here is the web address for the program, called, IPhone Backup Decoder. It contains a link to download the script:

    http://code.google.com/p/iphone-backup-decoder/

    Can someone please post specific detailed instructions on how to get it to run. It requires some UNIX commands in Terminal.

    Thanks,
    Rob McElroy