Skip navigation
This discussion is archived

IPhone and Exchange Server

10988 Views 29 Replies Latest reply: Sep 22, 2008 3:28 PM by damyale RSS
  • BanditoB Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jul 25, 2008 11:35 AM (in response to Jean Desnoyers 1)
    Jean,

    Yes, it sounds like you simply don't have permission to access the service. Your IT department should be able to grant this access to you in a matter of moments if they are so inclined.
    iMac, MacBook, Mac Mini, Mac OS X (10.4.10)
  • BanditoB Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jul 25, 2008 11:47 AM (in response to lcavada)
    When I was not syncing but not getting any errors, I could not access OMA as I would get an error message that indicated it was not working (sorry, I don't remember specifically what it said). That's when I figured out the solution that I documented here:

    http://discussions.apple.com/thread.jspa?threadID=1629194&tstart=15

    Once I had completed this, everything worked and the iPhone synced and I started getting messages pushed as well. Your ability to log in to OMA successfully makes me think that everything is fine on the Exchange server side, but you may have an issue on the iPhone side. I'd try a couple of things to see what happens. First, it wouldn't hurt to go through the Exchange server and verify the settings that are in my other post, above. Second, I'd delete the iPhone's Exchange account and recreate it to see if that might fix it up.

    Finally, if none of these things work, I would try using the domain name with your User ID in the iPhone setting as in:

    DomainName\UserID which would look something like this, MyCompany\jane.doe

    Also, be sure that you're using a backslash ( \ ) between the domain name and the user ID and not a regular or forward slash ( / ). If you're already using the domain name, try taking it off and only using your user ID.

    It would also help to know which version of Windows Server you are running. SBS or Regular.
    iMac, MacBook, Mac Mini, Mac OS X (10.4.10)
  • BanditoB Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jul 25, 2008 12:12 PM (in response to sergechar)
    scharbit,

    There's no hotline, other than AppleCare, that I know of, so we're pretty much on our own. From your error message, I'd guess that you're using the wrong domain name. The external domain name is usually different that what you would see in looking at your Outlook account settings.

    One of the usual formats, though your Admins can pretty much call it anything they want to, is to add 'mail.' to the front of your external domain, i.e. if your email address is jane.doe@mycompany.com, your email server's external domain name would be mail.mycompany.com Is that what you're using? If not give it a try.

    Also, as I mentioned above, you may need to add your internal domain name to your user ID in your iPhone's account settings. You can find this by right-clicking on the My Computer icon on your desktop or in your Start menu and selecting Properties. From there, click on the Advanced tab and then click on the Settings button in the middle under User Profiles. Be patient, as it may take a few moments for the User Profiles window to come up. When it does, find your user name and the domain name will be everything to the left of the backslash in front of your user ID. If you find your username in the list twice, one of them will likely be your computer's name. You can try both in your iPhone as the wrong domain name won't hurt anything. Be sure to Cancel out of the User Profiles and System Properties windows so that you don't change any settings.
    iMac, MacBook, Mac Mini, Mac OS X (10.4.10)
  • Jean Desnoyers 1 Calculating status...
    Currently Being Moderated
    Jul 26, 2008 8:29 AM (in response to BanditoB)
    Ok, talked to IT and I got the boring "Corporate is standardized on Blackberry so we don't support other types of wireless device"

    Very open minded..... grrrrrrr !

    Anyway, I'll continue using SyncML and MobileMe with my Mac at home to Sync my email, contact, calendar and Global adress book.

    Thx folks for the help with this Activesync thing.
    Imac Intel, Mac Mini Intel, Apple TV, Iphone 3G, Mac OS X (10.5.4)
  • skp_sr Calculating status...
    Currently Being Moderated
    Jul 26, 2008 12:44 PM (in response to Jean Desnoyers 1)
    we just got some iphones and plan to implement the ms active sync soon.

    right now i am using VPN then configure the iphone exchange settings to one of my owa servers.

    works great for mail and contacts but calendar comes out weird.

    Anyway, this method seems to really drain the battery life, and I was wondering if anyone knows how the battery life will be once we get the active sync in place?

    i even have 3g turned off, location services off and bluetooth off.

    Message was edited by: skp_sr
    MacBook, Mac OS X (10.5.3)
  • sergechar Calculating status...
    Currently Being Moderated
    Jul 29, 2008 5:24 AM (in response to BanditoB)
    First of all, thank you very much for your reply.
    I followed exactly your email to find the Domain name but i get the same error.
    In our company to logon to the exchange server using the webmail I use the following address : http://webmail.mycompany.com. And I use the same address for the Exchange ActiveSync Host in the iPhone configuration utility.
    So if you have any other idea, I'll appreciate.
    Thanks
    Windows XP Pro
  • BanditoB Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jul 30, 2008 3:52 PM (in response to sergechar)
    scharbit,

    Where do you see the error message? On the iPhone?

    If you go into Safari and type in your webmail address does Outlook Web Access come up and allow you to log into your email on the Exchange server?

    If that does work, type in your webmail address again and add '/oma' (without the quote marks) at the end and see what happens.
    iMac, MacBook, Mac Mini, Mac OS X (10.4.10)
  • lcavada Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2008 8:22 PM (in response to jwestyp)
    If any windows smartphone or Pocket PC quickly and reliably connect to MS Exchange server 2003 SP1 or newer, why would Apple force Companies to upgrade to SP2 or higher in order to use the iPhone?

    My company's IT department wants no part in upgrading the Exchange server as they are "busy" with other tasks. They will offer no help in getting my iphone to connect.

    Why can't apple provide instructions or a patch to allow the use of EAS 2003 SP1 ?

    This feature is one of the most touted improvements on the iphone from 1G to 3G. In a way I feel cheated as I cannot use this feature..... PRECISELY the reason why I bought the iPhone 3G !

    I have submitted a support ticket for this issue, and it has gone all the way to "Apple Engineering", their reply was that they cannot help with my server settings. They claim the problem is not the iphone.

    Seems to me that there is lots of folks in the same boat. Our time is running out as August 11th is last day to return the device. I urge Apple to reconsider by providing a solution to this issue, surely an oversight in Apple's plan.
    Windows Vista
  • LenH Level 2 Level 2 (390 points)
    Currently Being Moderated
    Jul 30, 2008 8:35 PM (in response to lcavada)
    lcavada wrote:
    why would Apple force Companies to upgrade to SP2 or higher in order to use the iPhone?




    Security. Admins can remote wipe the device if it is lost or stolen. This allows the iPhone to compete in the workplace because Windows Mobile and BlackBerrys can do this too.

    A service pack 2 upgrade to Exchange 2003 is not a major undertaking, so I can understand your disappointment in the IT lack of effort on that front.
    Mac OS X (10.5.4)
  • sergechar Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2008 1:42 AM (in response to BanditoB)
    Yes, the message is displayed on the iPhone.
    With Safari I don't have any problem, except a warning about the certificate, but it works.
    I tried with '/oma' and I got the same message with the iPhone configuration utility.
    With Safari, I got a 404 error, page not found.
    Thanks
  • doungchak Calculating status...
    Currently Being Moderated
    Aug 5, 2008 5:53 PM (in response to sergechar)
    I think we may be onto something here. At least for us. I have a similar setup. I'm not sure what happens on the inside.

    I have a Exchange server on the inside of a firewall. It's has a name like boo.domain.local, which by the way I can access on the inside of the network.

    I then have my router configured to port translate so that all traffic port 443 is forward to an internal IP.

    Under this configuration, OWA works, SSL works with a cert issues with cert server and installed roots on the iphone (via iphone configuration).

    It's some domain naming scheme that the iphone doesn't like. It must have something to do with that. Maybe it doesn't like port forwarding. Anyone have same issue?

    Thanks.
  • doungchak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2008 9:57 AM (in response to doungchak)
    I now everything working and in the environment specified. I ended up calling the guy. My basic config was good, it was just the settings in Exchange and in my iphone that were wrong. The guy was very professional and got it fixed fast. I feel kind of dumb as I should have tried some of the fixes. Give him a call. He's well worth it.
  • neopaladine Calculating status...
    Currently Being Moderated
    Aug 7, 2008 7:05 AM (in response to jwestyp)
    Alright, here's a tough one.
    I've got several customers with W2K3SBS server's running Exchange with all capabilities regarding OWA, RPC/HTTP & OMA.
    Every customer that has needed an iPhone configured for Exchange Activesync has worked like cake, not a problem until now.

    I have one customer network with a few doctors that are Mac users so knowing & having experienced some of the difficulties of getting a Mac to authenticate the a Windows AD with the .local domain extension I decided (before the iPhone was to have Activesync) to contruct this W2K3SBS network with a .lan extension per advice of some tech articles & forum info from other users that experienced .local issues with how Windows AD vs. Mac integration.

    Well...
    On this particular network iPhones will not fully connect to Exchange Activesync the same way. The setup & verification works but no data ever changes hands between the iPhone & W2K3SBS server & no errors are identified.
    These same iPhones will work fine with connection to any other W2K3SBS network & I've checked every setting, cross checked, tweaked, un-tweaked.

    Anyone have any similar issue or suggestion on what the issue truely is?
    Whatever my hands are on at the time!, Windows Vista
  • Mark Mahacek Calculating status...
    Currently Being Moderated
    Sep 16, 2008 3:55 PM (in response to sergechar)
    I was getting this too, but was able to resolve the issue today.
    WARNING: the following must be done by a network administrator with access to the domain controller and knowedge of adsiedit.

    The problem has to do with the msExchOmaAdminWirelessEnable attribute on the user account. There is a news group posting at (http://groups.google.com/group/microsoft.public.windows.server.activedirectory/browsethread/thread/3da065527e85cbb1/366c87fdeb8bec72) that gives an overview of the appropriate values. My lucky number turned out to be 32.
    iBook/PowerBook, Mac OS X (10.4.11)
  • damyale Calculating status...
    Currently Being Moderated
    Sep 22, 2008 3:28 PM (in response to jwestyp)
    I have been trying to figure out this same problem. What is SBS
    PC, Windows Vista
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.