4 Replies Latest reply: Aug 1, 2008 2:04 PM by Todd I
Vegabondsx Level 1 Level 1 (15 points)
For some reason my Macbook Pro keeps ejecting all my CD-Rs that I put in it. I know these CD-Rs work fine because my sister's Macbook recognizes them as soon as she puts them into her drive.

When I put them in it seems like it tries to read the disc a few times then it ejects without an error or any notification. CD-Rs and other discs that have already been burned seem to work fine.

UPDATE

I went into the console and saw that:

7/19/08 8:15:33 PM tuncfgd[437] tuncfg: already running, use 'killall tuncfg; tuncfg' to restart it

kept showing up. I ran this as superuser (sudo -s) and it seemed to fix the problem. Is there a better solution? Or does anyone know what the problem was?

Message was edited by: Vegabondsx

Macbook Pro: 2.16ghz Core Duo, 2gb DDR2, 100gb 72k rpm HD, 500gb External USB, Mac OS X (10.5.4), Others: Mac Mini G4, Power Mac G3, Mac SE, Mac Plus, iPod 1st Gen, iPod Touch
  • Todd I Level 1 Level 1 (5 points)
    I'm running into the same problem.. It seems like there are lots of variations on this same theme. Others report DVD-R's to be rejected.
    On my MacBook Pro, I can read standard CDs and DVDs, and I can burn DVD-Rs. But, I insert a CD-R it tries to read it for a few seconds, but eventually ejects the disk. I bought some different brands of CD-R (Verbatim and Memorex) and both are rejected in the same way.

    I first started seeing problems like this around the time I upgraded to Leopard. Could be coincidence, or maybe Leopard's disc burning is different.


    --
    Also, I don't have a "tuncfgd" process running on my system, so I don't think that is necessarily related to the CD-R issue. A google search for tuncfg turns up references to HamachiX, a VPN tunnel client for Mac OS X.
  • Vegabondsx Level 1 Level 1 (15 points)
    Thanks. I wasn't sure what that was.

    I actually solved this by buying a CD Drive cleaner. It's a CD with some brushes on the bottom of the CD that cleans the lens. Now it reads the CDs without any problems. I suggest you give this a try.
  • Vegabondsx Level 1 Level 1 (15 points)
    I fixed the problem by buying a CD lens cleaner. It's a CD with bushes on the bottom.
  • Todd I Level 1 Level 1 (5 points)
    I fixed the problem by buying a CD lens cleaner. It's a CD with bushes on the bottom.



    Thanks for the suggestion. I saw one of those while at my local computer supply store, and decided to give it a try.

    I got the "Memorex DVD Lens Cleaner" for $12. It is a DVD-Video disk, which has a few tiny brushes on the bottom of the disk. I guess that the DVD video forces the head/lens into a certain position to play the movie. It runs for about a minute, and it's done.

    I was pleasantly surprised when the CD-R I put in was recognized, and the disk burned just fine. A second iso image also burned fine. So far, so good.