5 Replies Latest reply: Aug 12, 2008 8:31 PM by onerose
cweirup Level 1 Level 1 (0 points)
I have my music on a shared network drive. I'm trying to rebuild my library. I can add folders and files from a local directory. The network drive has been assigned a drive letter in WinXP. However, when I try to use "Add Folder to Library" on any folder with music from the network, iTunes basically just ignores the command. iTunes doesn't show that the files are being added and the files in the folder are never added. I've also tried dragging a folder onto iTunes, with similar results.

However, I can add the actual music files into iTunes (from "Add Files to Library" for example). With 1,000s of songs across over 100 directories with subdirectories, I don't really want to do it that way; I want to just add the folder. I can see all of the files and folder, and I can play the files, so I don't think it is a permissions issue.

Any help would be greatly appreciated. Thanks!

IBM Laptop, Windows XP Pro
  • cweirup Level 1 Level 1 (0 points)
    Well, did a little more digging, and it turns out it was an issue with my SMB (Samba) configuration. All of my music files were getting set with the attributes "System" and "Hidden." Since I have Explorer show hidden files, I could see them, but iTunes could not import them. Once I updated Samba, the import started working. Thanks!
  • Mr.Sebs Level 1 Level 1 (0 points)
    Hello,

    Hopefully somebody can help with my similair problem. I have all my music in mp3 format on my linux server, which runs glftpd + scripts that catalogue the mp3 upon upload into genres/year/artist to make for easier finding of songs. I then use samba to access the shares within the glftpd directory structure, e.g.; /glftpd/site/mp3/albums.. I have added this share into windows as a mapped drive (M:\). The problem is this, whilst I can add the folder/drive into iTunes, i cant manually update the album art. iTunes does find some are for the albums, but I have a different source which I want to use to update the art. I also noticed that its not just the art I cant edit, its the track info. This i expected becuase the tracks reside on a network share which glftpd has probably locked permissions on, however the album art i cant understand becuase the library resides on my windows pc.

    Any ideas ?
  • onerose Level 1 Level 1 (10 points)
    i have a win 2003 server with basicly the same issues i've been screwing with the tags with some sucess but not all so i would start there


    i wish they would make a server version for us with large databases and muiltiple ipods and pc's
  • Katrina S. Level 7 Level 7 (24,090 points)
    +the album art i cant understand becuase the library resides on my windows pc.+

    If you want to edit a track's artwork, it's like editing track info - the permissions are locked.


    The iTunes downloaded art is in separate folders, not the ID3 tags in the actual mp3 files.
    on XP the path is
    C:\Documents and Settings\ username \My Documents\My Music\iTunes\Album Artwork
  • onerose Level 1 Level 1 (10 points)
    yo after reading this post i went back to screwing with this problem and found something, correpted files... i have this music database mgr.that found bad headers in my mp3 files it has a file repairer ran it and wala it worked.... this is going to sound cornie but, i d-loaded (err) purchesed all of areosmith disks and itunes only imported 4 of them then i fixed some bad files and i'm back in the saddle again!!!!!! i no i no
    this may help