5 Replies Latest reply: Jul 31, 2008 11:20 AM by Claidheamdanns
lbrockman Level 1 Level 1 (0 points)
Hi, All – I have the original iPhone with 2.0 software. Since the initial install and even after doing a restore on it, the phone has been crashing and rebooting intermittently. I am using AT&T service, and I have never attempted to unlock the phone or run arbitrary code on it, so these issues are baffling to me. Below is a brief list of what I’ve encountered. Again, the iPhone is crashing and rebooting, not the apps:

Press the “Home” button = intermittent crash, then reboot (might happen back to back, or as infrequently as 6 hours – no rhyme or reason)
Press the “Power” button = (same result as above)
Phone locked up when receiving a call, lit up & identified the caller, no ring or vibration then it rebooted. This has happened twice.
Phone locked up when receiving a text message. Noticed it as I heard an odd tone from my phone for a split second, then it crashed and rebooted and showed a text message on the home screen when it finished rebooting.

Also, I have had other problems where the phone didn’t crash or reboot – it just didn’t perform properly:
When receiving a call – display does not light; phone does not ring or buzz. Voicemail received from caller though call not noted in received calls list. Also, I have had a greater number of “Call Failed” problems, even with full cell signal in Denver, CO. This may be AT&T’s fault, but it seems fine after I shut down and restart the phone.

In general, my iPhone with 2.0 software seems a bit more laggy. Screen rotation from portrait to landscape isn’t as smooth and opening the SMS app seems to have a consistent 2-second delay regardless of if I have cleared out my text message logs or not.
Also, when I reboot the phone, more often than not it starts off at the “slide to unlock” screen instead of the home screen.

Regarding location services – My gripe is that it can’t be told to either:
Stay on all the time
Shut off all the time
Activate when needed, then shut off – just like in 1.1.4.
Now when I use an application that I allow to use location services, I have to manually go and shut location services off again or my battery life will suffer.

I have now removed all of the new applications from the phone, and am still experiencing crash/reboot problems. My guess is my phone is damaged somehow or the software I downloaded was somehow flawed during downloading or installation.

Does anyone have any ideas? I really like this phone, but I can't bring myself to buy the new 3G if I can't be certain I wouldn't have the same problems

Thank you,

Lynn

HP DV9000, Windows XP Pro
  • mustngpny50 Level 1 Level 1 (0 points)
    I have experienced this problem as well and it is intermittent to say the least. I have two other friends that have an i-phone as well, and when the phone crashed it stored a picture of the screen in the photo library of the phone. I thought that was a little odd as well. I have another friend that has not updated to 2.0 yet and does not seem to be having any problems at all. I would venture to guess that there is a problem with the update and that an update will be out sometime to correct the problem. If anyone knows of a way to correct the problem please post a fix for us.
  • lbrockman Level 1 Level 1 (0 points)
    Hi, all - I set an appointment online with the apple genius bar, and visited them. Luckily, the lockup condition reared it's ugly head when I showed it to him, so he was able to confirm it. They ended up replacing the phone with a refurbished one, and after reloading to 2.0 again it has been perfectly solid. Problem solved, and faith in the iPhone restored!

    - Lynn
  • mustngpny50 Level 1 Level 1 (0 points)
    Thanks for the info. Did they by chance mention if they had seen this be an issue? Have they seen other phones doing it?
  • LP_2008 Level 1 Level 1 (0 points)
    2 weeks ago I had my iphone replaced with a refurbished one by the Genius bar due to dead spots on the screen after upgrading to 2.0. All was well for about a week until I started experiencing all of the lockups, crash and reboots whenever I unlocked my phone. Just the other day is rebooted in the middle of a call.
    Guess I will have to make a new appt with the Genius bar. Can't believe Apple hasn't addressed this with a SW update yet.
  • Claidheamdanns Level 1 Level 1 (0 points)
    My phone has been doing the same, ever since going over to the 2.0 software. And no amount of restoring has solved it. I notice that it consistently locks up at the Apple screen A LOT. iTunes is blocked here at work, so whenever this happens to me, I am stuck with no phone until I can get back home and run a restore again, which usually takes several hours after starting the process.

    One thing I've noticed that will consistently lock it up is if you click on the Settings app while it is downloading software. This is repeatable.