Previous 1 2 3 Next 37 Replies Latest reply: Dec 22, 2008 6:56 AM by romeoyankee Go to original post
  • ManateeMac Level 1 (5 points)
    Have you tried to Reset the iPhone? Hold to Home and Sleep buttons down until it powers off and turns back on, and then let it finish starting up. Then try a sync.
  • Parker Smith Level 1 (0 points)
    Just chiming in to say that I'm having the same problem. Next to "Applications" in the iTunes sidebar, I see a "2." At the bottom of the window, it says "2 updates available." But when I click that, I'm informed that "{my account} has no updates currently available." So which is true? If I really don't have any updates available, how do I reset the counter that's stuck on two?
  • ManateeMac Level 1 (5 points)
    That's the part I can't figure out either: Where is that count coming from? Is there a config file that needs to be deleted somewhere and re-created? Is it doing some on-the-fly comparison of the versions it thinks it sees among your downloaded .ipa files and data from the App Store? I can't figure out the logic.
  • DoubleDevil Level 1 (0 points)
    I am having this problem as well. The problem occurred before the 2.0.1 update and still remains after.

    I always see a 1 beside Applications in iTunes and "1 Update Available" at the bottom of the applications page, but when I try to see which update is available I have seen everything from all of my apps, to many multiple copies of the each app, to no updates being available.

    I have tried resetting the phone and sync history in iTunes to no avail.

    I would desperately like a logical fix to these problems.
  • calvinennis Level 1 (0 points)
    _Work Around_:

    iTunes suggests 1 app is available for download but wont show the app in question. To fix I synced with my iPhone and then used the app store on the iPhone to check for updates (it found 1). Sure enough the app in question was not up to date and the update would not display in iTunes.

    I went to the app's page in iTunes and downloaded again. I was warned that I had already downloaded the app and chose download again. The latest version was downloaded and replaced the previous version in iTunes.

    The annoying "1" next to applications in iTunes disappeared. I Synced my iPhone again and all is well.
  • davenik Level 1 (10 points)
    I experienced the same problem - usually a 1, but sometimes higher numbers on the applications icon in iTunes, and sometimes no apps, but other times many apps (often copies of the same app) in the downloads page.

    Here's what worked for me:

    I had an old .mac account associated with iTunes. I logged into it; iTunes displayed the 1 badge on the applications icon but showed 3 apps ready for download. I believe I had already downloaded them but I did it again.

    I logged out of my old .mac account and logged in with my new mobileme account. There is now no number on the applications icon in iTunes, and I'm told there are no updates.

    I think Apple did something on the back-end to make this work, because I tried it a while ago and it didn't fix the problem. For now though, the problem is fixed.

    Good luck!
  • tmhale13 Level 1 (0 points)
    I also have 2 Apple ID's/accounts. I have logged in to each and completed any updates that have been available. I STILL have that "1" next to my Apps icon in iTunes.
  • slowriter Level 1 (0 points)
    I'm having the same problem as Parker. In iTunes I get the "There are no updates available" notification, even though I supposedly have three updates available. In the iPhone, I show two updates, but when I try to download them it tells me "The application is currently being modified" OR "go to iTunes to retrieve your updated application" or some such.

    Ahh, the vagaries of new technology...
  • elachowitz Level 1 (0 points)
    OSX Users Only (unsure how to fix this using the PC - sorry in advance to all of those Windows people)

    Further, this will not permanently solve the issue but is a workaround to get rid of the pesky "1" (or however many numbers appear next to the Applications menu item) without removing all of your applications and re-syncing (which does not always work as you will come to understand)... Warning: You will need to have some computer understanding to rid the pesky update notification!

    Lets start with the problem shall we (there seems to be MANY posts with the same issue out there and hopefully I can shed some light on the situation). Please share my finding with anyone having this problem...

    We all know that the App store is having their share of versioning issues - (i.e. the developer has a more recent application in queue than what is being displayed on the App store). Here is where the problem resides... iTunes is able to see this update, however it is not "ready" to be pushed to your computer (this is also true for the App Store on the iPhone/iPod Touch). Thus fooling it to think there really is an update - when in fact, its not ready for download.

    Simple fix right...? Wrong. This issue has been around since the App store's inception and there is no provision in iTunes (not yet anyways) to ignore the soon-to-be-released-update. The update mechanism writes a key to the which you can clearly see if you follow this link:

    Notice the obvious: ipau stands for iPod Application Updates and there is that pesky "1" we so very much want to rid ourselves of...

    An easy fix would be to delete the entire plist file from your preferences directory (this is the path: /Users/<USER NAME>/library/preferences/ However, I recommend that you install an application like PlistEdit Pro ( to view the contents of the file and deleting the key ONLY (removing the whole file will cause iTunes to recreate a new one, thus causing you to have to re-enty some settings). Further, I'm sure there are some free Plist editors out there - you can do some diligence.

    Until this gets fixed by Apple, the "badge of death" as I have seen it referred to, will not go away anytime soon...

    Hope this helps.

  • JcRod73 Level 1 (0 points)
    I am having the same problem...Mine says 2 updates in iTunes 7.7.1...iPhone has no problem...
  • Phunkae Level 1 (0 points)
    I solved it by:
    - deleting all applications from itunes
    - copying over the apps from my iphone back to itunes
  • Joe Chiarelli Level 2 (365 points)
    This fixed my issue! THANKS, and it was very easy i think...
  • cmalberto Level 1 (40 points)
    I think some of the problem is that app gets renamed. I had one tonight that wouldn't updated. It was originally called Jawbreaker. Now it is updated and called reMovem Free. I guess the author got one of them letters...Anyways, I deleted from both the phone and itunes and just re-installed. All is well.

    Thought I would add my 2cents worth.

  • DeeRun Level 1 (0 points)
    My solution was to check under "Get Info" in iTunes "Applications" to see if any of the version numbers mismatch that shown in the Store. If they do, download that app again. If you've paid for it, it will simply overwrite the old app. The update number will disappear! Seems like some app updates get stuck or mismatch. Anyway, this is a relatively painless fix for now.
  • I am curious. Level 1 (20 points)
    Mine says I have 6 apps to update...