9 Replies Latest reply: Aug 26, 2008 9:33 AM by JScherer
ptaylor874 Level 1 Level 1 (0 points)
I'm seeing some very unusual results using WiFi on my iPhone 3G. When connected to my local WiFi network (WPA2 Enterprise... Yes, really!) I have sever problems surfing websites. On rare occasions, it works, but mostly I select the bookmark in Safari, it shows the location bar at the top and it starts filling with blue, but typically stops just after it begins filling in with blue. After some time, it tells me "Safari could not open the page because the server stopped responding".

Wondering if perhaps WPA2 Enterprise has issues, I dropped back to WPA2 Personal, but it behaves the same way, so that doesn't appear to be an issue.

One other strange thing is that the "Remote" app can find my local AppleTV, even when Safari seems unable to get to the Internet.

Perhaps the iPhone is getting confused with what it's default gateway should be? I'm saying this because I ran a packet capture on my router (pfSense) and didn't see even a DNS request from the iPhone when I attempted (and failed) to surf to a website.

iMac & iPhone 3G, Mac OS X (10.5.4)
  • 1. Re: iPhone 3G WiFi issues
    frayli Level 1 Level 1 (0 points)
    I am getting the exact same issue although since connecting to my network at home I cant connect to anything on the internet, my router is giving it an IP and the network seems connected on the 3g iphone. Apple couldnt help me, I am wondering if it is my router at home I will try to check the router at work (the internet worked via it then I updated when I got home and hasnt worked since)
  • 2. Re: iPhone 3G WiFi issues
    Mark_brennan Level 1 Level 1 (0 points)
    I am the same, iphone showing my home network but i am unable to surf/itunes. Using my mac book I shared my airport and jackpot it worked. But this is not what i want, checked with my work wifi and thumbs up again. what is going on? work fine with my old iphone?
  • 3. Re: iPhone 3G WiFi issues
    iphoneadopter Level 1 Level 1 (0 points)
    I had the same problem. I was on the phone with apple for over an hour and they couldn't solve it. From other forums I found that the DNS address that the iphone is getting through DHCP isn't working properly. You need to go to a static address (just switch from DHCP to Static) and then add the IP address of the router to the DNS address list. This should give you access to the Wifi. I'm sure it is a bug with the iPhone and hopefully will be fixed sometime.
  • 4. Re: iPhone 3G WiFi issues
    stratsj Level 1 Level 1 (0 points)
    I tried this approach and it unfortunately didn't work. I can connect to the WAP fine, but I can't get an internet connection.

    It seems to be inconsistent as well. When I connect to some wireless routers/access points I get an internet connection - others I don't.

    One thing I have noticed - when I do get an internet connection, the DNS is automatically set to the same address as the router. When I don't get a connection, the DNS is automatically set to a different address. Even if I manually change the DNS to the address of my router however, I still don't get an internet connection.

    The funny thing is it's one particular WAP that's giving me this issue, and it only started today without me changing any settings.

    Anyone have any luck figuring this one out?
  • 5. Re: iPhone 3G WiFi issues
    J. Alfredo Iniguez-Jimenez Level 1 Level 1 (25 points)
    i posted elsewhere about similar problems, My iPhone doesn't seem to have any problem connecting to open networks but can't connect to my home network (WPA personal, TKIP encryption). it always returns the message that it can't connect.
    Hopefully Apple will realize that this must be an iPhone issue (there are too many of us with the same problem to be otherwise) and come up with an update to take care of this issue.
  • 6. Re: iPhone 3G WiFi issues
    russelljones Level 1 Level 1 (0 points)
    HI

    I am very new to Apple products but have the old and new iphone.

    I have found the same problem but note that when I have a phone signal ( no matter how weak (and it is weak in my home) the WiFi works fine. And downloads at high internet speeds so its not just the phone signal taking over as there is no 3G access at my house.

    If the signal disapears then so does the accessibility to the WiFi network

    Very strange but true and I have tested this with both old and new phones, which both have latest software, and its the same for both of them. Done quite a few tests over a couple of weeks until I came to this observation.

    Very odd to me
  • 7. Re: iPhone 3G WiFi issues
    JScherer Level 1 Level 1 (0 points)
    Exactly the same problem - iphone finds d-Link router and connects (showing wifi symbol at top of iphone) then nothing - server times out on everything... nothing to do with router passwords as same problem even when I switch off route passwords... tried static IP (no joy), restarting and resetting everything in iphone and router - must be some glitch in the iphone itself... any other suggestions or ideas welcome!
  • 8. Re: iPhone 3G WiFi issues
    Kerin Gordon Level 1 Level 1 (15 points)
  • 9. Re: iPhone 3G WiFi issues
    JScherer Level 1 Level 1 (0 points)
    The fix recommended by Kerin Gordon fixed the issue - thanks a lot! I eliminated the (first) DNS number in wifi settings and it works fine now..