2 Replies Latest reply: Jul 24, 2008 2:36 PM by Richard Hallas
Richard Hallas Level 1 Level 1 (0 points)
Hi all,

Recently my PowerMac G5 died (coolant leak) and I've had to replace it with a new 2.8GHz Mac Pro.

I have an original FireWire external iSight camera that I got off eBay fairly recently, and which I'd used (briefly but successfully) with the G5.

Now that I've got the iSight attached to the new Mac Pro, I find that its microphone doesn't work. As a camera it works fine, but I get no sound input from it. I've tried plugging it into both the front and back FireWire 400 ports on the Mac Pro to see if it works with one and not the other, but it won't work with either. Video image fine; sound input non-working. It definitely worked OK before, when it was attached to the G5.

My system is completely up to date, as of today (24th July), running Leopard 10.5.4.

I'm not sure how one is supposed to tell what version of the iSight firmware is installed, but I looked under the FireWire section of Apple System Profiler, and the iSight is listed there as follows:

iSight:

Manufacturer: Apple Computer, Inc.
Model: 0x8
GUID: 0xA2700040E355E
Maximum Speed: Up to 400 Mb/sec
Connection Speed: Up to 200 Mb/sec
Sub-units:
iSight Unit:
Unit Software Version: 0x102
Unit Spec ID: 0xA02D
iSight Unit:
Unit Software Version: 0x10
Unit Spec ID: 0xA27
iSight Unit:
Unit Software Version: 0x11
Unit Spec ID: 0xA27
iSight Unit:
Unit Software Version: 0x12
Unit Spec ID: 0xA27
Product Revision Level: 1.0.2

Now, I don't know why there are all those near-identical 'iSight Unit' entries, but I do note that the last line says "Product Revision Level: 1.0.2", so I assume that it means that I've got the 1.0.2 software installed in the camera.

I checked in the downloads section of Apple's support pages and found that there was an update available to version 1.0.3, and that version 1.0.3 improves audio performance in some way. So I tried to install the update, to at least see if I was able to.

And the answer is that I wasn't. The updater told me that I couldn't install the update on my machine because it doesn't run on any version of Mac OS X from 10.4 onwards.

I do still have an old laptop with Tiger installed on it, but I certainly don't have a machine that runs Panther any more, and Panther seems to be the latest OS supported by this particular update; so I can't even see if the 1.0.3 update would fix my problem (and there's no guarantee that it would anyway; it just sounded as though it would be worth a try).

Can anyone offer any advice about any of the above? I do have a USB headset with a working microphone in it, so the problem isn't a show-stopper for me, but I'd prefer the iSight to work properly if possible.

Mac Pro, Mac OS X (10.5.4), Dual 2.8GHz (8-core), nVidia GeForce 8800 GT
  • Malcolm Rayfield Level 7 Level 7 (28,070 points)
    Does the iSight show up as a choice for "Microphone" in QuickTime Player's "Recording" preference?
    Does it show up in the "Input" tab of "Sound" system preference?

    You may be able to apply the version 1.0.3 update The installer won't work because it was made before Tiger, and they didn't update it since the iSight was discontinued, but the update itself may work. Right click on iSightUpdater103.pkg in the downloaded iSightUpdater103.dmg and select "Show Package contents"
    In the package, double-click:
    /Contents/Resources/iSightUpdater103.pax.gz
    This should create:
    iSight Updater 1.0.3.app
    Move this to your Utilities folder and double-click it.
  • Richard Hallas Level 1 Level 1 (0 points)
    First of all, thank you very much: you've just solved my problem!

    To answer your initial question, the iSight did indeed show up as a sound input in all the places it should do so, including the Input tab of Sound in System Preferences (and Skype, and iChat etc.). Everything appeared to be absolutely correct, with the small shortcoming that the microphone didn't actually work!

    However, I followed your advice to extract the iSight 1.0.3 updater from its enclosing package, and having run that, it successfully updated my iSight to the latest software... and bingo! It works!

    So that really was all there was to it. I find it odd that the iSight worked fine on my G5 with Leopard but not on the new Mac Pro, but there you are... I guess that's what firmware updates are for.

    One slight oddity is that System Profiler is still showing the firmware as 1.0.2 (and I've done a 'Refresh' in case the info was cached), but the update did work and the updater application does now report the firmware as 1.0.3. And the main thing is that it does indeed now work correctly!

    So, thanks very much once again. That was a very swift and painless solution to an annoying problem.