Previous 1 2 Next 29 Replies Latest reply: Dec 30, 2009 5:52 PM by
turinreza Level 1 Level 1 (0 points)
keep following the instructions to the letter and keep getting

i was able to sign before. submitted app to store and got submission issue
"Missing Embedded Profile"

followed the instructions givein
"The documents are entitled, "Migrating from iPhone OS beta 6" and "Building and Distributing Multiple OS X iPhone Applications".

and now i get this stupid error


at a loss..

this is ridiculous

Mac OS X (10.5.2)
  • turinreza Level 1 Level 1 (0 points)
    i marked both the Apple WorldWide Developer certificat as always trusted..
    and the iPHone Distribution one as Always trusted

    put them in both login and system keychain
    the private keys are in both login and system

    still get same error

    why doesn't APple just do the codesigning for Distribution?
  • turinreza Level 1 Level 1 (0 points)
    /Users/jimmy/iCrowdSurfBetaAppStoreSubmit/build/Distribution-iphoneos/i######### .app: replacing invalid existing signature
    /Users/jimmy/iCrowdSurfBetaAppStoreSubmit/build/Distribution-iphoneos/i######### .app: CSSMERRTP_NOTTRUSTED
  • masterlee_dev Level 1 Level 1 (0 points)

    have the same **** CSSMERRTP_NOTTRUSTED while trying to sign it. Any help?
  • Amilion75 Level 1 Level 1 (0 points)
    Same problem, did anyone found a clue ?
  • turinreza Level 1 Level 1 (0 points)
    this turned out to be a problem with the certificate..
    i deleted all the private public keys,
    requested a new developer certificate.
    made sure to request it from the same machine and
    downloaded the new cert and installed it..
    made sure they existed only in the login keychain.

    i also deleted all the provisioning profiles in the mobileeevices/ directory
  • Amilion75 Level 1 Level 1 (0 points)
    Yes, I also solve this problem by adding the dev certificates at the system level. So I have 3 certificates at the same level :
    - Apple Worldwide
    - iPhone Developer: xxxx

    Build is now OK.

    But now I have got another problem : "Your mobile device has encountered an unexpected error (0xE8000001) during the install phase: Verifying application".

    It's a mess this Dev System.
  • Amilion75 Level 1 Level 1 (0 points)
    Finally I succeed to make the dev system work.
    1) *take care not to have special character in your login name* (on the MAC developping machine) my name has a "-" (minus). The result is CSSMERRTP_NOTTRUSTED error when you build your app.
    2) in xcode your have to be sure that in the build tab you can assign you developer profile. If not assign the system give a OxE800001 error when installing the code on the iPhone.
  • UglyAsCyn Level 1 Level 1 (0 points)
    For two long rainy days I worked on this. I loaded and deleted my certs and profiles so many times I had the instructions in the "iPhone Developer Program Standard Program Portal User Guide for OS X iPhone 2.0 " memorized.

    These are a few of the fine details that finally got my Hello World app to load on my iPhone.

    1. On your Mac's Keychain Access Program, under the login's Keys delete all the keys with duplicate names these are created while you are attempting to get your iPhone Developer Cert., profiles, etc to work. Only keep the key with the caret with the iPhone Developer sub category. Double click on this Key and set "Access Control" to "Allow all bla bla bla....."

    2. On your Mac's Keychain Access Program, double click the login's 'My Certificates' iPhone Developer and under Trust set to "System Defaults"

    3. In Xcode edit the "Bundle identifier" key in the info.plist of your application to read${PRODUCT_NAME:identifier} where 123456 is the Apple Id of your Provisioning Profile you created in, it should be a string with few numbers and letters with an * at the end. Substitute that string for the 123456. Remember this only works if, when you created your Apple ID you gave it a name and entered "*" for the App ID(Bundle Seed ....)

    4. Then in Xcode under the Build tag of your applications "Project info" set the following:
    -- Under "Code Signing identity" set the subcategory "Device = iPhone OS 2.0" -> "iPhone Developer:" to the same name in the "Keychain Access Program" of your iPhone Developer Key (mentioned my step 1 of this madness).
    -- Set "Code Signing Provisioning Profile" to "Default Provisioning Profile for Code Signing Identity" and the subcategory "Any iPhone OS Device" to the same "Default Provisioning Profile for Code Signing Identity".

  • iTea Level 1 Level 1 (0 points)
    Win. Thank you!!
  • bryanmackinnon Level 1 Level 1 (0 points)
    I'm fully at a loss for this problem. I've tried everything that I can find. I've also asked Apple directly but no useful response yet. Is there any info on the root cause that anyone knows about?
  • vzaliva Level 1 Level 1 (0 points)
    I am having the same problem and I tried all kinds of things suggested in this thread. I think I found the reason of the problem, but yet unsure how to fix it.
    If you try to use Keychain Tool, they have an "Evaluate" function in "Keychain Assistant" menu. When I run my "iPhone Developer: ..." cert via it, it says "No root cert" found. I have checked and I do have both Apple Word Wide Developer Connection and Apple Root certs in my keychain. I even re-imported them. The problem seems to be with Apple WWWDR cert. When I try to evaluate it, it says "Policy Verification Failed".

    Any suggestions how I can fix this problem?
  • bryanmackinnon Level 1 Level 1 (0 points)
    I'm not sure if anyone at Apple is paying attention to this thread. But I suggest asking them directly and if anyone gets lucky enough to get a response, then post it here. About 4 days ago I asked them but the response was they'd reply "soon."
  • bryanmackinnon Level 1 Level 1 (0 points)
    As a test, I deleted the Apple WWWDR cert from the key chain as a test and still got the same error (CSSMERRTP_NOTTRUSTED). So it may be that the problem is actually with the developer cert. Apple stated that they are "waiting a response from their development team." It's been almost a week since I asked them so not sure when their response will come.
  • bryanmackinnon Level 1 Level 1 (0 points)
    For some reason and without any changes on my part, this error disappeared. It just went away. Don't know if anyone else saw this.
Previous 1 2 Next