4 Replies Latest reply: Jul 25, 2008 1:20 PM by Macfizzle
Steve Canning Level 1 (15 points)
I just got my 3G iphone and I cannot get it to find my existing wireless network. I know the network is functioning properly because my macbook pro locates it just fine. I have tried removing the wpa2 encryption and it still will not find my network.

Any suggestions??


MacPro dual 2.66 3GB RAM/ MacBook Pro 15", Mac OS X (10.5.4)
  • theevilone Level 1 (15 points)
    in settings under wifi do you have it turned on.
  • Birkir Baldvinsson Level 1 (0 points)
    I have the same problem with this. It worked everywhere else, like in the mall where a Wi-Fi was current.
    Im now at home, and I cannot find my Wireless Internet, but ... I tried "Reset Network Settings", which seems to bugged it up. I could not update to 2.0 from 1.1.4. And it froze on "Resetting". I have now reset all settings, and it seems to work... Im not done with updating.

    Although I could not find my net, I cant make or receive calls either, but what I wondering is why cant I turn Wi-Fi ON? It wont let me.


    It wouldnt let me update, because of Network Settings...
    Am I doing something wrong, or did I do something wrong?
    Im hoping its just the Area, Im currently in Thailand, I'll have to see later if Im at a mall or something with Wi-Fi :P

    Message was edited by: Birkir Baldvinsson
  • Macfizzle Level 1 (0 points)
    Here are my recommendations:

    Note: I am assuming that you are familiar with both AP & client configurations, please follow these recommendations to your own comfort level. Also some of these items are things that I am sure that you have checked before

    1) If possible, I would first take your iPhone to an environment that has a broadcasted SSID without an authentication/association requirement (i.e. a Pre-Shared Key). Whether it be a neighbor's house, or a public place with wireless access. I recommend this first before tinkering with your own access point settings. If you are really comfortable with your Access Point's (AP) settings, we can go to step number two.

    **Ensure that the 802.11 transceiver is on and attempt to associate to the AP. If it is successful, proceed to number two**

    2) If you tested at a third-party site, or skipped straight to here, it's ok. We are going to open up your access point to an easy to join posture, and then lock it back down step by step, so that we can see which settings might be interfering. As you mentioned before, you disabled WPA encryption. Make sure that it is still disabled. Now I would also like you to ensure that your SSID is broadcasted. Now, if you touch the Settings Icon, you should see +not connected+ next to Wi-Fi. Touch the Wi-Fi button, and you should see your SSID appear. If you do not, you might want to take your iPhone to an Apple store if there is one close by & have them look at it. If you do see it, go ahead & attempt to join.

    3) At this point, I am assuming that you were able to join the network. Now log into your AP and enable WPA encryption and enter your Pre-Shared Key (WPA). Your iPhone should be bumped off of your network because of the newly enabled encryption. Use the same method as mentioned above to join the netowrk, but you will also need to enter your encryption scheme & key.

    4) At this point, verify that your other clients can join your wireless network. Keep the SSID broadcasted for now, because if you accidently changed either your SSID or PSK, it will be very easy to rejoin.

    5) Once you have all clients back on the network, stop broadcasting your SSID.

    At this point you should be good. Email me at macfizzle@gmail.com if you have more questions. Good Luck boss =)