3 Replies Latest reply: Jul 27, 2008 11:17 PM by BikeRanger
dragonflyx Level 1 (0 points)
Cro-Mag was working fine, but after attempting to update via the iPhone I got a message that stated the update failed and I would have to go to iTunes to get it. At that point, the icon for Cro-Mag disappeared from my phone.

The download from iTunes worked fine. It had some trouble synching (took a LONG time) but finally finished. When I went back to my phone it asked for my password... but since I didn't know what it would want my password for I hit "cancel". For a brief few seconds I saw the Cro-Mag icon in "update" mode (but the progress bar remained empty) and then it disappeared. Now I can't get it back.

I have tried restarting the phone, asking iTunes not to install Cro-Mag and then installing again, even tried to re-download (I can't delete because the icon isn't there to hit the x). In the iPhone app store it says "Installed". So it seems the icon is just missing....

Any suggestions would be greatly appreciated.

Mac OS X (10.5.4)
  • dragonflyx Level 1 (0 points)
    I stumbled across a way to fix this. I have no idea what is happening...

    I tried to purchase and download from the iphone another app (Vey) which again failed and told me to go to iTunes. Download from iTunes was ok, sync was fine... when all was done, Cro-Mag icon appeared and Vey was not there.

    So I figured if I want Vey to show up I would need yet another app... and thus picked out a free app, downloaded it (this time successfully on the iphone) and once that had installed, all icons, including the free app, now appear.
  • BikeRanger Level 1 (0 points)
    Similar (I think) problem here...

    I purchased an app, which downloaded and installed successfully. A few days later it disappeared from the iPhone. I'm not sure exactly when it disappeared, I don't think I noticed it right away.

    Figured it was just a glitch and went to re-install it from iTunes. The app doesn't appear in the iTunes app library, although all my others do, including some purchased at the same time as my missing app. It also doesn't appear on the phone in the Applications tab in iTunes.

    The missing app's .ipa file is still in /Music/iTunes/Mobile Applications. I have a backup copy and the app is on my iTunes purchase history. It just doesn't appear in iTunes. No error messages.

    I've tried restarting but not restoring. It seems like an iTunes problem since the app is on my computer but not shown in iTunes, so I'm hoping to avoid restoring the phone. Downloading a free app to shake loose the paid one didn't help in my case.

    Anyone else seen this problem or have an idea how to fix it?
  • BikeRanger Level 1 (0 points)
    Restored my missing Tuner app, it was embarrassingly easy.
    ] Shut down iTunes
    ] Overwrite .ipa file in /Music/iTunes/Mobile Applications from backup
    ] Start iTunes
    ] Select .ipa via File > Add To Library, then Open
    ] Check app for syncing under the Application tab for the device (or choose All Applications)
    ] Apply, then sync

    The app worked but needed an update (maybe this is what caused my issue?). All good after the update. Sorry to thread-jack -- thought it was related.