7 Replies Latest reply: Jan 11, 2009 10:40 AM by artiespk
Charlotte Mercer Level 1 Level 1 (15 points)
Please help!
I have three IMAP accounts set up in Mail, which all work perfectly as long as the IMAP path prefix in the Advanced settings is blank. However, I'm constantly getting a dialogue box saying that Mail needs to change the imap path prefix to INBOX (which is apparently what my mail server reports it as) in order to create the Apple Mail To Do folder on the server (which I neither want nor need as I have set Mail to store To Dos etc. on my mac, not on the server).

If I let it change this setting, I can suddenly no longer see any of the messages inside the folders in my mail accounts. I can see the contents of the Inbox, and the folder structure, but the folders all appear empty. If I check the account online via webmail, all the messages are still in the folders.

I've spent all day checking Google, Apple Support, my hosting service's support pages and various blogs and hints sites, but nothing they have suggested has worked.

Is there any way at all that I can either get Mail to stop trying to create the Apple Mail To Do file (and hence the dialogue boxes to go away), or to get my folders working with an IMAP path prefix?

One point that might be of interest - my three accounts all show up in Mail as 'inbox' icons underneath the top-level Mail inbox icon. I half remember somewhere that IMAP accounts were supposed to show up as separate top-level 'globe' icons, but I can't get mine to do that. I've tried creating new accounts from scratch but they still show up as inboxes. Not sure whether that's relevant or not.

Happy to supply any further info required. I can get at the various mail files on my hosting service but don't know enough about what I'm seeing to do anything without instruction!

Best,

C.

Mini, 1.83GHz, 2MB RAM, Mac OS X (10.4.10)
  • badtz Level 2 Level 2 (250 points)
    I have this EXACT same issue. My email server wants INBOX as the prefix, but Mail.app only works if the prefix is BLANK, but it keeps asking for the prefix to change to INBOX because of the ToDo folder ..... and if it is changed to INBOX, it creates a 2nd INBOX folder, and things start to get screwy.

    Anyone find a solution yet?

    I don't think it's the host's problem, I think it's Mail.app ......
  • RW in New York City Level 1 Level 1 (0 points)
    To get rid of it, permanently, this has worked for me so far.

    Make sure Mail is closed. In the Finder go to the Mail.app application. Right-click (or CTRL-click) and select Show Package Contents. In a folder called PlugIns is a file called "ToDoPlugIn.bundle". Move this file to the folder called PlugIns Disabled.

    Reopen Mail.app, and delete the To Do icon from your toolbar. You may have to delete the "Apple Mail To Do" folder in your email server manually, but it shouldn't reappear manually.
  • May2007 Level 1 Level 1 (0 points)
    did not work.

    any new ideas so far?
  • edchien Level 1 Level 1 (0 points)
    Just to add my 2 cents... I'm having the same problem. Even more so, I've been having this problem for the last year and couldn't find a solution. I get the IMAP path prefix notice when I try to move a mail from my INBOX to one of its subfolders. I've been clicking cancel for the last year.
  • badtz Level 2 Level 2 (250 points)
    I FINALLY FOUND A SOLUTION (it worked for me at least, after days of screaming at the G5 :P):

    Delete ALL of the email accounts in Mail. Then close and re-open Mail.

    Viola, worked for me Hope this helps someone! Now the INBOX prefix sticks perfectly! If you get the constantly duplicating INBOX sub-folders, log in via webmail and delete the INBOX.INBOX folder, and re-open Mail.
  • ssh Mac Level 1 Level 1 (20 points)
    I want to express my gratitude for this insight! I had "Apple Mail To Do" folders in every one of my IMAP accounts (including one that's on an Exchange server) and that folder seemed to be the cause of a number of issues. Making this change seems to have removed Mail's propensity to recreate that folder every time I delete it.

    Thank you! This is very helpful!
  • artiespk Level 1 Level 1 (0 points)
    Ho hum. After fiddling with all these settings, I started looking at the server and discovered that my UW (& Cyrus) /can't/ be adjusted to send an IMAP path prefix other than "" without going and amending the source code.

    So I installed Dovecot (http://www.dovecot.org), set the 'mail_location' correctly in the /etc/dovecot.conf file (http://wiki.dovecot.org/MailLocation), and I don't need to put anything at all in Apple Mail's IMAP path prefix box.

    A bit of a drastic step (and not one available to everyone), but everything seems to be working normally now. Well, I say everything: I've just got to work out why Mail seems to recreate the hierarchy of empty folders it was previously told about in some (not all) IMAP accounts everytime it quits.