11 Replies Latest reply: Nov 19, 2008 3:00 PM by inrime
ecflagg Level 1 Level 1 (0 points)
While attempting to burn a movie from iDVD, MacBook Pro rejects blank Maxell DVD-R discs.
System also rejected a commercially available DVD and CD-R.

Is this a common problem, and what is the solution?

MacBook Pro, Mac OS X (10.5.4)
  • 1. Re: SuperDrive rejects DVD-R
    MWGum Level 1 Level 1 (0 points)
    I have had the same problem on my MacBook Pro and on a MacPro. Just trying over and over again eventually gets it to work for me.
  • 2. Re: SuperDrive rejects DVD-R
    ecflagg Level 1 Level 1 (0 points)
    I talked to Apple about this today - Tech Rep told me it is likely a software problem. The drive will read music CD's and was accepting movie DVDs while on the phone. Conclusion was that the drive is mechanically sound.

    Bigger question: If a software problem, where's the update to correct the problem? Come on Apple, even a PC works better than this.
  • 3. Re: SuperDrive rejects DVD-R
    jomitch Level 1 Level 1 (0 points)
    Wierd!
    I'm having similar problems still although the complete opposite.
    My drive reads and burns dvds no problem - have just successfully burned 3 philips dvds this morning (all from idvd) but when I try to burn folders from Finder onto blank cds, then this is when I come unstuck. Today since burning the dvds i have tried 2 cd burns onto a ridata and also sony disc - both ejected almost immediately with error code 0x8002006D. Incredibly frustrating. Both these brands have worked for me in the past if only sporadically.
    I missed my service at genius bar this morning but am booked in for Wed morning so I am making a complete log of all in/activities today to tell them.
    Also, my drive no longer reads any commercial music cds which it used too!!!
    Madness.
    Anyone else tried this combo update 10.5 that was mentioned in another thread - its isn't listed in my software updates?
    thanks
  • 4. Re: SuperDrive rejects DVD-R
    rshim Level 1 Level 1 (10 points)
    I was having the same problem. All of my blank DVD -R discs would spin in the drive for 10-30 seconds, the drive would make some clicking sounds and then eject the disc. DVD DL discs would have no problems. I tried resetting PRAM, but that did not help. I tried multiple brands of DVD -R's but that did not help either. I finally went and tried a lens cleaner (with the tiny brushes-Fellowes). I know these are not recommended for slot loading drives and I was potentially asking for trouble, but I needed a solution. Fortunately, the cleaner disc was read by the system properly, the movie played and the tests ran without a problem. Once it was complete, I popped in a DVD -R and it load without a hitch. Have burned 2-3 discs now without a problem.
  • 5. Re: SuperDrive rejects DVD-R
    per4manz Level 1 Level 1 (15 points)
    I can attest to this working as well. See my post regarding this here:

    http://discussions.apple.com/thread.jspa?threadID=1651354&tstart=0
  • 6. Re: SuperDrive rejects DVD-R
    222ele Level 1 Level 1 (0 points)
    The cheap DVD cleaner works for me too. I was ready to buy an external drive, but thought I'd try this and so far I've been able to burn a few DVD-R and CD-Rs without a problem.
    It seems odd that the drive would be so sensitive, but this is definitely worth a try if your superdrive doesn't burn or read discs. No problems ejecting the cleaner disc either.
  • 7. Re: SuperDrive rejects DVD-R
    KevLeviathan Level 1 Level 1 (145 points)
    Another "me too", I used a laser lens cleaner disc and fixed my MBPs problem not burning DVD-Rs.
  • 8. Re: SuperDrive rejects DVD-R
    dan440 Level 1 Level 1 (0 points)
    Mine actually rejects DVD+Rs. I just had to run to the store and buy DVD-R because it wont read the +. The CD-Rs it reads too. Odd. I tried feeding it DVD+Rs numerous times and got nothing.
  • 9. Re: SuperDrive rejects DVD-R
    Peter Liao Level 1 Level 1 (15 points)
    Yet ANOTHER "me too!" Couldn't get my MBP to keep a blank DVD-R in the drive. It could read commercial DVD movies and CD's [blank or otherwise]. So, I took the advice of several users and bought an inexpensive laser lens cleaner. I had a hard time finding the Phillips DVD lens cleaner, so I went with the SkipDR Any Lens Cleaner from Circuit City [$14.99]. Now the optical drive recognizes a blank DVD and I'm in business again! Thanks to all who wrote in.
  • 10. Re: SuperDrive rejects DVD-R
    Peter Liao Level 1 Level 1 (15 points)
    Another thing... Before the DVD-R's kept getting ejected, when I would write to a DVD-R, it would often fail verification. I have yet to put it to the test with regard to that. But, I suspect that problem may be related and hopefully fixed by the lens cleaner.
  • 11. Re: SuperDrive rejects DVD-R
    inrime Level 1 Level 1 (0 points)
    I hope this discussion isn't at the end... i have this problem with blank dvd-r disks ejecting.
    i brought the lens cleaner into the equation...
    repaired permissions...
    reset the 'what to do when disks inserted' preferences...

    got a superdrive version (2006) imac have wrote dvd+DL before; can write cd-r still; never wrote dvd-r ever: could it be a manufacturer malfunction or does the lens cleaner need to be "Phillips" - (partly joking)

    do the solution-type cleaners work best? or what...
    i am hesitant to say that it is cleaning or hardware as i hadn't used dvd-r before and cannot say if it's broke or has never worked...
    i ran out of direction for relevent questions... Thx.