6 Replies Latest reply: Nov 8, 2008 9:47 AM by Andrew T.
Nyorker Level 1 Level 1 (0 points)
When i am on my laptop and my iphone is connected to my wireless netowrk (linksys wrt54g) my laptop will connect to the network but it will not let me surf the web, it just stalls.. Why is this? if i turn off wifi on the iphone then the laptop starts to work.. Is there a way to fix this?

hp laptop, Windows Vista
  • Francia Level 1 Level 1 (35 points)
    I am having the exact same problem. WiFi reception has never been a problem at home with my Powerbook. Ever since I've gotten my iPhone and set-it up on my WiFi network, I don't get a stable connection with my Powerbook. The iPhone has got to be the problem, I didn't have this problem before.

    My signal strength on my Powerbook shows I have full strength however once every 10 minutes I can't surf (pages don't load) and my email isn't being updated, as if I didn't have internet anymore. I shut off airport and re-open and the problem is solved... for another 10 minutes. I've tried changing channels but the problem is still there. I haven't tried shutting off WiFi on my iPhone, I will test it however. I have a hard time believing this wasn't tested by Apple prior to launch.

    Message was edited by: Francia
  • McJones123 Level 1 Level 1 (0 points)
    I am having the same problem as you. Is there a real solution for the problem?
  • Allan Sampson Level 10 Level 10 (123,370 points)
    I'm using an Airport Extreme base station for my wireless network at home and I was using an Airport Express before that. My wireless network is encrypted via WPA2 Personal.

    I have no such problem, nor have I experienced any problems after connecting my iPhone to the wireless network at my office, nor have there been any reported problems after I've connected my iPhone to the wireless network at my sister's house with a number of computers accessing the internet via the wireless network. I don't know which brand of wireless router that my brother-in-law is using and the model, but it isn't an Apple wireless router.

    Which wireless router are you using? If an Apple wireless router, have you installed updates when made avaialble - which haven't been many?

    If a 3rd party wireless router, have you checked the manufacturer's website to see if a firmware update is available for your router model that you haven't installed?
  • McJones123 Level 1 Level 1 (0 points)
    After a bit of fiddling around with the Airport's preferences enabling the "interference robustness"-option seems to have solved my problem.
  • Francia Level 1 Level 1 (35 points)
    After trying to ignore this problem for a few months (I've been keeping my Powerbook connected with Ethernet) I still have to find a solution to the Airport problem. My boyfriend who is an IT tech is baffled by this problem. If I shut off my iPhone completely I have no more WiFi connection issues with my laptop. If the phone is on, I lose my connection every 5 to 10 minutes. We've even assigned static IP addresses to both through our router using each unit's MAC addresses and still the problem persists.
    The router we have is a D-Link DI-524. Internet Robustness does not help, the problem remains.
  • Andrew T. Level 4 Level 4 (3,210 points)
    Hello everyone. I have personally found that the following tips work for me in my own home environment.

    1. Keep cell phone 10 feet away from computers and just waring my BT headset. Depending on your cellphone plan you can easily have these calls forwarded to a skype line of some sort. Which will reduce the need of having to have the cell phone near the computers. You can also use certain software to forward SMS alerts to the computer you are using.

    2. Update WiFi card and other driver updates for your personal machine.

    3. Updating Router Firmware as some of the updates will help improve stability and performance. (Check your router manufacture website for more info on firmware updates.)

    4. Changing the Radio mode from Mixed mode to a more precise mode. Like B/G only, G only, B only, N only, etc.

    5. Changing the channel on the router from Automatic to a channel from 1 to 11. In hopes of hitting a channel that will pose less interference with cell phones

    6. As stated earlier if needed you can activate Interference robustness on Airport Routers, and on the Tiger OS

    7. Raising the router and re-locating the router to provide better signal will also decrease potential drop outs and disconnects with the computer.

    AirPort: Potential sources of interference