Previous 1 2 Next 24 Replies Latest reply: Apr 15, 2009 11:32 AM by Alex Suarez
kenec Level 1 Level 1
I just updated to 2.1.1 and tried importing some pictures from my Nikon D80. The import pane only shows grey boxes as placeholders for the images in my camera. I can import the pictures into my library and see them there. Anybody else having this problem?

On a positive note, pictures are now auto-rotating properly with the D80...

PowerMac G4 Quad, Mac OS X (10.5.2)
  • atomicbunny Level 1 Level 1
    First of all, sorry for my maybe crappy english!

    I have the same problem after installing the update. Because of the tether function, the USB on my D80 is set to PTP. When i set it to Mass Storage USB i can see the previews. But the tether function is not working with this setting. Seems to be a bug ...

  • John Jarrett Level 1 Level 1
    I'm having same problem. A new software upload just became available this morning and after loading it, it asks for my Aperture serial number. I DON'T HAVE THAT PAPER ANYMORE. I'm an event photographer and lost about $600 yesterday because of this. Anyone know how to get that info from Apple? They sure don't want to talk to you if you didn't purchase AppleCare.
  • sizzling badger Level 1 Level 1
    If you have a perfectly legal copy of Aperture you should not get asked to input the serial number. If you have a serial number that you have obtained from a shared / illegal site for instance then this update may identify that serial number as being compromised and will not install. If you have given your serial number away then it could well have been passed on to one of these sites and may have been compromised.
  • Alex Suarez Level 1 Level 1
    I'm Using a Nikon D300 and am experiencing the same +missing thumbnails in the import pane+ issue with the Aperture 2.1.1 Update.

    Troubleshooting I have tried includes:

    • Rebooting
    • Deleting the Aperture preferences: ~/Library/Preferences/
    • Setting Image Capture as the default application when the camera is connected and testing if I get image thumbnails there--I do.
    • Setting to USB Mass Storage. As Mario pointed out above, this lets me see thumbnails but requires that I remember to eject the camera before I disconnect and I have to switch my camera back to MTP/PTP to shoot tethered. <--This is a workaround, but it is not pretty.

    It appear that 2.1.1 has broken this functionality and we'll have to wait for another update.

    My 2¢,
  • sizzling badger Level 1 Level 1
    I have the same problem with my D300. I have reverted back to version 2.1 with Time Machine for now.
  • David Slater Level 6 Level 6

    then your silly for throwing out your license for your working software

    keep these around at all cost
    very silly of you . . .

    btw 1-800-sos-apple
  • bapenguin Level 1 Level 1
    I'm having the same problem with my Nikon D60. No preview icons.
  • John Jarrett Level 1 Level 1
    My copy was purchased directly from Apple. The screen that pops up and asks for my serial number even has my name and company name already filled in. Why would Apple ask for this number when they already have it on file? Anyway, any suggestions on how to contact the right people at Apple to get this info?
  • Alex Suarez Level 1 Level 1
    If it was purchased as an online download, then you should have received an email with the serial number that you used to activate the software. If you had it pre-installed on a Mac that you bought from Apple online, then the serial number should be in the paperwork you received with the Mac. You might also look at your purchase history on for a possible listing of your serial number. If that doesn't help, you might also talk to the Apple sales folks at 800-MY-APPLE. That's less likely to be a resolution for your issue.

    Also, if you have a Time Machine backup of your drive, you might restore it to another drive and boot from that drive and launch Aperture. You can then retrieve your serial number from the startup screen or the "About Aperture" window. Hope this helps.

  • David Slater Level 6 Level 6
  • Rogier Mulder1 Level 1 Level 1
    I have the same problem with multiple camera's: Nikon D2X (NEF) and Ricoh GX100 (DNG).
  • ryanka Level 1 Level 1
    Try this [Troubleshooting serial number issues with professional products|]
  • Old Man at the Mac Level 1 Level 1
    Same with me. I have a Nikon D80. This worked fine before the last update. Now I get blank camera preview images when trying to import from the camera. Tried using iPhoto and the preview images are fine.
    All the photos are raw images.

    This is a real pain. It would be great if it could be fixed (please).

  • Charles G. Level 1 Level 1
    No preview thumbs in import pane here either! - (Nikon D40, Aperture 2.1.1) Don't you just hate it when a great software develops problems like this...

    My work-around: Use Image Capture to preview + download your RAW images then import from file in Aperture. Not ideal but beats looking blank squares!
Previous 1 2 Next