3 Replies Latest reply: Sep 14, 2008 10:20 AM by sharewaredemon
sseguin Level 1 Level 1 (0 points)
I'm setting up multiple email accounts in Mail.

Internet provider is with Rogers

Rogers blocks SMTP ports so the only SMTP I can use with all my mail accounts is smtp.broadband.rogers.com

Having a problem with Mail where one of the accounts is using the "Email Address" field (under Mail Prefs, Accounts, Account Information, field under "Description") for SMTP authentication and not the actual "User Name" field (under Outgoing Mail Server, edit server list, advanced, Authentication: Password)

So when I try to send an email with this non rogers account, I get the error:

*The sender address info@myotherdomain.ca was rejected by the server smtp.broadband.rogers.com.*

*Select a different outgoing mail server from the list below or click Try Later to leave the message in your Outbox until it can be delivered.*

If I go to info@myotherdomain.ca's settings and remove info@myotherdomain.ca from the email address field under "Account Information", the message can send fine... Problem being, it uses another of my email address as the sender so if people reply, they reply to the wrong address.

Seems that Apple mail's tying to use the email address for for SMTP authentication, instead of the username field.

Any ideas on how to fix this? All help appreciated and thank you in advance.

Cheers.

MacBook, Mac OS X (10.5.4), Mail Version: Version 3.3 (926.1/926)