Previous 1 2 3 4 Next 47 Replies Latest reply: Jan 6, 2010 7:25 AM by Tytuss
jlcarey1 Level 1 Level 1 (0 points)
Trying to get new iPhone 3G to work with ActiveSync on an Exchange 2003 server. I type in all of the required info and get the following error: "Exchange account verification failed." ActiveSync is setup correctly on the Exchange server itself, port 443 is open on firewall. When the iPhone prompts me to add in info the the server, I put in the IP Address of our firewall because the name of our email server is not publicly published anywhere in DNS for spam control reasons. What else needs to be done to get this thing to work?

Windows XP Pro
  • dblj79 Level 1 Level 1 (0 points)
    I've had similiar issues. Any resolution yet?
  • Lisa_G Level 1 Level 1 (0 points)
    I'm having a similar issue - one of the users in our office has just given up and returned the phone....
  • doungchak Level 1 Level 1 (0 points)
    I'm getting a similar problem. Here's what I got.

    - Exchange Server 2003 with all the correct updates. OMA is enable both for the use and via ESM

    - I have a certificate that I created via certificate server and via the iPhone Configuration Utility. I installed the root cert and the site cert. I can access my OWA via Safari OK with SSL and no SSL warning.

    - My exchange server is behind a firewall so I have to access it via https for OWA and OMA.

    I'm getting same "Exchange Account Verification Failed" on the iPhone. Does anyone know how I can view some logs or something?

    Thanks.
  • pugnut Level 1 Level 1 (0 points)
    I had the same issue. I did a complete restore, however I did not restore form backup. I started form scratch and it worked with no issues. Also there seems to be somthing with connection via Wi-fi when trying to setup. I would not recommned setting up via wi-fi
  • Chuck Coulson1 Level 1 Level 1 (115 points)
    GREAT tip pugnut! I was having the same problem and disabling WiFi allowed my Exchange setup to complete.
  • dblj79 Level 1 Level 1 (0 points)
    Did what you recommended, Pugnut, but still get the account verification failed message. Any other suggestions? HELP!!!
  • LenH Level 2 Level 2 (390 points)
    Question: Are you manually configuring all of the Exchange settings when you set this up or are you just keying in an email address?

    You may need to manually configure your client settings for Exchange 2003 (and some companies have their Exchange environments tweaked in different ways).

    Perhaps if you configure all of the settings manually or use the iPhone Configuration Utility to set up an Exchange profile with all of the login information and server name, etc. you might be able to get it set up.
  • FiberNut Level 1 Level 1 (0 points)
    ...You may have already done this, but in order to get iPhone to properly "see" the mail server from the outside etc., some of the entries in the Mail settings are not entered with the info you might think:

    +*Username syntax with domain prefix is usually noted thusly:*+
    domain\jschmoe

    +*Username syntax required to get ActiveSync working on iPhone:*+
    domain/jschmoe

    Note the slashes direction. Mine didn't work until I used the slash (NOT the backslash one is used to)

    Server:
    I first tried it with the actual (inside) name of our Exchange server (duh) which didn't work; then the IP address, which also didn't work. Finally used the OWA name:

    email.domainname.com

    And of course, turn on "Use SSL"

    All working, ActiveSync pushing immediate syncs/copies of all Calendar, Contacts & Mail activity to the iPhone efficiently.

    Message was edited by: FiberNut
  • dblj79 Level 1 Level 1 (0 points)
    I have manually configured my iPhone settings. I think I'll give the utility a try.
  • dblj79 Level 1 Level 1 (0 points)
    Seems so straight forward (except for the part about back slash - forward slash). Tried your suggestions, but still no luck. BTW, ActiveSync is working on Windows Mobile devices within our organization. Any special considerations that one needs to be aware of with an iPhone?
  • LenH Level 2 Level 2 (390 points)
    dblj79 wrote:
    Seems so straight forward (except for the part about back slash - forward slash). Tried your suggestions, but still no luck. BTW, ActiveSync is working on Windows Mobile devices within our organization. Any special considerations that one needs to be aware of with an iPhone?


    None at our organization. No modifications to the Exchange side of things and we configure our iPhones just like we do with Windows Mobile. We are on Exchange 2003 SP 2, which is the minimum version.
  • Stowy Level 1 Level 1 (0 points)
    We may have figured this out. We had a user reporting this same error and he called back and said he got past this error by doing the following steps

    - when you get the error "Exchange account verification failed" - click next then save
    - then edit the profile and uncheck use SSL
    - this got him going but I think we would rather have this user use SSL so I am sure it is an additional port we need to open for now.

    I have had a few 3G buddies on the horn with AT&T because strange ports were blocked, maybe this is similar?
  • dblj79 Level 1 Level 1 (0 points)
    Tried everything suggested here but still no luck. Everyone's input has been very much appreciated. I'll continue to come up with a solution and will post it here when found.
  • Marcel G Level 1 Level 1 (0 points)
    I found out that my problem had to do with the "special" character in my last name. Seams that login does not work when you have an "umlaut" like "ä" "ö" "ü" in your name
    This is quite common in german.

    How can I report this to apple?

    Cheers Marcel

    Message was edited by: Marcel G
Previous 1 2 3 4 Next