Previous 1 2 Next 21 Replies Latest reply: Aug 29, 2008 4:11 PM by KathleenH Go to original post
  • Roger Whiteley Level 1 Level 1 (25 points)
    Hi there, there are several reasons why your iPod might not connect:

    The access point may be configured with MAC address filtering
    You might have put in the wrong SSID or mistyped it
    You are possibly entering the WEP key incorrectly
    The access point / router may not be accurately giving the iPod an IP address, OR there may not be a DHCP server at all and you'll have to give the iPod a Static IP address through the config page on the iPod, make sure you put the correct subnet mask, default gateway and DNS server addresses, otherwise you'll get a connection to the local network but no Internet access.

    There are many reported problems with iPods refusing to connect to certain makes of Wireless Router / Access point on the discussion boards.

    MAC address filtering is often used because WEP is basically insecure and can be cracked, MAC filtering just makes it a bit more difficult, somebody who is serious about hacking your network won't be put off.

    Setting the Access Point SSID broadcast to hidden stops the Access Point transmitting wireless packets which basically say 'Hi I am here and my name is <come and hack me>'. Hiding the SSID merely puts off the curious, not a determined hacker.

    You should check:
    That MAC filtering is disabled
    That the SSID broadcast is enabled, the iPod will find the network more easily
    That whatever is giving out IP addresses on the network (a DHCP server) has not run out of addresses.

    If you can get the touch to associate with the wireless network properly then the DHCP server should give the iPod all the settings necessary to get onto the internet, with a correct subnet mask, yours should be 255.255.255.0 because that's what the PC's have

    If you have V2.0 software on your touch it won't connect to a WEP network, there are lots of posts on this problem on the discussions and it affects iPhones running V2.0 as well.

    A 128bit WEP network will involve typing in the 26 hexadecimal characters of the encryption key, tedious, but I can assure you that a 1.1.4 iPod touch does connect to a 128bit WEP network, at least mine does, the access point is a Linksys WAP54G running version 2.07 software.

    I hope I have explained things well enough, what is going on and how to check it properly needs quite a lot of expertise and I don't know the extent of your IT / networking knowledge.

    I'll see what version 2.0.1 does in about half an hour.
  • Roger Whiteley Level 1 Level 1 (25 points)
    Update - 2.0.1 = bricked ipod and blue screened laptop AGAIN , way to go Apple.........

    Tried new user account approach recommended by others,
    Reinstalled 1.1.5 downloaded direct from Apple, got Wireless working... so getting a bricked iPod operational with a new user profile is a good start if you only have one computer and no easy access to a MAC or an Apple store.

    Tried upgrading to 2.0.1, more blue screens during 'preparing iPod for update' progress bar.
    On reboot, Stopped local software firewall (have two physical firewalls), removed external USB mouse, downloading 2.0.1 upgrade again............. dare I upgrade with Firefox running?

    No difference, string of beeps followed by BLUE SCREEN AGAIN..
  • pap3rcl1p Level 1 Level 1 (0 points)
    ugh.... this is friggin ridiculous....

    ok well.... I tried using the 26 hexidecimal key I found. that didnt work.
    My dad gave me a wireless router to try. so basically we have 3 routers in the house.....

    kitchen has a wrireless router which goes to every room, and in my room a have a non-wifi router, and I hooked up my linksys to that router and I pick the signal from my iPOD but it still wont go on youtube or safari.

    I think that might be a reason why im getting connection prblems. but the main wireless router is the main HUB. so I dunno....

    also the linksys one is not protected. its open but it still don work.
    but it also gives me different stuff too.

    from DHCP it gave me a different IP, (same subnet mask as my desktop), a router IP, and a DNS. we have a workgroup but I'm pretty sure we dont have a domain name.

    If I do static, what should I put in? same stuff as my desktop computer?
    Do I need a domain name?
    and is there anything I can do from my PC that might help?
    I'm gonna ask my dad to help me out.

    I'm also gonna try to install 2.0 if its free.

    Message was edited by: pap3rcl1p
  • pap3rcl1p Level 1 Level 1 (0 points)
    I got it!

    donald was right. It was the 10 digit code on the bottom of the router.

    :P

    Although I did try that before... I must've typed it wrong.

    well thanks for the help guys!

    Message was edited by: pap3rcl1p
  • Roger Whiteley Level 1 Level 1 (25 points)
    Cool I'm glad you got it working....
    If you have three routers there's no wonder you had problems , you should only ever have one DHCP server, unless you have a huge network, that is, the other DHCP servers should be turned off from the router browser interface..

    Configuring DHCP scopes (IP address ranges ) to not overlap is the other solution, but different DHCP server setting could lead to exactly the type of problem you described. Didn't think of that one!!!
  • Voyvodich Level 1 Level 1 (0 points)
    Thank you so much!

    I have just bought a Mac book and got a free Ipod touch with it.
    The mac book worked when I plugged the cable in but didnt when I tried the wireless internet.
    The ipod touch worked on what seemed like every wifi connection but mine.

    But then.... I tried the 10 digit code on the bottom of my 2wire and it fixed both problems, so once again thank you so much.

    Now I need to find out why torrent downloading doesn't work on my mac.
  • KathleenH Level 1 Level 1 (30 points)
    Please which line does the 10 digit code go in? I have been trying to get this to connect for 6 months. At other location with Belkin wireless router it works fine, but not with 2wire modem.
Previous 1 2 Next